Vous recevez des messages d’échec de status de travail dans Data Protection Manager

Cet article vous aide à résoudre un problème dans lequel le travail status messages d’échec se produisent si le composant de surveillance en temps réel d’un programme antivirus est configuré pour surveiller les réplicas et transférer des fichiers journaux pour les volumes protégés par Data Protection Manager.

Version d’origine du produit : System Center Data Protection Manager
Numéro de la base de connaissances d’origine : 928840

Symptômes

Après avoir configuré Microsoft System Center Data Protection Manager pour protéger les données sur un ou plusieurs serveurs de fichiers, vous rencontrez les symptômes suivants :

  • Les serveurs de fichiers contiennent des réplicas incohérents.

  • Lorsque vous utilisez la console Administrateur de Data Protection Manager, vous remarquez que les taux de transfert de données peuvent ralentir de façon aléatoire.

  • Les travaux de réplication de données peuvent échouer sur un ou plusieurs serveurs de fichiers. Dans ce cas, le travail status informations qui ressemblent à ce qui suit sont générées sur les serveurs de fichiers affectés :

    Message d’état 1

    Type : cohérence case activée
    État : Échec
    Description : le service DPM n’a pas pu communiquer avec l’agent de fichier DPM sur le serveur localhost. (Détails de l’ID 52 : le nom de réseau spécifié n’est plus disponible (0x80070040))
    Heure de début : <startTime>
    Temps écoulé : <elapsedTime>
    Données transférées : 118,51 Go (127253828784 octets)
    Taux de transfert de données : 464 Ko/s
    Détails de la source : <Volume> sur <ServerName>
    Membres du groupe de protection : 7
    Détails
    Groupe de protection : <ProtectionGroup>

    Message d’état 2

    Type : Synchronisation
    État : Échec
    Description : la réplica sur le serveur DPM pour <Volume> sur <ServerName> est incohérente. Les modifications ne peuvent pas être appliquées au fichier <FilePath>. (DÉTAILS DE l’ID 109 : Le processus ne peut pas accéder au fichier, car il est utilisé par un autre processus (0x80070020))
    Heure de début : <startTime>
    Temps écoulé : <elapsedTime>
    Données transférées : 1,79 Go (1916715024 octets)
    Taux de transfert de données : 100 Ko/s
    Détails de la source : <Volume> sur <ServerName>
    Membres du groupe de protection : 7
    Détails
    Groupe de protection : <ProtectionGroup>

    Message d’état 3

    Type : Synchronisation
    État : Échec
    Description : la réplica sur le serveur DPM pour <Volume> sur <ServerName> est incohérente. Les modifications ne peuvent pas être appliquées au fichier <FilePath>. (Détails de l’ID 109 : l’accès est refusé (0x80070005))
    Heure de début : <startTime>
    Temps écoulé : <elapsedTime>
    Données transférées : 1,57 Go (1691028040 octets)
    Débit de transfert de données : 207 Ko/s
    Détails de la source : <Volume> sur <ServerName>
    Membres du groupe de protection : 2
    Détails
    Groupe de protection : <ProtectionGroup>

    Message d’état 4

    Type : Synchronisation
    État : Échec
    Description : la réplica sur le serveur DPM pour <Volume> sur <ServerName> est incohérente. Les modifications ne peuvent pas être appliquées au fichier <FilePath>. (Détails de l’ID 109 : le système ne trouve pas le chemin spécifié (0x80070003))
    Heure de début : <startTime>
    Temps écoulé : <elapsedTime>
    Données transférées : 116,74 Mo (122411432 octets)
    Taux de transfert de données : 221 Ko/s
    Détails de la source : <Volume> sur <ServerName>
    Membres du groupe de protection : 2
    Détails Groupe de protection : <ProtectionGroup>

    Remarque

    Vous pouvez également recevoir d’autres messages d’échec status de travail.

  • La synchronisation de Data Protection Manager peut échouer. Dans ce cas, vous recevez status messages qui ressemblent à l’un des suivants :

    Message d’état 1

    Description : Depuis <la date et l’heure>, les travaux de synchronisation pour <le chemin d’accès> sur <ServerName> ont échoué. Nombre total de travaux ayant échoué = 4. Le dernier travail a échoué pour la raison suivante : (ID 3115) DPM n’a pas pu effectuer ce travail dans le temps alloué à l’ensemble des travaux associés à ce groupe de protection. (ID 3151).

    Message d’état 2

    Type : Synchronisation
    État : Échec
    Description : la réplica sur le serveur DPM pour <le chemin d’accès> sur <ServerName> est incohérente. Les modifications ne peuvent pas être appliquées au chemin d’accès et au < nom >de fichier. (Détails de l’ID 109 : l’accès est refusé (0x80070005)
    Heure de début : <date et heure>
    Temps écoulé : <elapsedTime>
    Données transférées : 18,75 Mo (19662648 octets)
    Taux de transfert de données : 83 Ko/s
    Détails de la source : <chemin> sur <ServerName>
    Groupe de protection : <ProtectionGroup>

Cause

Ce problème peut se produire si le composant de surveillance en temps réel d’un programme antivirus est configuré pour surveiller les réplicas et transférer des fichiers journaux pour les volumes protégés par Data Protection Manager. Vous pouvez rencontrer ce problème si le composant de surveillance en temps réel d’un programme antivirus surveille le programme Msdpmfsagent.exe sur le serveur Data Protection Manager.

Résolution

Pour résoudre ce problème, consultez Exécuter un logiciel antivirus sur le serveur DPM.

Plus d’informations

La surveillance en temps réel de l’antivirus des réplicas et des fichiers journaux de transfert diminue les performances dans Data Protection Manager. Ce comportement se produit parce que le processus de surveillance en temps réel oblige le programme antivirus à analyser les journaux de transfert chaque fois que Data Protection Manager se synchronise avec le serveur de fichiers. En outre, le processus de surveillance en temps réel oblige le programme antivirus à analyser tous les fichiers affectés chaque fois que Data Protection Manager applique des modifications aux réplicas.

Nous vous recommandons de configurer le programme antivirus pour supprimer les fichiers infectés des serveurs de fichiers et du serveur Data Protection Manager au lieu d’utiliser la fonctionnalité de mise en quarantaine pour archiver les fichiers infectés. Cela permet d’empêcher l’altération des données des réplicas et des clichés instantanés.

Si un programme antivirus est configuré pour propre et mettre en quarantaine automatiquement un fichier infecté, le programme antivirus modifie le fichier. Toutefois, Data Protection Manager ne peut pas détecter ces modifications apportées au fichier. Lorsque Data Protection Manager tente de synchroniser un réplica qui a été modifié par un autre programme, le réplica et les clichés instantanés du fichier peuvent être endommagés. Pour plus d’informations sur la configuration d’un programme antivirus pour supprimer les fichiers infectés, consultez la documentation du programme ou contactez le fabricant du programme antivirus.