Un client WSUS prend plus de temps que prévu pour terminer une analyse de mise à jour
Cet article vous aide à résoudre un problème où un ordinateur client Microsoft Windows Server Update Services (WSUS) prend plus de temps que prévu pour terminer une analyse afin de déterminer si une mise à jour s’applique à l’ordinateur client.
Version d’origine du produit : Configuration Manager
Numéro de la base de connaissances d’origine : 938947
Symptômes
Prenons l’exemple du scénario suivant :
- Un ordinateur client WSUS est connecté à un serveur WSUS ou Configuration Manager Software Update Services (SUP).
- L’ordinateur client WSUS exécute une analyse pour déterminer si une mise à jour s’applique à l’ordinateur client.
Dans ce scénario, l’ordinateur client WSUS prend plus de temps que prévu pour terminer l’analyse. Par exemple, l’analyse peut prendre des heures ou des jours. En outre, vous rencontrez les problèmes suivants sur l’ordinateur client WSUS :
- Le Gestionnaire des tâches indique une utilisation élevée du processeur pour le processus Svchost.exe.
- Vous ne pouvez pas arrêter le processus Svchost.exe.
Cause
Ce problème se produit si vous ne refusez pas les mises à jour de définition expirées ou les mises à jour malveillantes (également appelées logiciels malveillants) sur le serveur WSUS ou SUP.
Résolution
Pour résoudre ce problème, définissez l’option pour approuver automatiquement les révisions de mise à jour sur le serveur WSUS ou SUP. Définissez également l’option pour refuser les mises à jour expirées sur le serveur.
- Dans la console d’administration WSUS, cliquez sur Options, puis sur Approbations automatiques.
- Sous l’onglet Avancé , assurez-vous que l’option Approuver automatiquement les nouvelles révisions des mises à jour approuvées et Refuser automatiquement les mises à jour lorsqu’une nouvelle révision entraîne leur expiration sont sélectionnées.
- Cliquez sur OK.
Plus d’informations
Par défaut, les options Approuver automatiquement les nouvelles révisions des mises à jour approuvées et Refuser automatiquement les mises à jour lorsqu’une nouvelle révision entraîne leur expiration sont sélectionnées. Si vous décidez de ne pas approuver automatiquement les révisions de mise à jour, le serveur WSUS utilise l’ancienne révision de mise à jour. Dans ce cas, vous devez approuver manuellement la révision de mise à jour.
Remarque
Une révision est une version de mise à jour qui a changé. Par exemple, la version de mise à jour peut avoir expiré ou la version de mise à jour peut avoir des règles d’applicabilité qui ont été mises à jour.
Les paramètres par défaut des options Approuver automatiquement les nouvelles révisions des mises à jour approuvées et Refuser automatiquement les mises à jour lorsqu’une nouvelle révision entraîne leur expiration vous permettent de maintenir de bonnes performances sur le réseau WSUS. Si vous ne souhaitez pas que les mises à jour expirées soient automatiquement refusées, vous pouvez les refuser manuellement. Toutefois, assurez-vous de le faire régulièrement.
Il est recommandé d’exécuter régulièrement l’Assistant propre serveur. Pour plus d’informations, consultez Conseils généraux sur l’optimisation des performances du client WSUS.
Résoudre les problèmes liés aux ordinateurs clients bloqués
Pour résoudre un problème dans lequel un ordinateur client cesse de répondre pendant une analyse de mise à jour, procédez comme suit :
- Sur l’ordinateur client affecté, définissez le type de démarrage du service d’Mises à jour automatique (Wuauserv) sur Désactivé.
- Redémarrez l'ordinateur.
- Supprimez le dossier
%Windir%\SoftwareDistribution
. - Définissez le type de démarrage du service d’Mises à jour automatique sur Automatique, puis démarrez le service d’Mises à jour automatique.
Commentaires
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