Auf einem Windows Server 2003-basierten Computer, auf dem der Volumeschattenkopie-Dienst ausgeführt wird, können verschiedene Probleme auftreten.

In diesem Artikel werden Probleme beschrieben, bei denen die Ereignis-ID 8019, 20, 8193 oder 12302 im Anwendungsprotokoll protokolliert wird. Sie erhalten eine Fehlermeldung vom 0x8004230F oder 0x80004002.

Gilt für: Windows Server 2003
Ursprüngliche KB-Nummer: 940032

Symptome

Auf einem Microsoft Windows Server 2003-basierten Computer, auf dem der Volumeschattenkopie-Dienst (Volume Shadow Copy Service, VSS) ausgeführt wird, tritt eines der folgenden Symptome auf:

  • Wenn Sie einen Sicherungsvorgang mit dem NTBackup-Tool ausführen, wird das folgende Ereignis im Anwendungsprotokoll protokolliert:

    Ereignistyp: Fehler
    Ereignisquelle: NTBackup
    Ereignis-ID: 8019
    Beschreibung: Vorgang beenden: Warnungen oder Fehler sind aufgetreten. Weitere Informationen finden Sie im Sicherungsbericht.

    Hinweis

    Wenn Sie die Sicherungsprotokolldatei anzeigen, werden die folgenden Informationen angezeigt:

    Fehler beim Erstellen der Volumeschattenkopie:0xffffffff

  • Wenn Sie auf die Eigenschaften eines Volumes zugreifen und dann auf Schattenkopien klicken, wird eine der folgenden Fehlermeldungen angezeigt:

    Fehler 0x8004230F: Beim Versuch, den angegebenen Vorgang zu verarbeiten, ist beim Schattenkopieanbieter ein unerwarteter Fehler aufgetreten.

    Fehler 0x80004002: Diese Schnittstelle wird nicht unterstützt.

  • Eines der folgenden Ereignisse wird im Anwendungsprotokoll protokolliert:

    Ereignistyp: Fehler
    Ereignisquelle: VSS
    Ereignis-ID: 20
    Beschreibung: Volumeschattenkopie-Dienstfehler: Eine kritische Komponente, die für den Volumeschattenkopie-Dienst erforderlich ist, ist nicht registriert. Dies kann passieren, wenn während des Windows-Setups oder während der Installation eines Schattenkopieanbieters ein Fehler aufgetreten ist. Der von CoCreateInstance für die Klasse zurückgegebene Fehler mit CLSID {faf53cc4-bd73-4e36-83f1-2b23f46e513e} und Name VSSEvent ist [0x80040154].

    Ereignistyp: Fehler
    Ereignisquelle: VSS
    Ereignis-ID: 20
    Beschreibung: Volumeschattenkopie-Dienstfehler: Eine kritische Komponente, die für den Volumeschattenkopie-Dienst erforderlich ist, ist nicht registriert. Dies kann passieren, wenn während des Windows-Setups oder während der Installation eines Schattenkopieanbieters ein Fehler aufgetreten ist. Der von CoCreateInstance für die Klasse zurückgegebene Fehler mit CLSID {faf53cc4-bd73-4e36-83f1-2b23f46e513e} und Name VSSEvent ist [0x80004002].

    Ereignistyp: Fehler
    Ereignisquelle: VSS
    Ereignis-ID: 8193
    Beschreibung: Fehler des Volumeschattenkopie-Diensts: Unerwarteter Fehler beim Aufrufen der Routine "CoCreateInstance". hr = 0x80040154.

    Ereignistyp: Fehler
    Ereignisquelle: VSS
    Ereigniskategorie: Keine
    Ereignis-ID: 8193
    Beschreibung: Fehler des Volumeschattenkopie-Diensts: Unerwarteter Fehler beim Aufrufen der Routine "CoCreateInstance". hr = 0x80004002.

    Ereignistyp: Fehler
    Ereignisquelle: VSS
    Ereignis-ID: 12302
    Beschreibung: Fehler des Volumeschattenkopie-Diensts: Beim Versuch, Schattenkopiedienst-Writer zu kontaktieren, wurde eine interne Inkonsistenz erkannt. Überprüfen Sie, ob der Ereignisdienst und der Volumeschattenkopiedienst ordnungsgemäß funktionieren.

Ursache

Dieses Problem tritt auf, weil die VSS-Systemdateien nicht registriert sind.

Lösung

Hinweis

Dieser Artikel ist nicht für die Verwendung mit Windows Vista, Windows Server 2008 oder höheren Betriebssystemen vorgesehen. Ab Windows Vista und Windows Server 2008 ist die Installation der Windows-Komponente manifestbasiert. Wenn Sie versuchen, bestimmte Komponenten manuell zu registrieren, z. B. die in diesem Abschnitt "Lösung" beschriebenen Komponenten, können in den in diesem Hinweis erwähnten Betriebssystemen unerwartete Ergebnisse auftreten, die möglicherweise eine Neuinstallation von Windows erfordern, um die Behebung zu beheben.

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:

  1. Klicken Sie auf Start und auf Ausführen, geben Sie „cmd“ ein, und klicken Sie dann auf OK.

  2. Geben Sie die folgenden Befehle an einer Eingabeaufforderung ein. Drücken Sie die EINGABETASTE, nachdem Sie die einzelnen Befehle eingegeben haben.

    • cd /d %windir%\system32
    • Net stop vss
    • Net stop swprv
    • regsvr32 ole32.dll
    • regsvr32 oleaut32.dll
    • regsvr32 vss_ps.dll
    • vssvc /register
    • regsvr32 /i swprv.dll
    • regsvr32 /i eventcls.dll
    • regsvr32 es.dll
    • regsvr32 stdprov.dll
    • regsvr32 vssui.dll
    • regsvr32 msxml.dll
    • regsvr32 msxml3.dll
    • regsvr32 msxml4.dll

    Hinweis

    Der letzte Befehl wird möglicherweise nicht erfolgreich ausgeführt.

  3. Führen Sie einen Sicherungsvorgang aus, um zu überprüfen, ob das Problem behoben wurde.

Weitere Informationen

Schritte zum Reproduzieren dieses Problems

  1. Geben Sie den folgenden Befehl an einer Eingabeaufforderung ein. Drücken Sie die EINGABETASTE, nachdem Sie den Befehl eingegeben haben.

    regsvr32 /u swprv.dll
    
  2. Versuchen Sie, einen Sicherungsvorgang auszuführen.