Erreur 0x8000FFFF lorsque vous exécutez la commande vssadmin list writers sur un ordinateur Windows Server 2003

Cet article résout un problème qui se produit lorsque vous utilisez la vssadmin list writers commande sur un ordinateur Windows Server 2003. lorsque le problème se produit, vous pouvez recevoir un message d’erreur, un événement ou la liste peut être vide.

Produit concerné : Windows Server 2003
Numéro de la base de connaissances d’origine : 940184

Symptômes

Lorsque vous exécutez la vssadmin list writers commande sur un ordinateur Windows Server 2003, vous pouvez rencontrer l’un des symptômes suivants.

Remarque

La vssadmin list writers commande répertorie les enregistreurs de clichés instantanés de volume abonnés.

  • Le message d’erreur suivant s’affiche :

    Erreur : 0x8000FFFF

  • L’événement suivant peut être enregistré dans le journal des applications :

    Type d'événement : Erreur
    Source de l’événement : VSS
    ID d’événement : 12302
    Description : Erreur du service de cliché instantané de volume : une incohérence interne a été détectée lors de la tentative de contact avec les rédacteurs du service de cliché instantané. Veuillez case activée pour vérifier que le service d’événements et le service de cliché instantané de volume fonctionnent correctement.

  • La liste est vide.

Cause

Ce problème peut se produire si la clé de Registre suivante est endommagée :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EventSystem\{26c409cc-ae86-11d1-b616-00805fc79216}\Subscriptions

Résolution

Importante

Cet article n’est pas destiné à être utilisé avec Windows Vista, Windows Server 2008 ou avec des systèmes d’exploitation Windows ultérieurs. À compter de Windows Vista et de Windows Server 2008, l’installation des composants Windows est basée sur un manifeste. La tentative d’inscription manuelle de composants spécifiques, comme décrit dans les étapes suivantes, peut avoir des résultats inattendus qui peuvent nécessiter la réinstallation de Windows pour résoudre le problème.

Pour résoudre ce problème, procédez comme suit :

  1. Cliquez sur Démarrer>l’exécution, tapez Regedit, puis cliquez sur OK.

  2. Recherchez la sous-clé de Registre suivante, puis cliquez dessus :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EventSystem\{26c409cc-ae86-11d1-b616-00805fc79216}\Subscriptions

  3. Dans le menu Modifier , cliquez sur Supprimer, puis sur Oui pour confirmer que vous souhaitez supprimer la sous-clé.

  4. Fermez l’Éditeur du Registre.

  5. Cliquez sur Démarrer>l’exécution, tapezservices.msc, puis cliquez sur OK.

  6. Cliquez avec le bouton droit sur les services suivants un par un. Pour chaque service, cliquez sur Redémarrer :

    • Système d’événements COM +
    • Application système COM+
    • Fournisseur de clichés instantanés logiciels Microsoft
    • Cliché instantané des volumes
  7. Cliquez sur Démarrer>l’exécution, tapez cmd, puis cliquez sur OK.

  8. À l’invite de commandes, tapez vssadmin list writers, puis appuyez sur Entrée.

  9. Si les enregistreurs VSS sont maintenant répertoriés, fermez la fenêtre d’invite de commandes. Vous n’avez pas besoin d’effectuer les étapes restantes.

    Si les enregistreurs VSS ne sont pas répertoriés, tapez les commandes suivantes à l’invite de commandes. Appuyez sur Entrée après chaque commande.

    • cd /d %windir%\system32
    • net stop vss
    • net stop swprv
    • regsvr32 ole32.dll
    • regsvr32 oleaut32.dll
    • regsvr32 /i eventcls.dll
    • regsvr32 vss_ps.dll
    • vssvc /register
    • regsvr32 /i swprv.dll
    • regsvr32 es.dll
    • regsvr32 stdprov.dll
    • regsvr32 vssui.dll
    • regsvr32 msxml.dll
    • regsvr32 msxml3.dll
    • regsvr32 msxml4.dll

    Remarque

    La dernière commande peut ne pas s’exécuter correctement.

  10. À l’invite de commandes, tapez vssadmin list writers, puis appuyez sur Entrée.

  11. Vérifiez que les enregistreurs VSS sont désormais répertoriés.

Cela a-t-il résolu le problème ?

Vérifiez si le problème est résolu. Si le problème est résolu, vous en avez terminé avec cette section. Si le problème n’est pas résolu, vous pouvez contacter le support technique.