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Symptoms

In an Active Directory directory service domain environment, you configure the Internet Explorer Maintenance Group Policy settings. A user logs on to the domain from a Windows XP-based, a Windows Server 2003-based, or Windows Vista-based client computer that has Internet Explorer 7 or Internet Explorer 8 installed. However, the user experiences a 20-second logon delay compared with a client computer that has Internet Explorer 6 installed.

Note You may experience a similar delay while trying to establish a Terminal Services or a Remote Desktop Services session.

To verify this delay, you can view the contents of the Branding log file (Brndlog.txt) for Internet Explorer Maintenance.

Note The Brndlog.txt file is in the following folder:

%UserProfile%\Local Settings\Application Data\Microsoft\Internet ExplorerIn the Branding log file, you may see the information that resembles the following: 10/25/2007 10:36:37 Refreshing browser settings...
10/25/2007 10:36:37 Broadcasting "Windows settings change" to all top level windows...
10/25/2007 10:36:57 Done.
This sample shows that a 20-second delay occurs in the following phase:

Broadcasting "Windows settings change" to all top level windows

Cause

Internet Explorer 7 introduced an error that causes this problem. This error occurs when Internet Explorer 7 or Internet Explorer 8 parses command line parameters.

Resolution

Hotfix information

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 installed on the client computer.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information


This hotfix does not replace any other previously released hotfixes.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in WindowsTo enable this hotfix, follow these steps:

  1. Click Start, click Run, type regedit, and then press ENTER.

  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl

  3. On the Edit menu, point to New, and then click Key.

  4. Type the following name, and then press ENTER:

    FEATURE_PARSING_BRANDING_CMDLINE_FLAGS_KB941158Note We recommend that you type this value. Please remove trailing spaces if you plan to copy and paste this registry value.

  5. On the Edit menu, point to New, and then click DWORD Value.

  6. Type the asterisk symbol (*), and then press ENTER.

  7. On the Edit menu, click Modify.

  8. Type 1, and then click OK.

  9. Exit Registry Editor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Internet Explorer 7 on Windows XP, x86-based versions

File name

File version

File size

Date

Time

Platform

iedkcs32.dll

17.0.6000.20668

387,584

28-Aug-2007

17:29

x86



Internet Explorer 8 on Windows XP, x86-based versions

File name

File version

File size

Date

Time

Platform

iedkcs32.dll

18.0.6001.22918

387,584

29-Aug-2009

5:17

x86

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 2 installed on the client computer.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information


This hotfix does not replace any other previously released hotfixes.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in Windows

To enable this hotfix, follow these steps:

  1. Click Start, click Run, type regedit, and then press ENTER.

  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl

  3. On the Edit menu, point to New, and then click Key.

  4. Type the following name, and then press ENTER:

    FEATURE_PARSING_BRANDING_CMDLINE_FLAGS_KB941158

  5. On the Edit menu, point to New, and then click DWORD Value.

  6. Type the asterisk symbol (*), and then press ENTER.

  7. On the Edit menu, click Modify.

  8. Type 1, and then click OK.

  9. Exit Registry Editor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Internet Explorer 7 on Windows Server 2003, x86-based versions

File name

File version

File size

Date

Time

Platform

iedkcs32.dll

17.0.6000.20668

387,584

29-Aug-2007

07:21

x86



Internet Explorer 8 on Windows Server 2003, x86-based versions

File name

File version

File size

Date

Time

Platform

iedkcs32.dll

18.0.6001.22918

387,584

31-Aug-2009

10:08

x86



Internet Explorer 7 on Windows Server 2003, x64-based versions

File name

File version

File size

Date

Time

Platform

SP requirement

Service branch

iedkcs32.dll

17.0.6000.20668

479,744

29-Aug-2007

08:02

x64

SP2

Not Applicable

Wiedkcs32.dll

17.0.6000.20668

387,584

29-Aug-2007

08:02

x86

SP2

WOW



Internet Explorer 8 on Windows Server 2003, x64-based versions

File name

File version

File size

Date

Time

Platform

iedkcs32.dll

18.0.6001.22918

387,584

31-Aug-2009

10:18

x64

Windows Vista service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

Windows Vista hotfix information

You may not experience the 20-second delay on a Windows Vista-based client computer. However, the error exists in Internet Explorer 7, regardless of the operating system. Therefore, we recommend that you apply the hotfix on a Windows Vista-based computer.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information


This hotfix does not replace any other previously released hotfixes.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in Windows

To enable this hotfix, follow these steps:

  1. Click Start, type regedit in the Start Search box, and then press ENTER.

  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl

  3. On the Edit menu, point to New, and then click Key.

  4. Type the following name, and then press ENTER:

    FEATURE_PARSING_BRANDING_CMDLINE_FLAGS_KB941158

  5. On the Edit menu, point to New, and then click DWORD Value.

  6. Type the asterisk symbol (*), and then press ENTER.

  7. On the Edit menu, click Modify.

  8. Type 1, and then click OK.

  9. Exit Registry Editor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Internet Explorer 7 on Windows Vista, 32-bit versions

File name

File version

File size

Date

Time

Platform

Update.mum

Not Applicable

1,799

23-Aug-2007

16:27

Not Applicable

X86_dbdfdc1ce64e1c55cd027e2558b71669_31bf3856ad364e35_6.0.6000.20666_none_5cfffc5ca5285acc.manifest

Not Applicable

707

23-Aug-2007

16:27

Not Applicable

X86_microsoft-windows-ie-adminkitbranding_31bf3856ad364e35_6.0.6000.20666_none_72b8eaec739f840f.manifest

Not Applicable

15,306

23-Aug-2007

16:27

Not Applicable

iedkcs32.dll

17.0.6000.20666

387,584

23-Aug-2007

02:09

x86



Internet Explorer 8 on Windows Vista and on Windows Server 2008

File name

File version

File size

Date

Time

Platform

iedkcs32.dll

18.0.6001.22917

387,584

25-Aug-2009

7:27

x86

Windows 7 and Windows Server 2008 R2 hotfix information

You may not experience the 20-second delay on a Windows 7 or Windows Server 2008 R2-based computer. However, the error exists in Internet Explorer, regardless of the operating system. Therefore, we recommend that you apply the hotfix on a Windows 7 or Windows Server 2008 R2-based computer.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information


This hotfix does not replace any other previously released hotfixes.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in WindowsTo enable this hotfix, follow these steps:

  1. Click Start, type regedit in the Start Search box, and then press ENTER.

  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl

  3. On the Edit menu, point to New, and then click Key.

  4. Type the following name, and then press ENTER:

    FEATURE_PARSING_BRANDING_CMDLINE_FLAGS_KB941158

  5. On the Edit menu, point to New, and then click DWORD Value.

  6. Type the asterisk symbol (*), and then press ENTER.

  7. On the Edit menu, click Modify.

  8. Type 1, and then click OK.

  9. Exit Registry Editor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Internet Explorer 8 on Windows 7 and on Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Iedkcs32.dll

18.0.7600.20598

381,440

17-Dec-2009

07:27

x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

More Information

To configure the Internet Explorer Maintenance Group Policy settings, following these steps:

  1. Open the Active Directory Users and Computers MMC snap-in, right-click the organizational unit to which you want to apply the Internet Explorer Maintenance Group Policy settings, and then click Properties.

  2. In the Group Policy tab, click Add, and then click Edit to open Group Policy Object Editor.

  3. In the Group Policy Object Editor, expand User Configuration, expand Windows Settings, expand Internet Explorer Maintenance, and then configure the Internet Explorer Maintenance Group Policy settings.

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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