Die durch den Anmeldefehler angeforderte Datenbank kann nicht geöffnet werden, wenn Sie sich bei Microsoft Dynamics CRM

In diesem Artikel finden Sie eine Lösung für das Problem, dass bei der Anmeldung bei Microsoft Dynamics CRM möglicherweise eine Datenbank "Organization_MSCRM kann nicht geöffnet werden" angezeigt wird, die durch den Anmeldefehler angefordert wurde.

Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 946286

Problembeschreibung

Sie installieren Microsoft Dynamics CRM. Wenn Sie versuchen, sich bei Microsoft Dynamics CRM anzumelden, wird die folgende Fehlermeldung angezeigt:

Die von der Anmeldung angeforderte Datenbank "Organization_MSCRM" kann nicht geöffnet werden.
Fehler bei der Anmeldung. Fehler bei der Anmeldung für den Benutzer "NT AUTHORITY\NETWORK SERVICE".

Wenn der DevErrors-Wert in der Web.config Datei auf Ein festgelegt ist, erhalten Sie eine Fehlermeldung, die der folgenden ähnelt:

Serverfehler in der Anwendung "/".

Die vom Anmeldenamen angeforderte Datenbank "MSCRM_CONFIG" kann nicht geöffnet werden. Fehler bei der Anmeldung.
Fehler bei der Anmeldung für den Benutzer "Domain\CRMServer$".
Beschreibung: Während der Ausführung der aktuellen Webanforderung ist eine Ausnahme ohne Behandlung aufgetreten. Weitere Informationen zu dem Fehler und dessen Ursprung im Code finden Sie in der Stapelüberwachung.

Ausnahmedetails: System.Data.SqlClient.SqlException: Die von der Anmeldung angeforderte Datenbank "MSCRM_CONFIG" kann nicht geöffnet werden. Fehler bei der Anmeldung. Fehler bei der Anmeldung für den Benutzer "Domain\CRMServer$".

Quellfehler:

Während der Ausführung der aktuellen Webanforderung wurde eine Ausnahme generiert, die nicht behandelt wurde. Informationen zum Ursprung und Speicherort der Ausnahme können mithilfe der nachstehenden Ausnahmestapelablaufverfolgung identifiziert werden.

Stapelüberwachung:

[SqlException (0x80131904): Die von der Anmeldung angeforderte Datenbank "MSCRM_CONFIG" kann nicht geöffnet werden. Fehler bei der Anmeldung.

Fehler bei der Anmeldung für den Benutzer "Domain\CRMServer$".]

System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject) +437
System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection) +82
System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory) +105
System.Data.SqlClient.SqlConnection.Open() +111
Microsoft.Crm.CrmDbConnection.Open() +386
Microsoft.Crm.SharedDatabase.DatabaseMetadata.LoadMetadataXmlFromDatabase(CrmDBConnectionType connectionType, String connectionString, Int32& maxBlobSize) +125
Microsoft.Crm.SharedDatabase.DatabaseMetadata.LoadCacheFromDatabase(CrmDBConnectionType connectionType, String connectionString) +65
Microsoft.Crm.ConfigurationDatabase.ConfigurationMetadata.LoadCache() +41
Microsoft.Crm.ConfigurationDatabase.ConfigurationMetadata.get_Cache() +114
Microsoft.Crm.ConfigurationDatabase.ConfigurationDatabaseService.InitializeMetadataCache() +28
Microsoft.Crm.SharedDatabase.DatabaseService.Initialize(String tableName) +53
Microsoft.Crm.SharedDatabase.DatabaseService.Retrieve(String tableName, String[] columns, PropertyBag[] conditions) +109
Microsoft.Crm.ServerLocatorService.GetSiteSettingIdFromDatabase() +155
Microsoft.Crm.ServerLocatorService.GetSiteSettingId() +187
Microsoft.Crm.ServerLocatorService.GetSiteSetting(String settingName) +82
Microsoft.Crm.LocatorService.GetSiteSetting(String settingName) +35
Microsoft.Crm.CrmTrace.get_RefreshTrace() +654
Versionsinformationen: Microsoft .NET Framework Version:2.0.50727.832; ASP.NET Version:2.0.50727.832

Ursache

Dieses Problem tritt auf, wenn mindestens eine der folgenden Bedingungen zutrifft:

  • Sie installieren Microsoft Dynamics CRM in einer Umgebung mit mehreren Servern. Anschließend installieren Sie Microsoft Dynamics CRM direkt auf einem Server, auf dem Microsoft SQL Server ausgeführt wird. Einige SQL Server Berechtigungen sind jedoch nicht festgelegt.
  • Der Microsoft Dynamics CRM Server wird der Gruppe SQLAccessGroup im Active Directory-Verzeichnisdienst nicht hinzugefügt.

Lösung

Verwenden Sie eine oder mehrere der folgenden Methoden, um dieses Problem zu beheben.

Methode 1

Richten Sie das KONTO NT AUTHORITY\NETWORK SERVICE als SQL Server Benutzer ein, der Zugriff auf die Microsoft Dynamics CRM Datenbanken hat. Gehen Sie dazu wie folgt vor:

  1. Wählen Sie Start aus, zeigen Sie auf Alle Programme, zeigen Sie auf Microsoft SQL Server 2005, und wählen Sie dann SQL Management Studio aus.

    Hinweis

    Für Dynamics CRM 2011 ist es Microsoft SQL Server 2008.

  2. Klicken Sie auf OK, um sich bei SQL Server Management Studio anzumelden.
  3. Erweitern Sie in Objekt-Explorer Datenbanken, erweitern Sie die Organization_MSCRM Datenbank, und erweitern Sie dann Sicherheit.
  4. Klicken Sie mit der rechten Maustaste auf Benutzer, und wählen Sie dann Neuer Benutzer aus.
  5. Geben Sie im Dialogfeld Datenbankbenutzer – Neu den Namen NT AUTHORITY\NETWORK SERVICE in die folgenden Felder ein:
    • Das Feld Benutzername .
    • Das Feld Anmeldename .
  6. Aktivieren Sie im Bereich Mitgliedschaft der Datenbankrolle das Kontrollkästchen db_owner , und klicken Sie dann auf OK.

Methode 2

Fügen Sie den Microsoft Dynamics CRM-Server der Gruppe SQLAccessGroup in Active Directory hinzu. Gehen Sie dazu wie folgt vor:

  1. Wählen Sie Start aus, wählen Sie Ausführen aus, geben Sie dsa.msc ein, und wählen Sie dann OK aus.
  2. Wählen Sie die Organisationseinheit aus, in der Sie Microsoft Dynamics CRM installieren.
  3. Doppelklicken Sie auf SQLAccessGroup.
  4. Wählen Sie im Dialogfeld SQLAccessGroup die Option Mitglieder, dann Hinzufügen und Objekttypen aus, aktivieren Sie das Kontrollkästchen Computer , und wählen Sie dann OK aus.
  5. Geben Sie im Feld Geben Sie die auszuwählenden Objektnamen ein den Namen des Microsoft Dynamics CRM-Servers ein, und wählen Sie dann Namen überprüfen aus.
  6. Vergewissern Sie sich, dass der Name des Microsoft Dynamics CRM Servers im Feld Geben Sie die zu markierenden Objektnamen ein, und wählen Sie dann zweimal OK aus.
  7. Starten Sie den Microsoft Dynamics CRM Server neu.