ワークグループのメンバーである別の Windows Vista ベースのコンピューターから Windows Vista ベースのコンピューター上の管理共有にアクセスしようとするとエラーが発生しました:ログオンに失敗しました:Windows でログオンできません

この記事では、ワークグループのメンバーである別の Windows Vista ベースのコンピューターから Windows Vista ベースのコンピューター上の管理共有にアクセスしようとすると、ログオンが失敗する動作について説明します。

適用対象: Windows Vista
元の KB 番号: 947232

サービス パックがインストールされていない Windows Vista のサポートは、2010 年 4 月 13 日に終了しました。 Windows のセキュリティ更新プログラムを引き続き受け取る場合は、Service Pack 2 (SP2) で Windows Vista を実行していることを確認してください。 詳細については、「Microsoft Web ページ: 一部のバージョンの Windows でサポートが終了する」を参照してください。

エラー メッセージの説明

次のような状況で問題が発生します。

  • ワークグループのメンバーである Windows Vista ベースのコンピューターで作業します。
  • このコンピューターから、別の Windows Vista ベースのコンピューターにある管理共有にアクセスしようとします。
  • アクセスしようとしているコンピューターは、ワークグループのメンバーまたはドメインのメンバーです。 たとえば、C$ 管理共有にアクセスしようとするとします。
  • ユーザー資格情報の入力を求められたら、移行先コンピューターの管理ユーザー アカウントのユーザー資格情報を指定します。

このとき、次のエラー メッセージが表示されます。

ログオンに失敗しました:
Windows でログオンできません。
ユーザー名とパスワードが正しいことを確認します。

Net Use コマンドを使用してネットワーク ドライブを管理共有にマップしようとすると、正しい資格情報を指定した後に次のエラー メッセージが表示されます。

システム エラー 5
が発生しました。 アクセスが拒否されました。

原因

既定では、Windows Vista 以降のバージョンの Windows では、ローカル アカウントがネットワーク経由で管理共有にアクセスできなくなります。

解決方法

ユーザーがアクセスできるようにするには、適切なアクセス許可を使用して、Windows Vista ベースのコンピューターに共有を作成することをお勧めします。 何らかの理由でこの解決策を適用できない場合は、 回避策を試してみてください。

ファイル共有が有効になっている Windows Vista ベースのコンピューターでフォルダーを共有するには、次の手順に従います。

  1. [コンピューターの起動]> をクリックします

  2. 共有するフォルダーを見つけます。

  3. 共有するフォルダーを右クリックし、[ 共有] をクリックします。

  4. パスワードで保護された共有を有効にしている場合は、共有フォルダーとそのアクセス許可レベルにアクセスできるユーザーを選択します。 すべてのユーザーがアクセスできるようにするには、ユーザーの一覧で [ すべてのユーザー ] を選択します。 既定では、アクセス許可レベルは "閲覧者" です。このアクセス許可レベルを持つユーザーは、ファイルを変更したり、共有に新しいファイルを作成したりすることはできません。 ユーザーがファイルを変更したり、フォルダーを変更したり、新しいファイルを作成したり、新しいフォルダーを作成したりするには、"共同所有者" アクセス許可レベルを使用します。

    パスワードで保護された共有が無効になっている場合は、 ゲスト アカウントまたは Everyone アカウントを選択します。 これは、Windows XP での単純な共有と同じです。

  5. [完了の共有>] をクリックします

回避策

Windows のワークグループで管理共有アクセスを許可するには、次の回避策を使用します。

重要

このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 レジストリを変更する際には十分に注意してください。 保護を強化するため、レジストリを変更する前にレジストリをバックアップします。 こうしておけば、問題が発生した場合にレジストリを復元できます。 レジストリのバックアップ方法および復元方法の詳細を参照するには、以下のサポート技術情報番号をクリックしてください。

322756 Windows でレジストリをバックアップおよび復元する方法

  1. [スタート] をクリックし、[検索の開始] ボックスに「regedit」と入力し、Enter キーを押します。

    注:

    管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力して [OK] をクリックし、確認を要求するダイアログ ボックスが表示された場合は [続行] をクリックします。

  2. 次のレジストリ サブキーを見つけてクリックします。

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

  3. [ 編集 ] メニューの [ 新規] をポイントし、[ DWORD (32 ビット) 値] をクリックします。

  4. LocalAccountTokenFilterPolicy と入力して新しいエントリに名前を付け、Enter キーを押します。

  5. [LocalAccountTokenFilterPolicy] を右クリックし、[変更] をクリックします。

  6. [値のデータ] ボックスに「 1」と入力し、[OK] をクリックします。

  7. レジストリ エディターを終了します。

レジストリの LocalAccountTokenFilterPolicy エントリの値は 0 または 1 です。 これらの値は、エントリの動作を次のように設定します。

  • 0 = フィルター処理されたトークンを構築する

これが既定値です。 管理者の資格情報が削除されます。 これらの資格情報は、印刷ドライバーのリモート管理に必要です。

  • 1 = 昇格されたトークンを構築する

この値を使用すると、ワークグループ内のサーバー上の印刷ドライバーをリモートで管理できます。

問題が解決されたかどうかの確認

問題が解決されたかどうかを確認します。 修正された場合は、この記事を完了しました。 修正されていない場合は、サポートにお問い合わせください。

状態

この動作は仕様です。

詳細

移行先の Windows Vista ベースのコンピューターと、管理共有にアクセスするコンピューターが同じドメイン上にある場合は、ドメイン管理者の資格情報を使用して共有にアクセスできます。

移行先の Windows Vista ベースのコンピューターがドメインに参加していて、ワークグループに参加しているコンピューターを使用して接続しようとすると、この管理共有にアクセスできません。 これは、移行先のコンピューターが配置されているドメインに対して正しいドメイン管理者の資格情報を指定した場合でも当てはまります。

Windows Vista でフォルダーまたはプリンターを共有する方法の詳細については、次の Microsoft Web サイトを参照してください。

Windows Vista でのファイルとプリンターの共有