Druckerspooler stürzt möglicherweise zufällig auf einem Windows Server-Computer ab, auf dem ein HP-Drucker installiert ist

Dieser Artikel bietet eine Lösung für ein Problem, bei dem der Druckerspooler zufällig auf einem Windows Server-Computer abstürzt, auf dem ein HP-Drucker installiert ist.

Gilt für: Windows Server 2012 R2
Ursprüngliche KB-Nummer: 947477

Symptome

Auf einem Windows Server-basierten Computer, auf dem ein HP-Drucker installiert ist, stürzt der Druckerspooler möglicherweise nach dem Zufallsprinzip ab.

Ursache

Dieses Problem tritt aufgrund einer der folgenden Dateien auf:

  • Hpbmmon.dll (HP Master Monitor)
  • Hpzpi4wm.dll (HP Print Processor)
  • Hpzpp4wm.dll (HP Print Processor)
  • HPtcpMon.dll (HP TCP-Portmonitor)

Lösung

Wenden Sie sich an den Drittanbieter, um dieses Problem zu beheben.

Wichtig

Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Für zusätzlichen Schutz sichern Sie die Registrierung, bevor Sie sie ändern. Sie können die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie unter Sichern und Wiederherstellen der Registrierung in Windows.

Problemumgehung für das durch Hpbmmon.dll verursachte Problem

Entfernen Sie den HP Master Monitor, um dieses Problem zu umgehen. Gehen Sie dazu wie folgt vor:

  1. Starten Sie den Registrierungs-Editor.

  2. Suchen Sie den Registrierungsunterschlüssel, und klicken Sie dann auf den Registrierungsunterschlüssel HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\HP Master Monitor.

  3. Klicken Sie im Menü Datei auf Exportieren.

  4. Geben Sie im Feld Dateiname den Namen HPprinter ein, und klicken Sie dann auf Speichern.

    Hinweis

    Wenn Sie diesen Registrierungsunterschlüssel wiederherstellen möchten, doppelklicken Sie auf die HPprinter.reg Datei, die Sie in diesem Schritt speichern.

  5. Klicken Sie mit der rechten Maustaste auf den Registrierungseintrag HP Master Monitor , und klicken Sie dann auf Löschen.

  6. Klicken Sie auf Ja.

  7. Beenden Sie den Registrierungs-Editor, und starten Sie den Computer anschließend neu.

  8. Benennen Sie die Hpbmmon.dll-Datei in Hpbmmon.old um. Die Datei befindet sich am Speicherort C:\WINDOWS\system32\Hpbmmon.dll Datei.

Problemumgehung für das Durch Hpzpi4wm.dll oder Hpzpp4wm.dll verursachte Problem

Hinweis

Wenn dieser Drucker nicht mit WinPrint funktioniert, funktionieren die folgenden Schritte möglicherweise nicht. Wenden Sie sich in diesem Fall an HP, um den HPZPP4WM Druckprozessor auf die neuere Version zu aktualisieren.

  1. Klicken Sie auf Start und dann auf Systemsteuerung.
  2. Doppelklicken Sie auf Drucker und Faxe.
  3. Klicken Sie mit der rechten Maustaste auf den Drucker, den Sie verwenden möchten, und klicken Sie dann auf Eigenschaften.
  4. Klicken Sie auf die Registerkarte Erweitert und dann auf Druckprozessor.
  5. Klicken Sie im Feld Druckprozessor auf WinPrint, klicken Sie im Feld Standarddatentyp auf RAW, und klicken Sie dann zweimal auf OK.
  6. Benennen Sie die Hpzpi4wm.dll-Datei in Hpzpi4wm.old um. Die Datei befindet sich am Speicherort: C:\WINDOWS\system32\spool\drivers\w32x86\3\Hpzpi4wm.dll.
  7. Benennen Sie die Hpzpp4wm.dll-Datei in Hpzpp4wm.old um. Die Datei befindet sich am Speicherort: C:\WINDOWS\system32\spool\PRTPROCS\W32X86\Hpzpp4wm.dll.

Problemumgehung für das durch HPtcpMon.dll verursachte Problem

  1. Starten Sie den Registrierungs-Editor.

  2. Klicken Sie auf den folgenden Registrierungsunterschlüssel: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\HP Standard TCP/IP Port

  3. Klicken Sie im Menü Datei auf Exportieren.

  4. Geben Sie im Feld Dateiname den NamenHPprinter ein, und klicken Sie dann auf Speichern.

    Hinweis

    Wenn Sie diesen Registrierungsunterschlüssel wiederherstellen möchten, doppelklicken Sie auf die HPprinter.reg Datei, die Sie in diesem Schritt speichern.

  5. Klicken Sie mit der rechten Maustaste auf den Registrierungseintrag HP Standard TCP/IP-Port , und klicken Sie dann auf Löschen.

  6. Klicken Sie auf Ja.

  7. Suchen Sie den Registrierungsunterschlüssel, und klicken Sie dann auf den Registrierungsunterschlüssel HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Standard TCP/IP Port.

  8. Doppelklicken Sie auf Treiber, und überprüfen Sie dann, ob der Wert des Felds Werttcpmon.dllist.

    Hinweis

    Wenn der Registrierungseintrag Driver nicht vorhanden ist oder sein Wert nicht tcpmon.dll ist, erstellen Sie den Registrierungseintrag Driver , und legen Sie dann seinen Wert auf tcpmon.dll fest. Gehen Sie dazu wie folgt vor:

    1. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie dann auf Zeichenfolgenwert.
    2. Geben Sie Driver ein, und drücken Sie dann die EINGABETASTE.
    3. Klicken Sie mit der rechten Maustaste auf Treiber, und klicken Sie dann auf Ändern.
    4. Geben Sie im Feld Wertdaten tcpmon.dll ein, und klicken Sie dann auf OK.
  9. Beenden Sie den Registrierungs-Editor, und starten Sie den Computer anschließend neu.

  10. Benennen Sie die HPtcpMon.dll-Datei in HPtcpMon.old um. Die Datei befindet sich am Speicherort: C:\WINDOWS\system32\HPTcpMon.dll.

Weitere Informationen

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