El servicio del agente de protección DPM no se puede iniciar

Este artículo le ayuda a corregir un problema por el que recibe el error 10048 (0x2740) del servicio DPMRA terminado con el error específico del servicio al iniciar el servicio del agente de protección de Data Protection Manager (DPM).

Versión original del producto: System Center Data Protection Manager
Número de KB original: 947682

Síntomas

Después de implementar el agente de protección DPM en Microsoft System Center Data Protection Manager, el servicio agente de protección DPM no se puede iniciar en los servidores protegidos. (Un servidor protegido es un servidor que contiene orígenes de datos que son miembros del grupo de protección).

Causa

Este problema puede producirse por una de las siguientes razones:

  • Otro proceso es usar el puerto TCP 5718 y el puerto TCP 5719. El servicio del agente de protección DPM necesita estos dos puertos.
  • El puerto TCP 5718 y el puerto TCP 5719 no están abiertos para aplicaciones de firewall ni para dispositivos de firewall en el equipo.

Solución 1

Para resolver este problema, busque el proceso que usa los puertos TCP necesarios. Para ello, siga estos pasos:

  1. Abra una ventana del símbolo del sistema. Ejecute los comandos siguientes en el símbolo del sistema:

    netstat -ano > netstat.txt
    tasklist > tasklist.txt
    tasklist /svc >svclist.txt
    

    Nota:

    En este paso, las salidas de comando del netstat comando y el tasklist comando se escriben en archivos de texto para que pueda comprobar las salidas más fácilmente. Ejecute el tasklist comando junto con el /svc modificador porque el proceso que usa los puertos necesarios puede estar ejecutándose como servicio.

  2. Abra los archivos de texto generados en el paso 1. Para ello, ejecute los siguientes comandos en el símbolo del sistema:

    notepad netstat.txt
    notepad tasklist.txt
    notepad svclist.txt
    
  3. En el archivo Netstat.txt, busque las entradas correspondientes al puerto TCP 5718 y al puerto TCP 5719. Anote el identificador de proceso (PID) para cada entrada.

  4. En el archivo Tasklist.txt, busque los PIN que encontró en el paso 3 para determinar qué procesos usan los puertos necesarios. Si no encuentra los PIN en el archivo Tasklist.txt, intente buscar los PIN en el archivo Svclist.txt.

  5. Después de averiguar qué proceso usa los puertos necesarios, configure el programa correspondiente para usar otros puertos disponibles. Si no puede cambiar los puertos del programa o si el programa usa puertos dinámicamente, debe detener el programa.

Nota:

Si otra aplicación usa el puerto o los puertos (5718 y 5719), los puertos no se pueden cambiar. En este caso, puede usar, en su lugar, la herramienta SetAgentcfg.exe. Esta herramienta proporciona la capacidad de cambiar los puertos predeterminados que usa el agente DPM.

Para cambiar los puertos que usa el agente DPM, siga estos pasos en el equipo protegido que experimenta el problema. Asegúrese de que ninguna otra aplicación usará los puertos que reasigna.

Nota:

Para enumerar la ruta de instalación de DPM, ejecute el siguiente comando:

Reg query "HKLM\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Setup" /v installpath

  1. Busque el archivo SetAgentcfg.exe desde el servidor DPM. De forma predeterminada, el archivo se encuentra en %PROGRAMFILES%\Microsoft DPM\DPM\Setup\SetAgentCfg.exe.

  2. Copie el archivo en el equipo protegido que está experimentando el problema. Copie el archivo en el directorio DPM\Bin del agente. De forma predeterminada, el archivo se encuentra en %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin.

  3. En el equipo protegido que experimenta el problema, abra una ventana del símbolo del sistema administrativo.

  4. En la ventana símbolo del sistema, cambie al directorio en el que se copió el archivo SetAgentCfg.exe. Por ejemplo, cambie al directorio %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin.

  5. Ejecute el siguiente comando para cambiar los puertos que usa el agente DPM:

    SetAgentCfg e dpmra <port number> <alternate port number>
    
  6. Reinicie el servicio DPMRA.

Si estos pasos no resuelven este problema, determine si las aplicaciones de firewall requieren que compruebe estos puertos. A continuación, abra manualmente los puertos.

Solución 2

Para reservar los puertos TCP 5718 y 5719, siga los pasos que se documentan en Cómo reservar un intervalo de puertos efímeros en un equipo que ejecuta Windows Server 2003 o Windows 2000 Server.

Más información

Data Protection Manager y los servidores protegidos abren conexiones a través del puerto TCP 5718 y a través del puerto TCP 5719 para habilitar las operaciones de Data Protection Manager, como la sincronización y la recuperación. El problema actual puede producirse en servidores protegidos que ejecutan el servicio operador del sistema de Microsoft Exchange . Este servicio usa puertos TCP dinámicamente. Este servicio puede tomar uno o ambos puertos necesarios.

Data Protection Manager también usa los puertos siguientes:

  • TCP 135 dinámico
  • Protocolo de datagramas de usuario (UDP) 53
  • UDP 88
  • TCP 88
  • UDP 137
  • UDP 138
  • TCP 139
  • TCP 389
  • UDP 389