Не удается запустить службу агента защиты DPM

Эта статья поможет устранить проблему, из-за которой служба DPMRA завершается с ошибкой 10048 (0x2740) при запуске службы агента защиты Data Protection Manager (DPM).

Исходная версия продукта: System Center Data Protection Manager
Исходный номер базы знаний: 947682

Симптомы

После развертывания агента защиты DPM в Microsoft System Center Data Protection Manager служба агента защиты DPM не может запуститься на защищенных серверах. (Защищенный сервер — это сервер, содержащий источники данных, которые являются членами группы защиты.)

Причина

Эта проблема может возникнуть по одной из следующих причин:

  • Другой процесс — использование TCP-порта 5718 и TCP-порта 5719. Эти два порта требуются службе агента защиты DPM.
  • TCP-порты 5718 и TCP-порт 5719 не открыты для приложений брандмауэра или для устройств брандмауэра на компьютере.

Решение 1

Чтобы устранить эту проблему, найдите процесс, использующий необходимые TCP-порты. Для этого выполните следующие действия:

  1. Откройте окно командной строки. Выполните следующие команды в командной строке:

    netstat -ano > netstat.txt
    tasklist > tasklist.txt
    tasklist /svc >svclist.txt
    

    Примечание.

    На этом шаге выходные данные netstat команды и tasklist команды записываются в текстовые файлы, что упрощает проверка выходные данные. tasklist Выполните команду вместе с параметром/svc, так как процесс, использующий необходимые порты, может выполняться как служба.

  2. Откройте текстовые файлы, созданные на шаге 1. Для этого выполните в командной строке следующие команды:

    notepad netstat.txt
    notepad tasklist.txt
    notepad svclist.txt
    
  3. В файле Netstat.txt найдите все записи, соответствующие TCP-порту 5718 и TCP-порту 5719. Обратите внимание на идентификатор процесса (PID) для каждой записи.

  4. В файле Tasklist.txt найдите piD, найденные на шаге 3, чтобы определить, какие процессы используют необходимые порты. Если в файле Tasklist.txt не отображаются идентификаторы PID, попробуйте найти их в файле Svclist.txt.

  5. После того как вы узнаете, какой процесс использует необходимые порты, настройте соответствующую программу для использования других доступных портов. Если вы не можете изменить порты программы или если программа использует порты динамически, необходимо остановить программу.

Примечание.

Если другое приложение использует порт или порты (5718 и 5719), порты нельзя изменить. В этом случае вместо этого можно использовать средство SetAgentcfg.exe. Это средство позволяет изменять порты по умолчанию, используемые агентом DPM.

Чтобы изменить порты, используемые агентом DPM, выполните следующие действия на защищенном компьютере, на котором возникла проблема. Убедитесь, что переназначаемые порты не будут использоваться другими приложениями.

Примечание.

Чтобы получить список пути установки DPM, выполните следующую команду:

Reg query "HKLM\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Setup" /v installpath

  1. Найдите файл SetAgentcfg.exe на сервере DPM. По умолчанию файл находится по адресу %PROGRAMFILES%\Microsoft DPM\DPM\Setup\SetAgentCfg.exe.

  2. Скопируйте файл на защищенный компьютер, на котором возникла проблема. Скопируйте файл в каталог DPM\Bin агента. По умолчанию файл находится по адресу %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin.

  3. На защищенном компьютере, на котором возникла проблема, откройте окно командной строки администратора.

  4. В окне командной строки измените каталог, в который был скопирован файл SetAgentCfg.exe. Например, перейдите в каталог %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin.

  5. Выполните следующую команду, чтобы изменить порты, используемые агентом DPM:

    SetAgentCfg e dpmra <port number> <alternate port number>
    
  6. Перезапустите службу DPMRA.

Если эти действия не помогут устранить эту проблему, определите, требуются ли приложениям брандмауэра проверка этих портов. Затем вручную откройте порты.

Решение 2

Чтобы зарезервировать TCP-порты 5718 и 5719, выполните действия, описанные в статье Резервирование диапазона временных портов на компьютере под управлением Windows Server 2003 или Windows 2000 Server.

Дополнительная информация

Data Protection Manager и защищенные серверы открывают подключения через TCP-порт 5718 и ЧЕРЕЗ TCP-порт 5719, чтобы включить операции Data Protection Manager, такие как синхронизация и восстановление. Текущая проблема может возникнуть на защищенных серверах, на которых запущена служба системного сопровождающего Microsoft Exchange . Эта служба динамически использует TCP-порты. Эта служба может принимать один или оба необходимых порта.

Data Protection Manager также использует следующие порты:

  • Tcp 135 dynamic
  • Протокол пользовательской диаграммы (UDP) 53
  • UDP 88
  • TCP 88
  • UDP 137
  • UDP 138
  • TCP 139
  • TCP 389
  • UDP 389