O arquivo CBS.log contém entradas que alguns arquivos não são reparados mesmo depois de você executar com êxito o utilitário SFC em um computador baseado no Windows Server

Este artigo descreve um problema em que o arquivo CBS.log registra entradas quando um arquivo estático é alterado. Como o arquivo estático não é protegido pelo recurso proteção de recursos do Windows, o recurso relata a alteração no arquivo CBS.log.

Aplica-se a: Windows Server 2012 R2
Número de KB original: 954402

Sintomas

Você executa o utilitário SFC (System File Checker) (Sfc.exe) para verificar se há alterações nos arquivos do sistema Windows em um computador baseado no Windows Server 2008. Ao executar o utilitário SFC, você poderá receber a seguinte mensagem:

Todos os arquivos e chaves de registro listados nesta transação foram reparados com êxito.

No entanto, ao exibir o arquivo %windir%\Logs\CBS\CBS.log que o programa Sfc.exe gera, você poderá ver as seguintes entradas:

<Hora da Data><>, Info CSI 00000142 [SR] Reparando 1 componentes
<Hora da Data><>, Info CSI 00000143 [SR] Iniciando a transação Verificar e Reparar
<Hora da Data><>, Info CSI 00000145 [SR] Não é possível reparar o arquivo membro [l:18{9}]"img11.jpg" do Microsoft-Windows-Shell-Wallpaper-Common, Versão = 6.0.5720.0, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Cultura neutra, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Tipo neutro, TypeName neutro, PublicKey neutro na loja, hash incompatibilidade
<Hora da Data><>, Info CSI 00000147 [SR] Não é possível reparar o arquivo membro [l:18{9}]"img11.jpg" do Microsoft-Windows-Shell-Wallpaper-Common, Versão = 6.0.5720.0, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Cultura neutra, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Tipo neutro, TypeName neutro, PublicKey neutro na loja, hash incompatibilidade
<Hora da Data><>, Info CSI 00000149 [SR] Reparo concluído
<Hora da Data><>, Info CSI 0000014a [SR] Comprometendo transação
<Hora da> Data><, Info CSI 0000014e [SR] Verificação e reparo da transação concluída. Todos os arquivos e chaves do registro listados nesta transação foram reparados com êxito

Motivo

Arquivos estáticos e arquivos mutáveis são os dois tipos de arquivos definidos no sistema. Arquivos estáticos não podem ser alterados. Arquivos mutáveis podem ser alterados. Arquivos de registro e arquivos de log são exemplos de arquivos mutáveis. O recurso WRP (Proteção de Recursos do Windows) não verifica arquivos mutáveis. O recurso WRP verifica arquivos estáticos quando o utilitário SFC examina o computador. O recurso WRP ajuda a proteger a maioria dos arquivos estáticos. No entanto, nesse caso, o recurso WRP não protege o arquivo estático Img11.jpg. Se um arquivo estático for alterado quando o recurso WRP examinar o arquivo, a alteração será registrada no arquivo CBS.log. Como o recurso WRP não protege o arquivo estático Img11.jpg, o recurso WRP não tem outra opção a não ser relatar a alteração no arquivo CBS.log.

Mais informações

O programa Sfc.exe grava os detalhes de cada operação de verificação e de cada operação de reparo no arquivo CBS.log. Cada SFC.exe entrada do programa no arquivo CBS.log tem uma marca [SR].

Observação

O serviço Instalador de Módulos do Windows também grava no arquivo CBS.log. O serviço Instalador de Módulos do Windows instala recursos, atualizações e pacotes de serviço opcionais.

Você pode pesquisar marcas [SR] para ajudar a localizar SFC.exe entradas do programa. Para pesquisar marcas [SR] e redirecionar os resultados da pesquisa para um arquivo de texto, siga estas etapas:

  1. Clique em Iniciar, digite cmd na caixa Iniciar Pesquisa , clique com o botão direito do mouse em cmd na lista Programas e clique em Executar como administrador.

    Se você for solicitado a obter uma senha de administrador ou para confirmação, digite a senha ou clique em Continuar.

  2. No prompt de comando, digite o seguinte comando e pressione ENTER:

    findstr /c:"[SR]" %windir%\logs\cbs\cbs.log >sfcdetails.txt
    

    Observação

    O arquivo Sfcdetails.txt inclui as entradas registradas sempre que o programa SFC.exe é executado no computador.

  3. Digite a saída e pressione ENTER para fechar a janela Prompt de Comando.

Coleta de dados

Se você precisar de ajuda do suporte da Microsoft, recomendamos coletar as informações seguindo as etapas mencionadas em Coletar informações usando o TSS para problemas relacionados à implantação.