전자 메일 라우터 서비스가 Microsoft Dynamics CRM 전자 메일 라우터 서비스를 시작할 때 백그라운드 스레드 오류를 기본 서비스를 실행할 수 없습니다.

이 문서에서는 Microsoft Dynamics CRM 전자 메일 라우터 서비스를 시작할 때 전자 메일 라우터 서비스에서 백그라운드 스레드 오류를 기본 서비스를 실행할 수 없다는 문제를 해결할 수 있습니다.

적용 대상: Microsoft Dynamics CRM 2011
원래 KB 번호: 954522

증상

Microsoft Dynamics CRM Microsoft Dynamics CRM 전자 메일 라우터 서비스를 시작하려고 하면 애플리케이션 로그에 다음 Error 이벤트가 기록됩니다.

전자 메일 라우터 서비스에서 백그라운드 스레드를 기본 서비스를 실행할 수 없습니다.

원인

이 문제는 Microsoft.Crm.Tools.EmailAgent.SystemState.xml 파일이 손상되었기 때문에 발생합니다.

해결 방법

이 문제를 해결하려면 다음과 같이 하십시오.

  1. Microsoft.Crm.Tools.EmailAgent.SystemState.xml 파일을 삭제합니다.

    참고

    • 기본적으로 Microsoft.Crm.Tools.EmailAgent.SystemState.xml 파일은 C:\Program Files\Microsoft CRM Email\Service 폴더에 있습니다.
    • 기본적으로 서비스 폴더는 숨겨진 폴더입니다. 이 폴더를 보려면 숨겨진 파일과 숨겨진 폴더를 표시하도록 Windows Explorer 설정을 변경해야 합니다.
  2. Microsoft Dynamics CRM 전자 메일 라우터 서비스를 다시 시작합니다.

    Microsoft.Crm.Tools.EmailAgent.SystemState.xml 파일이 다시 만들어집니다.

Microsoft Dynamics CRM 사용자가 수신 메일에 대해 전달 사서함이 아닌 Email 라우터를 사용하도록 설정된 경우 이 해결 방법을 구현한 후 삭제된 전자 메일이 Microsoft Dynamics CRM 반환할 가능성이 있습니다. 사용자의 사서함에서 전자 메일을 삭제하지 않은 경우 Email 라우터는 받은 편지함에서 사용자의 전자 메일을 찾고, Microsoft Dynamics CRM 찾을 수 없으며, Microsoft Dynamics CRM 다시 전자 메일을 만들 수 있습니다. 이를 방지하려면 Microsoft Dynamics CRM 함께 사용자의 사서함에서도 전자 메일을 삭제해야 합니다.

이러한 상황을 방지하려면 다음 파일을 정기적으로 백업하고 동일한 서버의 바탕 화면에 저장합니다.

  • Microsoft.Crm.Tools.EmailAgent.Configuration.bin
  • Microsoft.Crm.Tools.EmailAgent.SystemState.Xml

시작 시 Microsoft Dynamics CRM Email 라우터 Configuration Manager 실패하거나 Microsoft Dynamics CRM Email 라우터 서비스가 시작되지 않는 경우 C:\Program Files\에서 위의 두 파일을 바꿉니다. Microsoft CRM Email\Service. Microsoft Dynamics CRM Email 라우터 서비스를 다시 시작한 다음 Microsoft Dynamics CRM Email 라우터 Configuration Manager 시작합니다. 이러한 파일의 백업이 최신인 경우 Email 라우터의 전체 구성을 갖습니다.

참조

자세한 내용은 Microsoft Dynamics CRM Email 라우터 Configuration Manager 시작할 때 구성 관리자가 구성 정보를 읽을 수 없는 Email 오류를 참조하세요.