Systemfehler 126 beim Starten des Windows Modules Installer-Diensts (TrustedInstaller): Das bestimmte Modul wurde nicht gefunden.

Dieser Artikel hilft bei der Behebung des Systemfehlers 126, der beim Starten des Windows Modules Installer-Diensts auftritt.

              Gilt für: Windows 7 Service Pack 1, Windows Server 2008 R2 Service Pack 1
Ursprüngliche KB-Nummer: 959077

Symptome

Wenn Sie den Windows Modules Installer-Dienst starten, erhalten Sie die folgende Fehlermeldung:

Screenshot des Windows Modules Installer-Diensts Fehler 126.

Außerdem erhalten Sie eine Fehlermeldung an der Eingabeaufforderung:

Screenshot der Fehlermeldung an der Eingabeaufforderung: Systemfehler 126 ist aufgetreten.

Ursache

Dieses Problem tritt auf, wenn der folgende Registrierungsunterschlüssel geändert wird:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Version

Lösung

Um dieses Problem zu beheben, müssen Sie den erweiterbaren Zeichenfolgenwert des Registrierungsunterschlüssels neu erstellen, der im Abschnitt Ursache erwähnt wird.

Zunächst müssen Sie überprüfen, ob der Registrierungsunterschlüssel vorhanden ist. Starten Sie hierzu die Registrierungs-Editor, und navigieren Sie dann zu dem Unterschlüssel, der im Abschnitt Ursache erwähnt wird. Wenn der Unterschlüssel nicht vorhanden ist, müssen Sie ihn erstellen. Gehen Sie dazu wie folgt vor:

  1. Suchen Sie das C:\Windows\Servicing\Version Verzeichnis, und notieren Sie sich den Namen des Unterordners in diesem Verzeichnis. Der Name lautet etwa 6.1.7600.16385. Dies ist Ihre TrustedInstaller-ID.

  2. Kopieren Sie den Namen des Unterordners in die Zwischenablage, und fügen Sie ihn dann zur sicheren Aufbewahrung in Editor ein.

    Screenshot des Unterordnernamens in diesem Verzeichnis.

    Hinweis

    In diesem Beispiel lautet die TrustedInstaller-ID 6.1.7601.17592.

  3. Suchen Sie im C:\Windows\WinSxS Verzeichnis nach einem Unterordner, dessen Name mit einer der folgenden Zeichenfolgen beginnt. (In den folgenden Unterordnernamen steht der Platzhalter TrustedInstaller ID für Ihre TrustedInstaller-ID.)

    Für 32-Bit-Windows: x86_microsoft-windows-servicingstack_31bf3856ad364e35_ TrustedInstaller ID _none

    Für 64-Bit-Windows: amd64_microsoft-windows-servicingstack_31bf3856ad364e35_ TrustedInstaller ID _none

  4. Kopieren Sie den Namen des Unterordners in die Zwischenablage, und fügen Sie ihn dann zur sicheren Aufbewahrung in Editor ein.

    Screenshot: Suchergebnis des Unterordnernamens im Verzeichnis

  5. Erstellen Sie den Registrierungsunterschlüssel HKLM\Software\Microsoft\Windows\CurrentVersion\Component Based Servicing\Version.

    Hinweis

    Um diesen Schlüssel zu erstellen, müssen Sie Besitzer des komponentenbasierten Wartungsschlüssels sein. Anschließend müssen Sie sich selbst Vollzugriffsberechtigungen erteilen.

  6. Erstellen Sie für den Versionsschlüssel , den Sie in Schritt 5 erstellt haben, einen erweiterbaren Zeichenfolgenwert (oder bearbeiten Sie ihn, wenn er bereits vorhanden ist). Verwenden Sie dazu die TrustedInstaller-ID als Namen und den vollständigen Pfad des Ordners, den Sie in Schritt 3 als Wert identifiziert haben.

    Hinweis

    Im vollständigen Pfad müssen Sie anstelle von C:\Windows\WinSxS\folder_nameverwenden%SystemRoot%\WinSxS\folder_name.

    Screenshot einer Beispieleinstellung für einen Zeichenfolgenwert des Versionsschlüssels.

  7. Klicken Sie auf OK, und beenden Sie dann die Registrierungs-Editor.

Sie können den Windows Modules Installer (TrustedInstaller)-Dienst jetzt wie gewohnt starten.

Datensammlung

Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Bereitstellungsprobleme ausführen.