Errores al intentar instalar un certificado mediante el Administrador de IIS 7.0

Este artículo le ayuda a resolver el problema por el que se puede producir un error inesperado en tiempo de ejecución al intentar instalar un certificado mediante Microsoft Internet Information Services (IIS) 7.0 Manager

Versión original del producto: Windows Server 2008 Service Pack 2, Internet Information Services 7.0
Número de KB original: 959216

Síntomas

Al intentar instalar un certificado desde un PKCS#7 archivo mediante el Administrador de IIS 7.0, puede recibir uno de los siguientes mensajes de error:

  • Mensaje de error 1

    No se encuentra la solicitud de certificado asociada a este archivo de certificado. Debe completarse una solicitud de certificado en el equipo donde se creó.

  • Mensaje de error 2

    Se produjo un error al realizar esta operación.
    Detalles: CertEnroll::CX509Enrollment::p_InstallResponse: se ha alcanzado el valor de la etiqueta incorrecta ASN1.
    0x8009310b (ASN:276)

Nota:

El certificado se instala correctamente a pesar del mensaje de error.

Causa

Este problema se produce porque el Administrador de IIS realiza una operación de búsqueda para buscar un nombre descriptivo del certificado durante la instalación. Sin embargo, el código que realiza esta operación de búsqueda omite este caso específico y no sabe cómo recuperar el nombre descriptivo de un certificado en un PKCS#7 archivo. Por eso se produce un error en la operación de búsqueda y recibe el mensaje de error.

Solución

Para resolver este problema, agregue un nombre descriptivo al certificado. Siga estos pasos para resolver este problema:

  1. Seleccione Inicio, ejecutar, escriba certmgr.msc y, a continuación, seleccione Aceptar.
  2. Seleccione Archivo, seleccione Agregar o quitar intervalos.
  3. Seleccione Certificados, agregue y, a continuación, seleccione Aceptar.
  4. Seleccione Cuenta de equipo, siguiente y, a continuación, seleccione Finalizar.
  5. Seleccione Aceptar.
  6. Expanda Certificados (equipo local) y Personal y, a continuación, Certificados.
  7. Haga clic con el botón derecho en el certificado y, a continuación, seleccione Propiedades.
  8. Edite el campo Nombre descriptivo .

Más información

Este problema está programado para resolverse en Windows Server 2008 Service Pack 3.