Aanmelden met Microsoft
Meld u aan of maak een account.
Hallo,
Selecteer een ander account.
U hebt meerdere accounts
Kies het account waarmee u zich wilt aanmelden.

Symptomen

Wanneer u opnieuw opstarten of afsluiten van een computer met Windows Server 2003, wordt een van de volgende Stop-foutberichten tijdens het afsluiten:

Stop 0x000000CE (parameter1, 0x00000000, parameter3, 0x00000000)
DRIVER_UNLOADED_WITHOUT_CANCELLING_PENDING_OPERATIONS

Stop 0x00000050 (parameter1, 0x00000000, parameter3, 0x00000000)
PAGE_FAULT_IN_NONPAGED_AREA

Opmerkingen

  • De parameters in de volgende Stop-foutberichten kunnen variëren, afhankelijk van de configuratie van de computer.

  • Dit probleem treedt op willekeurig.

Oorzaak

Wanneer het systeem wordt afgesloten, wordt een werkitem dat is gekoppeld aan het stuurprogramma Mrxsmb.sys in een wachtrij ingevoegd door de functie ExQueueWorkItem . De functie ExQueueWorkItem biedt echter geen mechanisme om te controleren of het apparaatobject dat is gekoppeld aan het opgegeven item beschikbaar is voordat het artikel wordt verwerkt. Als het stuurprogramma Mrxsmb.sys wordt verwijderd voordat het werk in de wachtrij-item is voltooid, wordt het systeem daarom een stop-fout.

Oplossing

Informatie over de hotfix

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld voor het probleem dat wordt beschreven in dit artikel. Voer deze hotfix alleen uit op systemen waarop de in dit artikel beschreven problemen zich voordoen. Deze hotfix moet wellicht extra worden getest. Als u geen ernstige hinder ondervindt van dit probleem, is het daarom raadzaam te wachten op de volgende update waarin deze hotfix is opgenomen.

Als de hotfix gedownload kan worden, is er een sectie 'Hotfix downloaden' aan het begin van dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, neem dan contact op met Microsoft Customer Service and Support om de hotfix te verkrijgen.

Opmerking Als er andere problemen optreden of als probleemoplossing is vereist, moet u wellicht een apart serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen en problemen die niet in aanmerking komen voor deze specifieke hotfix. Voor een volledige lijst met telefoonnummers van Microsoft Customer Service and Support of een afzonderlijk serviceverzoek maken, gaat u naar de volgende Microsoft-website:

http://support.microsoft.com/contactus/?ws=supportOpmerking Het formulier 'Hotfix kan worden gedownload' geeft de talen weer waarvoor de hotfix beschikbaar is. Als uw taal niet wordt weergegeven, is dit omdat een hotfix niet voor die taal beschikbaar is.

Vereisten

Deze hotfix moet Windows Server 2003 Service Pack 1 of Windows Server 2003 Service Pack 2.

Voor meer informatie klikt u op het volgende artikelnummer om het artikel in de Microsoft Knowledge Base weer te geven:

889100 het verkrijgen van het meest recente servicepack voor Windows Server 2003

Opnieuw opstarten

Nadat u deze hotfix hebt geïnstalleerd, moet u de computer opnieuw opstarten.

Informatie over het vervangen van hotfixes

Deze hotfix vervangt geen andere hotfixes.

Bestandsinformatie

De Engelse versie van deze hotfix heeft de bestandskenmerken (of recentere bestandskenmerken) die in de volgende tabel worden weergegeven. De datums en tijden voor deze bestanden worden weergegeven in Coordinated Universal Time (UTC). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Om het verschil tussen UTC en lokale tijd op te zoeken, gebruikt u het tabblad tijdzone in het onderdeel datum en tijd in het Configuratiescherm.

Windows Server 2003 met Service Pack 1, x86-versies

Bestandsnaam

Bestandsversie

Bestandsgrootte

Datum

Tijd

Platform

Mrxsmb.sys

5.2.3790.3276

438.784

07-Jan-2009

11:39

x86

Windows Server 2003 met Service Pack 2, x86-versies

Bestandsnaam

Bestandsversie

Bestandsgrootte

Datum

Tijd

Platform

Mrxsmb.sys

5.2.3790.4441

438.784

07-Jan-2009

11:44

x86

Windows Server 2003 met Service Pack 1, Itanium-versies

Bestandsnaam

Bestandsversie

Bestandsgrootte

Datum

Tijd

Platform

Mrxsmb.sys

5.2.3790.3276

1,172,992

07-Jan-2009

00:41

IA-64

Windows Server 2003 met Service Pack 2, Itanium-versies

Bestandsnaam

Bestandsversie

Bestandsgrootte

Datum

Tijd

Platform

Mrxsmb.sys

5.2.3790.4441

1,173,504

07-Jan-2009

00:47

IA-64

Windows Server 2003 met Service Pack 1, x64-versies

Bestandsnaam

Bestandsversie

Bestandsgrootte

Datum

Tijd

Platform

Mrxsmb.sys

5.2.3790.3276

786,944

07-Jan-2009

00:41

x64

Windows Server 2003 met Service Pack 2, x64-versies

Bestandsnaam

Bestandsversie

Bestandsgrootte

Datum

Tijd

Platform

Mrxsmb.sys

5.2.3790.4441

787,456

07-Jan-2009

00:49

x64

Windows XP x64 Professional Edition met servicepack 1

Bestandsnaam

Bestandsversie

Bestandsgrootte

Datum

Tijd

Platform

Mrxsmb.sys

5.2.3790.3276

786,944

07-Jan-2009

00:41

x64

Windows XP x64 Professional Edition met servicepack 2

Bestandsnaam

Bestandsversie

Bestandsgrootte

Datum

Tijd

Platform

Mrxsmb.sys

5.2.3790.4441

787,456

07-Jan-2009

00:49

x64

Status

Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.

Meer informatie

De functies ExInitializeWorkItem en ExQueueWorkItem kunnen worden gebruikt wanneer het opgegeven artikel niet gekoppeld aan een apparaatobject of apparaatstack is. In alle andere gevallen moeten de stuurprogramma's de routines voor IoAllocateWorkItem, IoFreeWorkItemen IoQueueWorkItem gebruiken. Alleen deze routines garanderen dat het apparaatobject dat is gekoppeld aan het opgegeven item beschikbaar blijft totdat u het werkitem is verwerkt.

Ga naar de volgende website van Microsoft Developer Network voor meer informatie:

http://msdn.microsoft.com/en-us/library/ms791491.aspxVoor meer informatie over terminologie voor software-updates klikt u op het volgende artikelnummer om het artikel in de Microsoft Knowledge Base weer te geven:

824684 beschrijving van de standaardterminologie die wordt gebruikt om software-updates voor Microsoft te beschrijven

Technische ondersteuning voor x64-versies van Microsoft Windows

Als de hardware is geleverd met een Microsoft Windows x64 edition is geïnstalleerd, biedt de hardwarefabrikant technische ondersteuning voor Windows x64 edition. In dit geval biedt de hardwarefabrikant ondersteuning omdat een Windows x64 edition geleverd bij uw hardware is. De fabrikant kan de installatie van Windows x64 edition hebt aangepast met unieke onderdelen. Unieke onderdelen kunnen bevatten specifieke apparaatstuurprogramma's of optionele instellingen om de prestaties van de hardware. Microsoft biedt assistentie in redelijkheid als u technische hulp nodig hebt bij een Windows x64 edition nodig hebt. Mogelijk moet u rechtstreeks contact opnemen met de fabrikant. De fabrikant van de is beste ondersteuning bieden voor software die de fabrikant op de hardware geïnstalleerd gekwalificeerd. Als u een versie van Windows x64 zoals een editie van Windows Server 2003 x64 apart hebt aangeschaft, moet u contact opnemen met Microsoft voor technische ondersteuning.

Voor productinformatie over Windows XP Professional x64 Edition, gaat u naar de volgende Microsoft-website:

http://www.microsoft.com/windowsxp/64bit/default.mspxVoor productinformatie over x64-versies van Windows Server 2003, gaat u naar de volgende Microsoft-website:

http://www.microsoft.com/windowsserver2003/64bit/x64/default.mspx

Meer hulp nodig?

Meer opties?

Verken abonnementsvoordelen, blader door trainingscursussen, leer hoe u uw apparaat kunt beveiligen en meer.

Community's helpen u vragen te stellen en te beantwoorden, feedback te geven en te leren van experts met uitgebreide kennis.

Was deze informatie nuttig?

Hoe tevreden bent u met de taalkwaliteit?
Wat heeft uw ervaring beïnvloed?
Als u op Verzenden klikt, wordt uw feedback gebruikt om producten en services van Microsoft te verbeteren. Uw IT-beheerder kan deze gegevens verzamelen. Privacyverklaring.

Hartelijk dank voor uw feedback.

×