SCVMM y SCVMM R2 P2V fallan con el error 2910 (0x80070005) Acceso denegado

En este artículo se proporciona una solución a un error 2910 (0x80070005) que se produce cuando se produce un error de conversión de físico a virtual (P2V) en Microsoft System Center Virtual Machine Manager 2008.

Se aplica a: Windows Server 2012 R2
Número de KB original: 969965

Síntomas

Cuando usa System Center Virtual Machine Manager 2008 para realizar un P2V, recibe el siguiente mensaje de error durante la fase del sistema de examen:

Error (2910)
VMM no tiene los permisos adecuados para acceder al recurso en %server.
Se deniega el acceso (0x80070005))

Acción recomendada
Asegúrese de que Virtual Machine Manager tiene los derechos adecuados para realizar esta acción.

Nota:

El equipo de origen es el equipo que se va a virtualizar en la conversión P2V.

Causa

Este problema suele producirse porque se cumple cualquiera de las condiciones siguientes:

  • Las credenciales que se especificaron en el Asistente para P2V no pertenecen a un miembro del grupo de administradores local en el equipo de origen.
  • El equipo de origen no permite llamadas WMI remotas al espacio de nombres CIMV2 a la cuenta que se usó para el Asistente para P2V.

Solución

Para resolver este problema, siga estos pasos:

  1. Asegúrese de que la cuenta que se usa para el Asistente para P2V es miembro del grupo administradores local en el equipo de origen.

    Nota:

    Esto es especialmente importante si el servidor SCVMM y el equipo de origen están en dominios diferentes.

  2. Compruebe la conectividad de WMI con el espacio de nombres CIMV2 en el equipo de origen. Para ello, siga estos pasos en el servidor SCVMM.

    Nota:

    Durante la fase del sistema de examen de la conversión P2V, SCVMM realiza llamadas WMI al espacio de nombres CIMV2 en el equipo de origen para extraer información básica del sistema. Si se produce un error en estas llamadas WMI, también se produce un error en la conversión P2V.

    1. Abra la ventana WBEMtest. Para ello, haga clic en Inicio, seleccione Ejecutar, escriba WBEMtest en el cuadro Abrir y, a continuación, haga clic en Aceptar.

    2. Haga clic en Conectar en la esquina superior derecha.

    3. Conéctese al espacio de nombres CIMV2 en el equipo de origen. Por ejemplo, escriba \Source\ROOT\CIMV2.

      Nota:

      Asegúrese de usar el nombre del equipo de origen.

    4. Haga clic en Conectar para completar la conexión.

    5. Compruebe la conexión mediante el acceso a un objeto de ejemplo. Para ello, haga clic en Abrir clasey, a continuación, escriba Win32_PhysicalMemory.

      Nota:

      Debería ver que los objetos rellenan la ventana Editor objeto. El contenido real que se devuelve no es importante. Este propósito de este paso es solo comprobar que se ha establecido una conexión remota al espacio de nombres CIMV2.

  3. Abra wmimgmt.msc para comprobar la conectividad con el equipo local y también para comprobar los permisos de habilitación remota. Para ello, siga estos pasos:

    1. Abra la ventana Control WMI (local). Para ello, haga clic en Inicio, seleccione Ejecutar, escriba wmimgmt.msc y, a continuación, haga clic en Aceptar.
    2. Haga clic con el botón derecho en el nodo Control WMI (local) y, a continuación, haga clic en Propiedades.
    3. Haga clic en la pestaña Seguridad , seleccione Raíz y, a continuación, haga clic en el botón Seguridad de la esquina inferior derecha.
    4. Haga clic para activar la casilla Habilitar remotamente para todos o la cuenta de usuario específica a la que desea conceder este permiso .

    Nota:

    Esta acción no requiere que reinicie el equipo.

  4. Abra dcomcnfg para comprobar que el servicio DCOM se está ejecutando y también para comprobar el permiso de activación remota. Para ello, siga estos pasos:

    1. Abra el complemento Servicios de componentes. Para ello, haga clic en Inicio, seleccione Ejecutar, escriba dcomcnfg y, a continuación, haga clic en Aceptar.
    2. Expanda Servicios de componentes, equiposy, a continuación, expanda Mi equipo.

    Nota:

    Si el nodo Mi equipo tiene una marca de flecha abajo roja, esto significa que el servicio DCOM no se está ejecutando y debe iniciarse. 3. Haga clic con el botón derecho en Mi equipo, haga clic en Propiedadesy luego haga clic en Seguridad COM pestaña. 4. En Permisos de inicio y activación, haga clic en Editar límites. 5. Para el grupo de usuarios Todos , haga clic para seleccionar la casilla Permitir de la fila Activación remota . Como alternativa, agregue la cuenta de usuario específica a la que desea conceder este permiso.

    Nota:

    Puede recibir un mensaje de error "Acceso denegado" si no se concede al usuario el permiso WMI adecuado. El mensaje de error puede incluir el código de error 0x80041003.

  5. Compruebe si falta la clave del Registro Ole o si tiene un valor incorrecto en el equipo de origen. Para ello, siga estos pasos:

    1. Inicie el Editor del Registro.
    2. Busque la siguiente subclave: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole
    3. Busque una entrada EnableDCOM que tenga un tipo de REG_SZ y un valor de Y.

Referencias

Para ver los pasos generales de solución de problemas de SCVMM, consulte el blog siguiente: System Center Virtual Machine Manager

Para obtener más información sobre las conversiones de P2V, visite el siguiente sitio web de Microsoft: Conversión de equipos físicos a Virtual Machines en VMM (conversiones P2V)