Kommunikationsprobleme bei einem Data Protection Manager-Agent

In diesem Artikel können Sie Fehlermeldungen zu Kommunikationsproblemen beheben, die bei einem Data Protection Manager-Agent (DPM) auftreten.

Ursprüngliche Produktversion: System Center Data Protection Manager
Ursprüngliche KB-Nummer: 970090

Symptome

Auf einem DPM-Agent erhalten Sie die folgenden Fehlermeldungen zu Kommunikationsproblemen:

Ein DPM-Agent konnte aufgrund eines Kommunikationsfehlers nicht mit dem DPM-Dienst auf dem <Server> kommunizieren. Stellen Sie sicher, dass über den Computer, < auf dem der DPM-Agent ausgeführt wird, remote auf den Server> zugegriffen werden kann. Wenn eine Firewall auf dem <Server> aktiviert ist, stellen Sie sicher, dass sie keine Anforderungen von dem Computer blockiert, auf dem der DPM-Agent ausgeführt wird (Fehlercode: 0x800706ba, vollständiger Name: <Server>).

DPM konnte nicht mit dem Schutz-Agent auf dem <Server> kommunizieren, da der Zugriff verweigert wird. (ID 42 Details: Zugriff verweigert (0x80070005))

Fehler 270: Fehler beim Agent-Vorgang auf dem <Server> , da DPM nicht mit dem DPM-Schutz-Agent kommunizieren konnte. Der Computer kann durch einen anderen DPM-Server geschützt werden, oder der Schutz-Agent wurde auf dem geschützten Computer deinstalliert.

Ursache

Dieses Problem tritt auf, wenn ein DPM-Computerkonto in einer der folgenden Sicherheitsgruppen auf dem geschützten Server fehlt:

  • DPMRADmTrustedMachines
  • DPMRADCOMTrustedMachines
  • Verteilte COM-Benutzer

Lösung

Wenn das DPM-Computerkonto in einer der Sicherheitsgruppen fehlt, die im Abschnitt Ursache aufgeführt sind, fügen Sie das DPM-Computerkonto manuell hinzu.

Wenn der Name des DPM-Servers beispielsweise DPM01 lautet und dieser Name zur Domäne Contoso gehört, sollte Conotoso\DPM01 als Mitglied jeder Gruppe auf dem geschützten Server angezeigt werden.

In einer Situation, in der der geschützte Server ein Domänencontroller ist, kann eine fehlgeschlagene Installation des Schutz-Agents dazu führen, dass die Gruppen DPMRADmTrustedMachines und DPMRADCOMTrustedMachines entfernt werden. Sie können dieses Problem beheben, indem Sie den folgenden Befehl ausführen:

<drive letter>:\Program Files\Microsoft Data Protection Manager\bin\SetDpmServer.exe -dpmServerName <DPM server name>

Der letzte Teil dieses Befehls könnte beispielsweise wie folgt aussehen:

SetDpmServer.exe -dpmServerName DPM01

Hinweis

  • DPM01 ist der tatsächliche DPM-Servername.
  • Mit diesem Befehl werden die beiden Gruppen in Active Directory neu erstellt, und das DPM-Computerkonto wird diesen Gruppen und der Gruppe Verteilte COM-Benutzer hinzugefügt.