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Symptômes

Considérez le scénario suivant :

  • Vous utilisez une séquence de tâches System Center Configuration Manager 2007 Deployment Feature Pack (OSD) pour déployer un fichier WIM (Os Windows Management Interface) Windows système d’exploitation.

  • Le fichier est supérieur à 4 Go.

  • Vous utilisez la méthode multicase pour déployer le fichier WIM du système d’exploitation.

Dans ce scénario, la séquence de tâches et le déploiement échouent immédiatement après le téléchargement du fichier WIM.

Notez que le même Windows fichier WIM du système d’exploitation se déploie correctement à l’aide de la monodiffusion. En outre, ce problème ne se produit pas si vous utilisez la méthode de multidiffusion pour déployer Windows fichiers WIM du système d’exploitation inférieurs à 4 Go.

Cause

Cette erreur est due à un problème connu dans System Center Configuration Manager Service Pack 1 (SP1) R2 2007. Dans ce problème, les calculs de hachage ne sont pas effectués correctement lorsque la taille du fichier WIM est supérieure à 4 Go.

Résolution

Informations du Service Pack

Pour résoudre ce problème, obtenez le dernier Service Pack pour Microsoft System Center Configuration Manager 2007, disponible à partir de ce site web Microsoft : http://www.microsoft.com/download/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
Pour obtenir la liste des problèmes résolus dans ce Service Pack, cliquez sur le numéro d’article suivant dans la base de connaissances Microsoft :

971348 Liste des correctifs logiciels et des mises à jour contenus dans System Center Configuration Manager Service Pack 2 2007

Informations sur le correctif logiciel

Un correctif logiciel pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif est destiné à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif logiciel uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif peut recevoir des tests supplémentaires. Par conséquent, si vous n’êtes pas gravement affecté par ce problème, nous vous recommandons d’attendre la prochaine mise à jour logicielle qui contient ce correctif logiciel.

Si le correctif logiciel est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » est disponible en haut de cet article de la Base de connaissances. Si cette section n’apparaît pas, contactez le service clientèle microsoft et le support technique pour obtenir le correctif logiciel.

Remarque Si des problèmes supplémentaires se produisent ou si un dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts de support habituels s’appliqueront aux questions et problèmes de support supplémentaires qui ne sont pas éligibles à ce correctif logiciel spécifique. Pour obtenir la liste complète des numéros de téléphone du service clientèle et du support technique Microsoft ou pour créer une demande de service distincte, visitez le site Web Microsoft suivant :

http://support.microsoft.com/contactus/?ws=supportNotez que le formulaire « Téléchargement du correctif logiciel disponible » affiche les langues pour lesquelles le correctif logiciel est disponible. Si vous ne voyez pas votre langue, c’est qu’un correctif logiciel n’est pas disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif logiciel, vous devez avoir installé System Center Configuration Manager Service Pack 1 2007.

Nécessité de redémarrer

Vous n’avez pas besoin de redémarrer votre ordinateur après avoir appliqué ce correctif logiciel.

Informations de remplacement du correctif logiciel

Ce correctif logiciel n'en remplace pas d'autre.

Informations sur les fichiers

La version anglaise de ce correctif logiciel contient les attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations des fichiers, les données sont converties en heure locale. Pour trouver la différence entre l’heure UTC et l’heure locale, utilisez l’onglet Fuseau horaire dans l’outil Date et heure dans Panneau de configuration.

Nom du fichier

Version du fichier

Taille du fichier

Date

Time

Platform

Mcs.msi

Non applicable

7,138,304

01-Dec-2008

1,501

Non applicable

Smswdstp.dll

4.0.6221.1176

119,128

01-Dec-2008

1,501

x86

Smswdstp.dll

4.0.6221.1176

286,040

01-Dec-2008

1,501

x64


Solution de contournement

Pour contourner ce problème, utilisez la méthode de monodiffusion pour déployer ou utilisez des fichiers WIM de système d’exploitation inférieurs à 4 Go.

État

Microsoft a confirmé l’existence de ce problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Informations supplémentaires

Après avoir installé le correctif logiciel décrit dans l’article de la Base de connaissances Microsoft (KB) 971413, les déploiements de système d’exploitation multidiffusion peuvent ne plus fonctionner. Cela inclut Windows fichiers WIM du système d’exploitation inférieurs à 4 Go.

Après avoir installé le correctif logiciel décrit dans l’article de base de connaissances 971413, une réinitialisation de site est lancée. Une réinitialisation de site réinstalle tous les composants du site. Toutefois, la session de multidiffusion échoue si les conditions suivantes sont remplies :

  • Une session de multidiffusion est lancée trop tôt après la procédure de réinitialisation du site.

  • La procédure de réinitialisation du site n’est pas terminée.

  • Tous les composants n’ont pas terminé leur processus de réinstallation, en particulier les composants associés à la multidiffusion.

Le moyen le plus simple de résoudre ce problème consiste à attendre un certain temps avant d’effectuer un déploiement de système d’exploitation multidiffusion. Toutefois, si le déploiement de multidiffusion ne fonctionne toujours pas, suivez les méthodes décrites ici :

Méthode 1

  1. Dans les propriétés de l’image du système d’exploitation, désactivez, puis réactivez l’option Autoriser le transfert de ce package via la multidiffusion (WinPE uniquement).

  2. Désactivez puis réactivez l’option Multicastdans les propriétés du point de distribution de multidiffusion (DP).

  3. Réinstallez WDS.

Remarque Si le déploiement de multidiffusion sur des fichiers de plus de 4 Go ne fonctionne toujours pas, suivez la méthode suivante.

Méthode 2

  1. Dans la console System Center Configuration Manager 2007, sous Images du système d’exploitation, cliquez avec le bouton droit sur l’image du système d’exploitation en cours de multidiffusion, puis cliquez sur Propriétés.

  2. Cliquez sur distribution Paramètres tab.

  3. Désactivez l’option Autoriser le transfert de ce package via la multidiffusion (WinPE uniquement), puis cliquez sur
    Appliquer.

  4. Vérifiez l’option Autoriser le transfert de ce package via la multidiffusion (WinPE uniquement), puis cliquez sur
    OK.

  5. Répétez les étapes 1 à 4 pour chaque image de système d’exploitation définie pour la multidiffusion.

Remarque Si le déploiement de multidiffusion sur des fichiers de plus de 4 Go ne fonctionne toujours pas, suivez la méthode suivante.

Méthode 3

  1. Dans la console System Center Configuration Manager 2007, sous Images du système d’exploitation, cliquez avec le bouton droit sur l’image du système d’exploitation en cours de multidiffusion, puis cliquez sur Propriétés.

  2. Cliquez sur distribution Paramètres tab.

  3. Désactivez l’option Autoriser le transfert de ce package à l’aide de l’option de multidiffusion (WinPE uniquement), puis cliquez sur OK.

  4. Répétez les étapes 1 à 3 de cette méthode pour chaque image de système d’exploitation qui ont été définies pour la multidiffusion.

  5. Désactivez le DP de multidiffusion dans les propriétés du rôle DP. Pour ce faire, cliquez sur l’onglet Multicast , désactivez l’option Activer la multidiffusion , puis cliquez sur OK.

  6. Surveillez le fichier MCSSetup.log et le fichier MCSMSI.log. Attendez que les fichiers soient correctement désinstallés.

  7. Réinstallez la multidiffusion dans les propriétés du rôle DP. Pour ce faire, cliquez sur l’onglet Multidiffusion , cochez Activer la multidiffusion, puis cliquez sur OK.

  8. Surveillez le fichier MCSSetup.log et le fichier MCSMSI.log. Attendez que les fichiers soient correctement installés.

  9. Dans la console System Center Configuration Manager 2007, sous Images du système d’exploitation, cliquez avec le bouton droit sur l’image du système d’exploitation en cours de multidiffusion, puis cliquez sur Propriétés.

  10. Cliquez sur distribution Paramètres tab.

  11. Vérifiez l’option Autoriser le transfert de ce package via la multidiffusion (WinPE uniquement), puis cliquez sur
    OK.

  12. Répétez les étapes 9 à l’étape 11 de cette méthode pour chaque image de système d’exploitation qui est en cours de multidiffusion.

Remarque Si le déploiement de multidiffusion sur des fichiers de plus de 4 Go ne fonctionne toujours pas, suivez la méthode suivante.

Méthode 4

  1. Suivez les étapes 1 à 6 de la méthode 3.

  2. Si le serveur n’est pas un point de service PXE, passez à l’étape 5 de cette méthode.

  3. Si le serveur est également un point de service PXE, supprimez les images de démarrage du DP PXEBOOTIMAGES$ et désinstallez le rôle de point de service PXE ConfigMgr.

  4. Surveillez le fichier PXESetup.log et assurez-vous que le point de service PXE est désinstallé correctement.

  5. Désinstallez WDS.

  6. Si vous y êtes invité, redémarrez le serveur.

  7. Réinstallez WDS pour vous assurer que vous sélectionnez à la fois le serveur de déploiement et le serveur de transport.

  8. Si le serveur n’est pas un point de service PXE, passez à l’étape 12 de cette méthode.

  9. Si le serveur est également un point de service PXE, réinstallez le rôle de point de service PXE ConfigMgr.

  10. Surveillez le fichier PXESetup.log et assurez-vous que le point de service PXE est correctement installé. Si le journal vous invite à redémarrer le serveur, redémarrez-le.

  11. Ajoutez les images de démarrage au DP PXEBOOTIMAGES$.

  12. Suivez les étapes 7 à l’étape 13 de la méthode 3.


Pour plus d’informations, cliquez sur le numéro d’article suivant pour afficher l’article dans la Base de connaissances Microsoft :

824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

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