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Symptômes

Problème 1

Considérez le scénario suivant :

  • Vous créez un ordinateur virtuel Hyper-V sur un ordinateur qui exécute Windows Server 2008.

  • Vous permet d’attacher d’un disque de différenciation qui a été créé sur un ordinateur qui exécute Windows Server 2008 R2.

Dans ce scénario, vous pouvez recevoir des messages d’erreur suivants :

Le serveur a rencontré une erreur lors de la configuration du disque dur sur VMName.
Échec d’ajout de périphérique « Microsoft Virtual Hard Disk ».
Ne peut pas ouvrir la pièce jointe '\Filename.vhd< nom du répertoire >'. Erreur : « le fichier ou le répertoire est endommagé et illisible. »
Impossible d’obtenir les informations de la pièce jointe '\Filename.vhd< nom du répertoire >'.

Problème 2

Considérez le scénario suivant :

  • System Center Virtual Machine Manager 2008 R2 gère un serveur Windows Server 2008 dont le rôle Hyper installé et un serveur Windows Server 2008 R2 avec le rôle Hyper-V est installé

  • Vous migrez un ordinateur virtuel Hyper-V de Windows Server 2008 R2 vers Windows Server 2008.

Dans ce scénario, le message d’erreur suivant peut s’afficher :

Erreur (1730)
L’action sélectionnée n’a pas pu aboutir car l’ordinateur virtuel n’est pas dans un état dans lequel l’action est valide.

Cause

Ce problème se produit car le pilote Vhdparser.sys dans Windows Server 2008 ne gère pas correctement une valeur de métadonnées. Cette valeur de métadonnées est utilisée sur les disques qui sont créées sur un serveur qui exécute Windows Server 2008 R2 de différenciation.

Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif vise à corriger uniquement le problème décrit dans cet article. Appliquez ce correctif uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » au début de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle et Support de Microsoft pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être formuler une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions et problèmes qui ne relèvent pas de ce correctif logiciel. Pour une liste complète des numéros de téléphone du Service clientèle et support technique de Microsoft ou pour créer une demande de service distincte, visitez le site Web de Microsoft à l'adresse suivante :

http://support.microsoft.com/contactus/? ws=supportRemarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, c'est parce qu'il n'y a pas de correctif disponible pour cette langue.

D'importants correctifs de Windows Vista et Windows Server 2008 sont inclus dans les mêmes packages. Toutefois, un seul de ces produits peut être répertorié dans la page demande de correctif « ». Pour demander le package de correctif qui s’applique à Windows Vista et Windows Server 2008, sélectionnez simplement le produit figurant sur la page.

Conditions préalables

Pour appliquer ce correctif logiciel, votre ordinateur doit exécuter l’un des systèmes d’exploitation suivants :

  • Windows Server 2008

  • Windows Server 2008 Service Pack 2 (SP2)

En outre, vous devez disposer le rôle Hyper-V est installé sur votre ordinateur.

Nécessite un redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations concernant le Registre

Vous ne disposez pas d’apporter de modification au Registre.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et heure dans le panneau de configuration.


Pour toutes les versions x64 de Windows Server 2008 prises en charge

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

SP requis

Isoparser.sys

6.0.6001.22445

19,968

08-Jun-2009

17:43

x64

SP1

Passthruparser.sys

6.0.6001.22445

28,672

08-Jun-2009

17:43

x64

SP1

Storvsp.sys

6.0.6001.22445

133,120

08-Jun-2009

17:43

x64

SP1

Vhdparser.sys

6.0.6001.22445

94,208

08-Jun-2009

17:43

x64

SP1

Wstorvsp.inf

Ne s'applique pas

6,462

08-Jun-2009

14:59

Ne s'applique pas

SP1


Pour toutes les versions basées sur les x64 de Windows Server 2008 SP2

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

SP requis

Isoparser.sys

6.0.6002.22148

19,968

08-Jun-2009

17:27

x64

SP2

Passthruparser.sys

6.0.6002.22148

28,672

08-Jun-2009

17:27

x64

SP2

Storvsp.sys

6.0.6002.22148

122 880

08-Jun-2009

17:27

x64

SP2

Vhdparser.sys

6.0.6002.22148

87,552

08-Jun-2009

17:27

x64

SP2

Wstorvsp.inf

Ne s'applique pas

6,462

08-Jun-2009

14:59

Ne s'applique pas

SP2


Plus d'informations

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

Description 824684 terminologie standard utilisée pour décrire les mises à jour logicielles de Microsoft


État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

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