Las aplicaciones hospedadas en explorador (XBAP) de WPF pueden bloquearse durante el inicio

Este artículo le ayuda a resolver el problema por el que los XBAP de WPF pueden bloquearse durante el inicio.

Versión original del producto: Microsoft .NET Framework 3.5 Service Pack 1
Número de KB original: 972928

Síntoma

Los XBAP de WPF pueden bloquearse durante el inicio.

Causa

Una de las causas de este problema es que se interrumpen los registros de interfaz de nivel de sistema. En concreto, es posible que falten registros para las siguientes interfaces:

  • IID_IWebBrowser2
  • IID_IShellBrowser

Esto puede deberse a instalaciones o actualizaciones erróneas o a infecciones de malware.

Solución

Vuelva a registrar las interfaces rotas mediante la ejecución de los siguientes comandos:

regsvr32 %SystemRoot%\System32\actxprxy.dll
regsvr32 "%ProgramFiles%\Internet Explorer\ieproxy.dll"

En Windows de 64 bits, ejecute también los siguientes comandos:

regsvr32 %SystemRoot%\SysWOW64\actxprxy.dll
regsvr32 "%ProgramFiles(x86)%\Internet Explorer\ieproxy.dll"

En Windows XP y Windows Server 2003, estos comandos deben ejecutarse desde una cuenta de usuario con privilegios administrativos en el equipo.

En Windows Vista o versiones posteriores, estos comandos deben ejecutarse con privilegios elevados. Seleccione Iniciar>todos los accesorios de programas>. Haga clic con el botón derecho en Símbolo del sistema y seleccione Ejecutar como administrador. En el símbolo del sistema, ejecute los comandos.

Compruebe si se ha solucionado el problema. Si el problema se soluciona, ha terminado con esta sección. Si el problema no se ha corregido, puede ponerse en contacto con el soporte técnico.