Les applications hébergées par le navigateur WPF (XBAPs) peuvent se bloquer au démarrage

Cet article vous aide à résoudre le problème où les XBAPs WPF peuvent se bloquer pendant le démarrage.

Version d’origine du produit : Microsoft .NET Framework 3.5 Service Pack 1
Numéro de la base de connaissances d’origine : 972928

Symptôme

Les XBAPs WPF peuvent se bloquer au démarrage.

Cause

L’une des causes de ce problème est que les inscriptions d’interface au niveau du système sont interrompues. En particulier, les inscriptions pour les interfaces suivantes peuvent être manquantes :

  • IID_IWebBrowser2
  • IID_IShellBrowser

Cela peut être dû à des échecs d’installations ou de mises à niveau, ou à des infections de programmes malveillants.

Résolution

Réinscrivez les interfaces rompues en exécutant les commandes suivantes :

regsvr32 %SystemRoot%\System32\actxprxy.dll
regsvr32 "%ProgramFiles%\Internet Explorer\ieproxy.dll"

Sur Windows 64 bits, exécutez également les commandes suivantes :

regsvr32 %SystemRoot%\SysWOW64\actxprxy.dll
regsvr32 "%ProgramFiles(x86)%\Internet Explorer\ieproxy.dll"

Sur Windows XP et Windows Server 2003, ces commandes doivent être exécutées à partir d’un compte d’utilisateur disposant de privilèges d’administrateur sur l’ordinateur.

Sur Windows Vista ou version ultérieure, ces commandes doivent être exécutées avec élévation de privilèges. Sélectionnez Démarrer>tous les accessoires de programmes>. Cliquez avec le bouton droit sur Invite de commandes et sélectionnez Exécuter en tant qu’administrateur. À l’invite de commandes, exécutez les commandes.

Vérifiez si le problème est résolu. Si le problème est résolu, vous en avez terminé avec cette section. Si le problème n’est pas résolu, vous pouvez contacter le support technique.