Der Windows-Remote-Manager-Dienst (WinRM) wird nach der Deinstallation von WinRM 2.0 nicht gestartet.
Dieser Artikel bietet eine Lösung für das Problem, dass der Windows-Remote-Manager-Dienst (WinRM) nach der Deinstallation von WinRM 2.0 nicht gestartet wird.
Gilt für: Windows Server 2012 R2, Windows 10 – alle Editionen
Ursprüngliche KB-Nummer: 974504
Symptome
Sie deinstallieren Windows Remote Manager 2.0 (WinRM) auf einem Computer, auf dem Windows Server 2008 oder Windows Vista ausgeführt wird. Wenn Sie versuchen, den WinRM-Dienst mit dem Befehl net start winrm zu starten, wird der WinRM-Dienst nicht gestartet, und Sie erhalten die Fehlermeldung "Zugriff verweigert".
Ursache
Dieses Problem tritt auf, wenn Sie WinRM 2.0 deinstallieren und ein WinRM-Listener an Port 5985 vorhanden war.
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben.
Wiederherstellen der WinRM-Konfiguration
Führen Sie die folgenden Schritte aus, um den Standardzustand der WinRM-Konfiguration wiederherzustellen:
Öffnen Sie ein Eingabeaufforderungsfenster.
Geben Sie an der Eingabeaufforderung den folgenden Befehl ein, und drücken Sie die EINGABETASTE:
winrm quickconfig
Löschen des WinRM-Listeners an Port 5985
Öffnen Sie ein Eingabeaufforderungsfenster.
Geben Sie an der Eingabeaufforderung den folgenden Befehl ein, und drücken Sie die EINGABETASTE:
winrm enumerate winrm/config/listener
Es listet alle Listener auf, die WinRM derzeit verwendet.
Suchen Sie den Listener mit den folgenden Parametern und Werten:
- Port=5985
- Transport=HTTP
Beachten Sie den Wert, der für den Address-Parameter des Listeners aufgeführt ist.
Geben Sie den folgenden Befehl ein, und drücken Sie dann die EINGABETASTE:
winrm löschen winrm/config/Listener? Address= Address + Transport=HTTP
In diesem Befehl ist der Platzhalter Adresse der Wert, den Sie sich in Schritt 4 notiert haben.
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