Verwaltungsserver und ihre verwalteten Geräte sind in der Operations Manager-Konsole abgeblendet.

In diesem Artikel wird ein Problem behoben, bei dem einige Operations Manager-Rollen in der Betriebskonsole abgeblendet sind und das Ereignis 623 auf den betroffenen Computern protokolliert wird.

Ursprüngliche Produktversion: Microsoft System Center 2012 Operations Manager
Ursprüngliche KB-Nummer: 975057

Symptome

In einer Microsoft System Center Operations Manager-Umgebung können mindestens ein Verwaltungsserver, der die folgenden Rollen hostet, zusammen mit den verwalteten Geräten dieser Verwaltungsserver in der Betriebskonsole abgeblendet oder abgeblendet angezeigt werden:

  • Verwaltungsserver
  • Gatewayserver
  • Agent

Darüber hinaus wird ein Ereignis, das dem folgenden ähnelt, im Operations Manager-Protokoll auf diesen Computern protokolliert:

Ereignisquelle: ESE
Ereigniskategorie: Transaktions-Manager
Ereignis-ID: 623
Beschreibung: HealthService (<PID>) Der Versionsspeicher für instance <instance>("<Name>") hat seine maximale Größe von <Mb> erreicht. Es ist wahrscheinlich, dass eine Transaktion mit langer Ausführungszeit die Bereinigung des Versionsspeichers verhindert und dessen Größe anwächst. Updates werden abgelehnt, bis für die Transaktion mit langer Ausführungszeit ein vollständiger Commit ausgeführt oder ein Rollback ausgeführt wurde. Mögliche Transaktion mit langer Ausführungsdauer:
SessionId: <value>
Sitzungskontext: <Wert>
ThreadId im Sitzungskontext: <Wert>.
Bereinigung: <Wert>

Hinweis

Dieses Ereignis kann das Problem mit anderen Operations Manager-Prozessen melden, abhängig von der betroffenen Rolle.

Ursache

Dieses Problem tritt in der Regel in einer großen Operations Manager-Umgebung auf, in der ein Verwaltungsserver oder ein Agent-Computer viele Workflows verwaltet. Diese Situation kann aus einem der folgenden Gründe auftreten:

  • Viele Management Packs sind installiert.
  • Ein Verwaltungsserver oder Agent fungiert als Proxy für viele Geräte.

Der Operations Manager-Integritätsdienst speichert Datensätze von Transaktionen, die nicht abgeschlossen sind, in einem sogenannten Versionsspeicher. Mit dem Versionsspeicher kann die Extensible Storage Engine (ESE) aktuelle Transaktionen nachverfolgen und verwalten. Der Versionsspeicher enthält eine Liste von Vorgängen, die von aktiven Transaktionen ausgeführt werden, die vom HealthService-Dienst verwaltet werden. Diese Liste ist eine Im-Memory-Liste mit Änderungen, die an der HealthService-Speicherdatenbank vorgenommen werden. Es gibt eine Standardgröße, die für eine typische Installation jeder Operations Manager-Rolle optimiert ist. Die Standardgröße kann jedoch für bestimmte Operations Manager-Umgebungen nicht ausreichen.

Lösung

Wichtig

Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Für zusätzlichen Schutz sichern Sie die Registrierung, bevor Sie sie ändern. Sie können die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie unter Sichern und Wiederherstellen der Registrierung in Windows.

Wenden Sie die folgende Registrierungseinstellung auf die Computer an, auf denen die betroffenen Rollen gehostet werden, um das Problem zu beheben:

  • Unterschlüssel: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HealthService\Parameters
  • Typ: REG_DWORD
  • Name: Maximaler Persistenzversionsspeicher
  • Wert: Anzahl der Seiten mit 16 Kilobyte
  • Basis: Dezimal

Die Standardgröße des Versionsspeichers hängt von der Operations Manager-Rolle ab und ist definiert als die Anzahl von 16-Kilobyte-Seiten, die im Arbeitsspeicher zugeordnet werden sollen. Die Standardwerte sind wie folgt:

  • Agent (Arbeitsstationsbetriebssysteme): 640 (10 MB)
  • Agent (Serverbetriebssysteme): 1920 (30 MB)
  • Verwaltungsserver: 5120 (80 MB)

Wenn dieses Problem auftritt, empfiehlt es sich, die Größe des Versionsspeichers auf das Doppelte der Standardgröße festzulegen. Wenn Sie beispielsweise die Größe des Versionsspeichers auf einem Computer festlegen, der eine Management Server-Rolle hostet, legen Sie den Registrierungswert auf 10240 (dezimal) fest.

Nachdem Sie die Registrierungsänderung angewendet haben, starten Sie den HealthService-Dienst neu.

Hinweis

  • Für eine größere Versionsspeichergröße muss zusätzlicher Arbeitsspeicher zugewiesen werden.
  • Wenn der HealthService viele Workflows ausführt, muss dieser Registrierungswert noch größer als die empfohlene Größe festgelegt werden.
  • Informationen zu anderen Problemen, bei denen einige dieser Symptome ähnlich sind, finden Sie unter Problembehandlung für graue Agent-Zustände in System Center Operations Manager.