Yönetim sunucuları ve yönetilen cihazları Operations Manager konsolunda soluk görüntülenir

Bu makalede, bazı Operations Manager rollerinin İşletim konsolunda soluk görüntülendiği ve etkilenen bilgisayarlarda olay 623'ün günlüğe kaydedildiği bir sorun giderilmektedir.

Orijinal ürün sürümü: Microsoft System Center 2012 Operations Manager
Özgün KB numarası: 975057

Belirtiler

Microsoft System Center Operations Manager ortamında, aşağıdaki rolleri barındıran bir veya daha fazla yönetim sunucusu, bu yönetim sunucularının yönetilen cihazlarıyla birlikte İşletim konsolunda soluk veya gri görünebilir:

  • Yönetim sunucusu
  • Ağ geçidi sunucusu
  • Aracı

Ayrıca, aşağıdakine benzer bir olay bu bilgisayarlarda operations manager günlüğüne kaydedilir:

Olay Kaynağı: ESE
Olay Kategorisi: Transaction Manager
Olay Kimliği: 623
Açıklama: HealthService (<PID>) Örnek <için> sürüm deposu("<ad>"), Mb değerinin <> en büyük boyutuna ulaştı. Uzun süre çalışan bir işlemin sürüm deposunun temizlenmesini engellemesi ve boyutunun derlenmesine neden olması olasıdır. Güncelleştirmeler, uzun süre çalışan işlem tamamen işlenene veya geri alınana kadar reddedilir. Uzun süre çalışan olası işlem:
SessionId: <değer>
Oturum bağlamı: <değer>
Oturum bağlamı ThreadId: <değer>.
Temizleme: <değer>

Not

Bu olay, etkilenen role bağlı olarak diğer Operations Manager işlemleriyle ilgili sorunu bildirebilir.

Neden

Bu sorun genellikle bir yönetim sunucusunun veya aracı bilgisayarın birçok iş akışını yönettiği büyük bir Operations Manager ortamında oluşur. Bu durum aşağıdaki nedenlerden biri nedeniyle oluşabilir:

  • Birçok yönetim paketi yüklenir.
  • Bir yönetim sunucusu veya aracı, birçok cihaz için ara sunucu olarak görev yapıyor.

Operations Manager Sistem Sağlığı Hizmeti, tamamlanmayan işlemlerin kayıtlarını sürüm deposu olarak adlandırılan bir şeyde depolar. Sürüm deposu, Genişletilebilir Depolama Altyapısı'nın (ESE) geçerli işlemleri izlemesini ve yönetmesini sağlar. Sürüm deposu, HealthService hizmeti tarafından tutulan etkin işlemler tarafından gerçekleştirilen işlemlerin bir listesine sahiptir. Bu liste, HealthService deposu veritabanında yapılan değişikliklerin bellek içi listesidir. Her Operations Manager rolünün tipik yüklemesi için iyileştirilmiş varsayılan bir boyut vardır. Ancak, varsayılan boyut bazı Operations Manager ortamları için yetersiz olabilir.

Çözüm

Önemli

Bu bölüm, yöntem veya görev, kayıt defterini nasıl değiştireceğinizin anlatıldığı adımları içermektedir. Ancak kayıt defterini hatalı biçimde değiştirirseniz önemli sorunlar oluşabilir. Bu nedenle bu adımları dikkatle uyguladığınızdan emin olun. Ek koruma için kayıt defterini değiştirmeden önce yedeklemeyi unutmayın. Böylece, bir sorun oluşursa kayıt defterini daha sonra geri yükleyebilirsiniz. Kayıt defterini yedekleme ve geri yükleme hakkında daha fazla bilgi için bkz. Windows'ta kayıt defterini yedekleme ve geri yükleme.

Sorunu çözmek için, etkilenen rolleri barındıran bilgisayarlara aşağıdaki kayıt defteri ayarını uygulayın:

  • Alt anahtar: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HealthService\Parameters
  • Tür: REG_DWORD
  • Ad: Kalıcılık Sürüm Deposu Üst Sınırı
  • Değer: 16 kilobaytlık sayfa sayısı
  • Taban: Ondalık

Sürüm deposunun varsayılan boyutu Operations Manager rolüne bağlıdır ve bellekte ayrılacak 16 kilobaytlık sayfa sayısı olarak tanımlanır. Varsayılan değerler aşağıdaki gibidir:

  • Aracı (iş istasyonu işletim sistemleri): 640 (10 megabayt)
  • Aracı (sunucu işletim sistemleri): 1920 (30 megabayt)
  • Yönetim sunucusu: 5120 (80 megabayt)

Bu sorunla karşılaşırsanız, sürüm deposu boyutunu varsayılan boyutunun iki katı olacak şekilde ayarlamanızı öneririz. Örneğin, Yönetim Sunucusu rolünü barındıran bir bilgisayarda sürüm deposu boyutunu ayarlarsanız, kayıt defteri değerini 10240 (ondalık) olarak ayarlayın.

Kayıt defteri değişikliğini uyguladıktan sonra HealthService hizmetini yeniden başlatın.

Not