Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Quando si tenta di aggiornare il computer da Windows Vista a Windows 7, il processo di aggiornamento blocco al 62% per un tempo indefinito.

Inoltre, viene creato un file denominato unità_sistema: \$WINDOWS.~BT\Sources\Panther\setupact.log. Se si esamina il contenuto del file, osservarsi le seguenti informazioni:

<date> <time>, Info MIG IPostApply::ApplySuccess for Plugin={ServerPath="%windir%\system32\migration\IphlpsvcMigPlugin.dll", CLSID={ade10465-2a43-454e-b0a7-3f220a61bd03}, ThreadingModel=Apartment} - Working directory: C:\$UPGRADE.~OS\OnlineUpgradeApplyWork\srcworking\agentmgr\CCSIAgent\005AE0CB<date> <time>, Info [0x0808fe] MIG Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: Performing upgrade actions for all protocols
<date> <time>, Info [0x0808fe] MIG Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: CountInterfacesOfAType for 0.InterfaceCount ptr = 1dae2b8, InterfaceCount = 0
<date> <time>, Info [0x0808fe] MIG Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: CountInterfacesOfAType for 0.Incrementing interface count
<date> <time>, Info [0x0808fe] MIG Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: CountInterfacesOfAType for 0.InterfaceCount ptr = 1dae2b8, New value of *InterfaceCount = 1
<date> <time>, Info [0x0808fe] MIG Plugin {ade10465-2a43-454e-b0a7-3f220a61bd03}: IphlpsvcMigPlugin: IphlpsvcMigPlugin: RegEnumKeyEx return 259. key name: {AC049C3C-9B90-41A7-9385-DC5AD3E656F0}.new index: 2
Warning [0x080b50] MIG AsyncCallback_ApplyStatus: Progress appears to be stuck. Current progress: 62

Nota: L'unità è generalmente l'unità C del computer.

Causa

Questo problema si verifica perché il servizio Iphlpsvc si blocca durante l'aggiornamento.

Nota: Altri servizi possono inoltre causare un problema in cui il processo di aggiornamento si blocca al 62%.

Risoluzione

Importante Non utilizzare questa risoluzione se l'aggiornamento si blocca una percentuale 62% o se le voci del registro non sono registrata . Per ulteriori informazioni su come aprire il file Seupact.log, vedere la sezione Ulteriori informazioni .

Per risolvere il problema, passare alla sezione "correzione". Se si preferisce risolvere il problema manualmente, andare alla sezione "Consenti correzione manuale".

Correzione automatica

Per risolvere il problema automaticamente, riavviare il computer in cui l'aggiornamento a Windows 7 non riesce al 62%. Il computer eseguirà il rollback a Windows Vista. Scaricare la correzione seguente in un'unità flash o su un CD o tornare a questo articolo, nel computer in cui l'aggiornamento non riesce. Se si torna al presente articolo nel computer in cui si verifica questo problema, scegliere il
Risolvere il problema
collegamento. Fare clic su
Eseguireil
Finestra di dialogo Download Filee seguire la procedura guidata.




Nota questa procedura guidata potrebbe essere in inglese. Tuttavia, la correzione automatica funziona anche per altre versioni di lingua di Windows.

Nota: Se non si è sul computer che presenta il problema, è possibile salvare la correzione automatica per un'unità memoria flash o su un CD e quindi eseguirla sul computer che presenta il problema.

Successivamente, Vai al "il problema è stato risolto?" sezione.

Consenti la correzione manuale

Per risolvere questo problema, attenersi alla seguente procedura:

  1. Riavviare il computer. Quindi, il computer eseguirà il rollback a Windows Vista.

  2. Fare clic su Start, destro del mouse sul Computer e quindi scegliere Proprietà.

  3. Nella scheda Avanzate , fare clic su Variabili di ambiente.

  4. Nella casella variabili di sistema, fare clic su Nuovo.

  5. Tipo di MIG_UPGRADE_IGNORE_PLUGINS nel campo nome della variabile .

  6. Digitare IphlpsvcMigPlugin.dll nel campo valore della variabile .

  7. Scegliere OK tre volte per chiudere le finestre di dialogo.

  8. Avviare nuovamente l'installazione di aggiornamento.

Ulteriori informazioni

Come aprire il file seupact.log

Per aprire il file Setupact. log durante il processo di aggiornamento, premere MAIUSC + F10 per aprire un prompt dei comandi, digitare C:\$WINDOWS.~BT\Sources\Panther\setupact.loge quindi premere INVIO.

Per aprire il file Setupact. log dopo il rollback del computer a Windows Vista, fare clic su Start, digitare C:\$WINDOWS.~BT\Sources\Panther\setupact.log nella casella Inizia ricerca e quindi premere INVIO.

Verrà aperto nel blocco note il file seupact.log. Per visualizzare le voci di registro più recente, scorrere fino alla fine del file.

Il problema è stato risolto?

Verificare se il problema viene risolto mediante l'aggiornamento del computer da Windows Vista a Windows 7. Se il processo di aggiornamento avanza oltre il 62%, si è finito con questo articolo. Se il problema non viene risolto, è possibile contattare il supporto tecnico.

ULTERIORE ASSISTENZA?

Se questo articolo non risponde alla domanda, fare clic su questo pulsante per porre la domanda agli altri membri della Community di Microsoft:

Fai una domanda


Se si desidera visualizzare le risposte a problemi analoghi, fare clic su collegamenti seguenti per visualizzare argomenti Communityforum di Microsoft:


Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×