Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

You have a computer that is running Windows 7 or Windows Server 2008 R2. You connect an audio device to an HDMI endpoint on this computer. At first, the audio device works correctly. However, after you restart the computer, you cannot hear any sound from the audio device. Additionally, in the Sound window, the status of the corresponding audio device is "Not plugged in."



This problem occurs occasionally. It is more likely to occur on certain hardware.

Cause

This problem occurs because of a timing issue during audio initialization.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following Windows operating systems:

  • Windows 7

  • Windows Server 2008 R2

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and times for these files are listed in Coordinated Universal Time (UTC). The dates and times for these files on your local computer are displayed in your local time and with your current daylight saving time (DST) bias. Additionally, the dates and times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notes


Important Windows 7 and Windows Server 2008 R2 hotfixes are included in the same packages. However, only one of these products may be listed on the "Hotfix Request" page. To request the hotfix package that applies to both Windows 7 and Windows Server 2008 R2, just select the product that is listed on the page.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Platform

Audiodg.exe

6.1.7600.16385

100,864

14-Jul-2009

01:14

x86

Audioeng.dll

6.1.7600.20572

374,784

11-Nov-2009

08:02

x86

Audiokse.dll

6.1.7600.20572

442,880

11-Nov-2009

08:02

x86

Audioses.dll

6.1.7600.16385

195,584

14-Jul-2009

01:14

x86

Audiosrv.dll

6.1.7600.20572

473,088

11-Nov-2009

08:02

x86

Encdump.dll

5.0.1.1

274,944

14-Jul-2009

01:15

x86

Prod_audio-audiocore.ptxml

Not Applicable

1,442

13-Jul-2009

21:00

Not Applicable

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Audiodg.exe

6.1.7600.16385

126,464

14-Jul-2009

01:38

x64

Audioeng.dll

6.1.7600.16385

440,832

14-Jul-2009

01:40

x64

Audiokse.dll

6.1.7600.20572

499,712

11-Nov-2009

08:31

x64

Audioses.dll

6.1.7600.16385

296,448

14-Jul-2009

01:40

x64

Audiosrv.dll

6.1.7600.20572

677,376

11-Nov-2009

08:27

x64

Encdump.dll

5.0.1.1

283,648

14-Jul-2009

01:40

x64

Prod_audio-audiocore.ptxml

Not Applicable

1,442

13-Jul-2009

20:47

Not Applicable

Audioeng.dll

6.1.7600.20572

374,784

11-Nov-2009

08:02

x86

Audiokse.dll

6.1.7600.20572

442,880

11-Nov-2009

08:02

x86

Audioses.dll

6.1.7600.20572

195,584

11-Nov-2009

08:02

x86

Prod_wow64_audio-audiocore.ptxml

Not Applicable

1,442

11-Nov-2009

01:14

Not Applicable

Workaround

To work around this problem, restart the Windows Audio Endpoint Builder service.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base: -

824684
Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Platform

Package_1_for_kb975538~31bf3856ad364e35~x86~~6.1.1.0.mum

Not Applicable

1,826

11-Nov-2009

10:44

Not Applicable

Package_for_kb975538_rtm~31bf3856ad364e35~x86~~6.1.1.0.mum

Not Applicable

1,458

11-Nov-2009

10:44

Not Applicable

X86_7ebd3a2cccb008bebfeb85bd625e1573_31bf3856ad364e35_6.1.7600.20572_none_6ab662d9fd41d16d.manifest

Not Applicable

703

11-Nov-2009

10:44

Not Applicable

X86_microsoft-windows-audio-audiocore_31bf3856ad364e35_6.1.7600.20572_none_770788095f0b8a46.manifest

Not Applicable

88,774

11-Nov-2009

10:50

Not Applicable

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Amd64_8fb1f6fb7ec9d3a0118706d390989e90_31bf3856ad364e35_6.1.7600.20572_none_a62e91266877e6e9.manifest

Not Applicable

1,056

11-Nov-2009

10:44

Not Applicable

Amd64_microsoft-windows-audio-audiocore_31bf3856ad364e35_6.1.7600.20572_none_d326238d1768fb7c.manifest

Not Applicable

88,778

11-Nov-2009

10:44

Not Applicable

Package_1_for_kb975538~31bf3856ad364e35~amd64~~6.1.1.0.mum

Not Applicable

2,059

11-Nov-2009

10:44

Not Applicable

Package_for_kb975538_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mum

Not Applicable

1,466

11-Nov-2009

10:44

Not Applicable

Wow64_microsoft-windows-audio-audiocore_31bf3856ad364e35_6.1.7600.20572_none_dd7acddf4bc9bd77.manifest

Not Applicable

75,377

11-Nov-2009

08:16

Not Applicable

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×