Um recurso de disco físico permanece no status Pendente Online ou o utilitário Chkdsk começa a ser executado automaticamente em um servidor que está executando o Windows Server 2008
Este artigo ajuda a corrigir um problema em que várias mensagens de erros podem ser registradas quando você coloca um recurso de disco físico online.
Aplica-se a: Windows Server 2012 R2
Número de KB original: 977516
Sintomas
Quando você coloca um recurso de disco físico online em um servidor que está executando o Windows Server 2008, você pode experimentar um dos seguintes sintomas:
Sintoma 1
Ao exibir o recurso de disco físico no snap-in gerenciamento de cluster de failover, o recurso pode mostrar uma status de Pending Online. Além disso, a seguinte mensagem de erro é registrada no log do sistema:
Nome do Log: Sistema
Fonte: Microsoft-Windows-FailoverClustering
ID do evento: 1066
Categoria de tarefa: recurso de disco físico
Nível: Aviso
Descrição:
O recurso de disco de cluster 'Cluster Disk 3' indica corrupção para o volume '\\?\Volume{ec2fa15d-b438-11de-88bc-00155dd999d36}'. O Chkdsk está sendo executado para reparar problemas. O disco ficará indisponível até que o Chkdsk seja concluído. A saída do Chkdsk será registrada para arquivar 'C:\Windows\Cluster\Reports\ChkDsk_ResCluster Disk 3_Disk2Part1.log'.
O Chkdsk também pode gravar informações no Log de Eventos do Aplicativo.
Além disso, a seguinte mensagem de erro é registrada no log do Cluster:
ERR [RES] Disco do Cluster de Disco <Físico 3>: VerifyFS: Falha ao abrir o arquivo \\?\GLOBALROOT\Device\Harddisk2\Partition1\TextDocument.txt Erro: 5.
Sintoma 2
Ao exibir o recurso de disco físico no utilitário administrador de cluster da Microsoft, você poderá experimentar um ou mais dos seguintes sintomas:
O recurso pode não estar online ou pode ficar online após um breve atraso.
O utilitário Chkdsk junto com o comutador /F começa a ser executado automaticamente no disco rígido compartilhado.
A ID do evento 1066 que tem uma descrição semelhante à seguinte aparece no log do sistema do Visualizador de Eventos:
O recurso de cluster Disk Y:: está corrompido. Executando o ChkDsk /F para reparar problemas.
Motivo
Esses problemas ocorrem por um dos seguintes motivos.
Causa do sintoma 1
Esse problema ocorre porque um arquivo somente leitura está localizado no diretório raiz do recurso. Quando um recurso de disco físico compartilhado é colocado online, o serviço de cluster enumera os arquivos do diretório raiz e tenta abrir cada arquivo com acesso completo. Esse comportamento ocorre para garantir que o sistema de arquivos seja consistente e que o volume não esteja corrompido. Se algum dos arquivos estiver somente leitura no diretório raiz do recurso, o volume será considerado corrompido e o Chkdsk será iniciado. Para contornar esse problema, use a solução alternativa mencionada na seção Solução Alternativa do Sintoma 1 .
Causa do sintoma 2
Esse problema ocorre porque o sinalizador "sujo" para o volume está definido. Quando um recurso de disco físico compartilhado é colocado online, o serviço de cluster enumera os arquivos do diretório raiz e tenta abrir cada arquivo com acesso completo. Esse comportamento ocorre para garantir que o sistema de arquivos seja consistente e que o volume não esteja corrompido. Se algum dos arquivos tiver o sinalizador "sujo" definido no diretório raiz do recurso, o volume será considerado corrompido e o Chkdsk será iniciado. Para contornar esse problema, use a solução alternativa mencionada na seção Solução Alternativa do Sintoma 2 .
Solução alternativa do sintoma 1
Para resolver esse problema, faça um dos seguintes procedimentos:
- Desmarque o atributo somente leitura dos arquivos exibindo as propriedades do arquivo ou usando o
attrib -r
comando em um prompt de comando. - Mova os arquivos que têm o atributo somente leitura do diretório raiz do recurso para uma subpasta apropriada.
Observação
Se você não conseguir colocar o disco online e executar mais marcar nos arquivos, defina a propriedade privada Disco Físico DiskRunChkDsk como uma propriedade de 4 (ChkDskDontRun). Isso desabilitará verificações de montagem de volume.
Solução alternativa do sintoma 2
Para resolver esse problema, primeiro determine se o sinalizador "sujo" para o volume especificado está definido.
Para determinar se o sinalizador "sujo" está definido para o volume no Windows Server 2008, use a ferramenta Chkntfs.
Para obter mais informações sobre a ferramenta Chkntfs, visite o seguinte site do Microsoft TechNet:
Chkntfs
Para determinar se o sinalizador "sujo" está definido para o volume no Windows Server 2008 R2, use o Assistente de Validação de Configuração.
Para obter mais informações sobre o Assistente de Validação de Configuração, visite o seguinte site do Microsoft TechNet:
Validando uma configuração de cluster de failover
Se o sinalizador "sujo" estiver definido para o volume, execute o utilitário Chkdsk junto com o comutador /F.
Para obter mais informações sobre o utilitário Chkdsk, visite o seguinte site do Microsoft TechNet:
Chkdsk
Status
A Microsoft confirmou que esse é um problema nos produtos da Microsoft listados no início deste artigo.
Comentários
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