メイン コンテンツへスキップ
サポート
Microsoft アカウントでサインイン
サインインまたはアカウントを作成してください。
こんにちは、
別のアカウントを選択してください。
複数のアカウントがあります
サインインに使用するアカウントを選択してください。

BUG #: 125788 (コンテンツ管理)バグ #: 3530 (EBizSE)は BUG #: 3535 (EBizSE)

現象

Host Integration Server 2009 年には、次のシナリオを検討してください。

  • DB2 2.0 には、DB2 または Microsoft OLE DB プロバイダーの Microsoft OLE DB プロバイダーを使用します。

  • SQL Server 統合サービス (SSIS) を使用するか、SQL Server のインポートとエクスポート ウィザードを使用して Microsoft SQL Server に DB2、タイムスタンプ データ型のデータをインポートするとします。

このシナリオでは、インポート操作が失敗します。次に、以下のようなエラー メッセージが表示されます。[Destination Destination Name] Error: SSIS Error Code DTS_E_OLEDBERROR. An OLE DB error has occurred. Error code: 0x80004005. An OLE DB record is available. Source: "Microsoft SQL Server Native Client 10.0" Hresult: 0x80004005 Description: "The fractional part of the provided time value overflows the scale of the corresponding SQL Server parameter or column. Increase bScale in DBPARAMBINDINFO or column scale to correct this error." [Destination - Destination Name] Error: There was an error with input column "column name" (57) on input "Destination Input" (44). The column status returned was: "Conversion failed because the data value overflowed the specified type." [Destination - Destination Name] Error: SSIS Error Code DTS_E_INDUCEDTRANSFORMFAILUREONERROR. The "input "Destination Input" (44)" failed because error code 0xC020907A occurred, and the error row disposition on "input "Destination Input" (44)" specifies failure on error. An error occurred on the specified object of the specified component. There may be error messages posted before this with more information about the failure.

原因

この問題は、DB2 用 OLE DB プロバイダーには、DBTYPE_DBTIMESTAMP 精度の誤った値が返されるために発生します。この不適切な値は、OLE DB 列行セットのDATETIME_REVISIONフィールドに格納されます。たとえば、DB2 用 OLE DB プロバイダーは、 0または6の精度を返します。

解決策

修正プログラムの情報

サポートされている修正プログラムは、マイクロソフトから入手可能です。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この修正プログラムは、この資料に記載された問題があったシステムのみに対して適用してください。この修正プログラムは、今後さらにテストを行う場合があります。したがって、この問題の影響が深刻でない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことをお勧めします。

修正プログラムをダウンロードできる場合は、このサポート技術情報の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、マイクロソフト カスタマー サービス サポートにお問い合わせのうえ、修正プログラムを入手してください。

ヘルプを表示

その他のオプションが必要ですか?

サブスクリプションの特典の参照、トレーニング コースの閲覧、デバイスのセキュリティ保護方法などについて説明します。

コミュニティは、質問をしたり質問の答えを得たり、フィードバックを提供したり、豊富な知識を持つ専門家の意見を聞いたりするのに役立ちます。

この情報は役に立ちましたか?

言語の品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?
[送信] を押すと、Microsoft の製品とサービスの改善にフィードバックが使用されます。 IT 管理者はこのデータを収集できます。 プライバシーに関する声明。

フィードバックをいただき、ありがとうございます。

×