Silverlight for Mac isn't recognized or you're continually prompted to install

Note

Silverlight has retired and is officially out of support. For more information, see Silverlight End of Support.

Symptoms

When you try to access a Web site that requires Silverlight to display the content, you receive an error message that states that you have to install Silverlight.

Cause

This behavior can occur for several reasons:

  • Your system has an earlier version of the plug-in and does not meet the requirements for the plug-in that the site is using.

  • You do not have the plug-in installed.

  • The browser is set to "Run using Rosetta," which will cause the computer to be identified incorrectly as a PowerPC-based Mac.

Resolution

Before you determine how to address the issue, you should assess the current environment in which the software is running. To do this, follow these steps:

  1. On the Apple menu, select About this Mac.

  2. Note the processor type, speed, RAM, and operating system information, as some Web sites have specific requirements to view their content.

  3. Close the window.

  4. Close all open browser windows.

  5. Double-click the hard drive icon on the desktop.

  6. Double-click the Library folder.

  7. Open the Internet Plug-ins folder.

  8. Is there a file that is named Silverlight.plugin? If this file exists, the plug-in is installed. To determine the version, click to select the file. Then, select Get Info on the File menu. Note the version number that is displayed.

    • If the version number that is displayed is 1.0.xxx and your processor type is a PowerPC, you have the correct version of the plug-in installed.

    • If you have an Intel Processor, all versions of Silverlight are supported. But we recommended that you run the latest version so that you can access Web sites that use the newest features and take advantage of the most recent product improvements.

Now, we can address the individual causes and resolutions.

Your system has an earlier version of the plug-in and doesn't meet the Web site's requirements

The most common cause of this issue is that the Web site is using Silverlight 3 for its content. If a site requires version 3, it recognizes whether your system meets the requirement. If the system does not, you are prompted to upgrade. You are directed to the Silverlight site. If you are using a PowerPC, the site recognizes this and that only version 1 can be installed. (This situation would have to be addressed by the Web site's support team, as the decision on what version of Silverlight to use is made by the Web site designers.)

You do not have the plug-in installed

If Silverlight has not yet been installed, follow these steps to install the plug-in:

  1. Start a Web browser, and then visit the following Web site:

    http://silverlight.net/getstarted/

  2. Locate the "Install Silverlight" area in the lower-right part of the window.

    • If you're running an Intel processor, click Mac Runtime next to "Silverlight 3."

    • Otherwise, select Runtime for Mac PowerPC next to "Silverlight 1.0."

  3. After the download is completed, installation should start automatically. Follow the steps in the installation wizard.

  4. After the installation is complete, you should be prompted to exit your browser. Close any browser windows, and then restart the browser. The browser should recognize the new plug-in.

The browser is set to "Run using Rosetta," which will cause the computer to be identified incorrectly as a PowerPC-based Mac

If the browser is set to run in the Rosetta engine, it will incorrectly identify the computer as a PowerPC-based Mac, or the Web site will not recognize that the appropriate plug-in is installed.

If the appropriate plug-in is installed as described in the previous section, follow these steps:

  1. Double-click the hard drive icon on the desktop.

  2. Choose the Applications folder.

  3. Find the icon for the browser that you are using. Hold down the CONTROL key while you click this icon.

  4. Select Get Info.

  5. Locate the Run using Rosetta option and make sure that this check box is not selected. If it is selected, click to clear the check box. Close the window.

  6. On the Apple menu, select Restart.

  7. After the computer restarts, again try to access the Web site that generated the error message.

Note

If the appropriate version of the plug-in is not installed, make sure that the Run using Rosetta check box isn't selected, and then follow the steps in the previous section to install the plug-in.