FIX: WCF-HTTP send doesn't retry or suspend when it receives an error 500 in BizTalk Server

Symptoms

When you receive a 500 error that is coming back from WCF send port, the send port is not suspended but instead completes successfully. This is inconsistent with the behavior of this same adapter when error 400 comes back and is also inconsistent with the behavior of other HTTP-based adapters which suspend the send port instance when error 500 is sent back. This behavior also prevents you from catching the exception in the orchestration in the case of a 500 error. 

Cause

This issue occurs because WCF adapters do not handle HTTP errors in the same manner as HTTP adapters do.

Resolution

Cumulative update information

This problem was fixed in the following cumulative updates for BizTalk Server:

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

For information about the service packs and cumulative update list for BizTalk Server, see KB 2555976: Service pack and cumulative update list for BizTalk Server .

For more information about BizTalk Server hotfixes, see KB 2003907: Information about BizTalk hotfixes and cumulative update support .
Properties

Article ID: 3121493 - Last Review: ಜನ 26, 2017 - Revision: 3

Microsoft BizTalk Server 2013 R2 Branch, Microsoft BizTalk Server 2013 R2 Developer, Microsoft BizTalk Server 2013 R2 Enterprise, Microsoft BizTalk Server 2013 R2 Standard, BizTalk Server 2016 Branch, BizTalk Server 2016 Developer, BizTalk Server 2016 Enterprise, BizTalk Server 2016 Standard

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