Excel에서 데이터 열을 연결하는 VBA 매크로

적용 대상
Excel 2010

요약​​

Microsoft Excel에서 매크로를 사용하여 인접한 두 열의 데이터를 연결하고 데이터가 포함된 열 오른쪽 열에 결과를 표시할 수 있습니다. 이 문서에는 이를 수행하기 위한 샘플 Microsoft Visual Basic for Applications(VBA) 매크로(하위 프로시저)가 포함되어 있습니다.

추가 정보

Microsoft는 명시적이거나 묵시적인 보증 없이 설명용으로만 프로그래밍 예제를 제공합니다. 여기에는 상품성 또는 특정 목적에의 적합성에 대한 묵시적 보증이 포함되지만 이에 국한되지 않습니다. 이 문서에서는 설명 중인 프로그래밍 언어와 프로시저를 만들고 디버깅하는 데 사용되는 도구에 대해 잘 알고 있다고 가정합니다. Microsoft 지원 엔지니어는 특정 절차의 기능을 설명하는 데 도움을 줄 수 있습니다. 그러나 추가 기능을 제공하거나 특정 요구 사항을 충족하는 절차를 구성하기 위해 이러한 예제를 수정하지는 않습니다.

VBA(Visual Basic for Applications) 매크로 샘플


Sub ConcatColumns()

   Do While ActiveCell <> ""  'Loops until the active cell is blank.

      'The "&" must have a space on both sides or it will be
      'treated as a variable type of long integer.

      ActiveCell.Offset(0, 1).FormulaR1C1 = _
         ActiveCell.Offset(0, -1) & " " & ActiveCell.Offset(0, 0)

      ActiveCell.Offset(1, 0).Select
   Loop

End Sub

참고: ActiveCell.Offset(0, 1) 문입니다. FormulaR1C1을 ActiveCell.Offset(0, 1) 문으로 바꿀 수 있습니다. 공식. 수식이 아닌 텍스트와 숫자만 사용하는 경우에도 똑같이 성공적으로 사용할 수 있습니다. 첫 번째 문의 끝에 사용되는 R1C1은 행 1, 열 1을 참조하며 도움말의 예제에서 사용되는 양식입니다.
 

Microsoft Office Excel 2007에서 매크로를 사용하는 방법

  1. 데이터가 포함된 통합 문서를 엽니다.

  2. Alt+F11을 눌러 Visual Basic Editor를 시작합니다.

  3. [삽입] 메뉴에서 [모듈]을 클릭하여 모듈을 삽입합니다. 모듈의 코드 창에 매크로를 입력합니다.

  4. 파일 메뉴에서 닫기를 클릭하고 Microsoft Excel로 돌아갑니다.

  5. 연결할 데이터가 포함된 워크시트를 선택합니다.

  6. 연결할 데이터의 오른쪽 열에서 맨 위 셀을 클릭합니다. 예를 들어 셀 A1:A100과 B1:B100에 데이터가 들어 있으면 셀 B1을 클릭합니다.

  7. 개발자 탭을 클릭합니다. 개발자 탭이 표시되지 않으면 다음 단계를 수행합니다.

    1. Microsoft Office 단추를 클릭한 다음 Excel 옵션을 클릭합니다.
    2. 인기 항목을 클릭합니다.
    3. 리본 검사 상자에서 개발자 탭 표시를 클릭하여 선택합니다.
    4. 확인을 클릭하여 Excel 옵션 대화 상자를 닫습니다.
  8. 코드 그룹에서 매크로를 클릭합니다.

  9. ConcatColumns 매크로를 선택한 다음 실행을 클릭합니다.

Microsoft Office Excel 2003 및 이전 버전의 Excel에서 매크로를 사용하는 방법

  1. 데이터가 포함된 통합 문서를 엽니다.
  2. Alt+F11을 눌러 Visual Basic Editor를 시작합니다.
  3. [삽입] 메뉴에서 [모듈]을 클릭하여 모듈을 삽입합니다. 모듈의 코드 창에 매크로를 입력합니다.
  4. 파일 메뉴에서 닫기를 클릭하고 Microsoft Excel로 돌아갑니다.
  5. 연결할 데이터가 포함된 워크시트를 선택합니다.
  6. 연결할 데이터의 오른쪽 열에서 맨 위 셀을 클릭합니다. 예를 들어 셀 A1:A100과 B1:B100에 데이터가 들어 있으면 셀 B1을 클릭합니다.
  7. [도구] 메뉴에서 [매크로]를 가리킨 다음 [매크로]를 클릭합니다. ConcatColumns 매크로를 선택한 다음 실행을 클릭합니다.