Microsoft Security Essentials 업데이트 문제 해결

Microsoft Security Essentials는 Microsoft 업데이트와 함께 자동으로 작동하여 바이러스 및 스파이웨어 정의를 최신 상태로 유지합니다.

증상

자동 업데이트의 몇 가지 일반적인 문제는 다음과 같습니다.

  • 업데이트가 실패했음을 나타내는 오류 메시지가 표시됩니다.
  • 업데이트를 확인할 때 바이러스 및 스파이웨어 정의 업데이트를 확인, 다운로드 또는 설치할 수 없다는 오류 메시지가 표시됩니다.
  • 인터넷에 연결되어 있는 경우에도 업데이트가 실패합니다.
  • 업데이트가 일정에 따라 자동으로 설치되지 않습니다.

원인

업데이트 문제의 가장 일반적인 원인은 인터넷 연결 문제입니다. 온라인 상태인 경우 Windows Internet Explorer의 설정과 충돌하여 문제가 발생했을 수 있습니다.

해결 방법


1단계: Internet Explorer 기본 설정 복원

  1. Internet Explorer를 포함하여 열려 있는 모든 프로그램을 종료합니다.
  2. 시작을 클릭하고 검색 시작 상자에 inetcpl.cpl을 입력한 다음 Enter 키를 누릅니다.
  3. 인터넷 옵션 대화 상자에서 고급 탭을 클릭합니다.
  4. Internet Explorer 기본 설정 복원 설정에서 원래대로를 클릭한 다음 원래대로를 다시 클릭합니다.
  5. Internet Explorer에서 설정 초기화가 완료될 때까지 기다린 다음 확인을 클릭합니다.
  6. Internet Explorer를 엽니다.
  7. Microsoft Security Essentials를 열고 업데이트 탭을 클릭한 다음 업데이트를 클릭합니다. 문제가 계속되면 다음 단계로 이동합니다.

2단계: Internet Explorer를 기본 브라우저로 설정

  1. Internet Explorer를 포함하여 열려 있는 프로그램을 모두 종료합니다.
  2. 시작을 클릭하고 검색 시작 상자에 inetcpl.cpl을 입력한 다음 Enter 키를 누릅니다.
  3. 인터넷 옵션 대화 상자에서 프로그램 탭을 클릭합니다.
  4. 기본 웹 브라우저에서 기본값으로를 클릭합니다. 확인을 클릭합니다.
  5. Microsoft Security Essentials를 엽니다. 업데이트 탭을 클릭한 다음 업데이트를 클릭합니다. 문제가 계속되면 다음 단계로 이동합니다.

3단계: PC에서 날짜와 시간이 올바르게 설정되어 있는지 확인

  1. Microsoft Security Essentials를 엽니다.
  2. 표시된 오류 메시지에 0x80072f8f 코드가 포함되어 있을 경우 PC의 잘못된 날짜 또는 시간 설정으로 인해 문제가 발생했을 가능성이 큽니다.
  3. PC의 날짜 또는 시간 설정을 초기화하려면 끊어진 바탕 화면 바로 가기 수정 및 일반적인 시스템 유지 관리 작업의 단계를 따르세요.

4단계: PC에서 소프트웨어 배포 폴더의 이름 바꾸기

  1. 자동 업데이트 서비스 중지
    1. 시작, 실행을 차례로 클릭하고 services.msc를 입력한 다음 확인을 클릭합니다.
    2. 자동 업데이트 서비스를 마우스 오른쪽 단추로 클릭하고 중지를 클릭합니다.
    3. 서비스 스냅인을 최소화합니다.
  2. 표시된 오류 메시지에 0x80072f8f 코드가 포함되어 있을 경우 PC의 잘못된 날짜 또는 시간 설정으로 인해 문제가 발생했을 가능성이 큽니다.
  3. 다음과 같이 SoftwareDistribution 디렉터리의 이름을 바꿉니다.
    1. 시작, 실행을 차례로 클릭하고 cmd를 입력한 다음 확인을 클릭합니다.
    2. cd %windir%을 입력하고 Enter 키를 누릅니다.
    3. ren SoftwareDistribution SDTemp를 입력하고 Enter 키를 누릅니다.
    4. 끝내기를 입력하고 Enter 키를 누릅니다.
  4. 다음과 같이 자동 업데이트 서비스를 시작합니다.
    1. 서비스 스냅인을 최대화합니다.
    2. 자동 업데이트 서비스를 마우스 오른쪽 단추로 클릭한 다음 시작을 클릭합니다.
    3. 서비스 스냅인 창을 닫습니다.

5단계: PC에서 Microsoft 바이러스 백신 업데이트 엔진 초기화

  1. 시작, 모든 프로그램, 보조프로그램을 차례로 클릭하고 명령 프롬프트를 마우스 오른쪽 단추로 클릭한 다음 관리자 권한으로 실행을 선택합니다.
  2. 명령 프롬프트 창에서 다음 명령을 입력하고 각 명령 뒤에 Enter 키를 누릅니다.
    • Cd\
    • Cd program files\microsoft security essentials
    • Mpcmdrun –removedefinitions –all
    • Exit
  3. PC를 다시 시작합니다.
  4. Microsoft Security Essentials를 열고 업데이트 탭을 클릭한 다음 업데이트를 클릭합니다. 문제가 계속되면 다음 단계로 이동합니다.

6단계: 수동으로 바이러스 및 스파이웨어 정의 업데이트 설치

실행을 클릭합니다. PC에서 최신 업데이트가 수동으로 설치됩니다.

7단계: 지원 센터로 문의

위의 단계를 모두 수행해도 문제가 해결되지 않는 경우 지원 센터로 문의하세요. 자세한 내용은 고객 지원을 참조하세요.





속성

문서 ID: 17451 - 마지막 검토: 2016. 9. 14. - 수정: 2

Windows 7

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