인터넷 익스플로러에서 링크를 클릭하면 아무 일도 일어나지 않습니다.

적용 대상: Internet Explorer 9

증상


웹 페이지 또는 전자 메일 메시지에서 하이퍼링크를 클릭하면 아무 일도 일어나지 않습니다. 인터넷 익스플로러가 웹 페이지를 열지 않습니다.
정보 아이콘
참고
이 정보는 인터넷 익스플로러 9, 인터넷 익스플로러 8 및 인터넷 익스플로러 7에 적용됩니다.

원인


이 문제는 다음 이유 중 하나 이상에 대해 발생할 수 있습니다.
  • 사용할 웹 브라우저를 선택하는 설정이 손상되었습니다. 이로 인해 Windows에서 컴퓨터의 기본 브라우저로 설정된 브라우저를 잘못 해석할 수 있습니다.
  • 소프트웨어를 설치한 후 설정이 변경되어 웹 페이지링크가 잘못 작동할 수 있습니다.
  • 이전에 설치된 브라우저 나 추가 기능이 컴퓨터의 다른 소프트웨어를 방해할 수 있습니다.
  • 레지스트리 키가 변경되었거나 손상되었습니다.

해결 방법


이 섹션은 초급에서 중간 컴퓨터 사용자를 위한 것입니다. 이러한 방법으로 문제가 해결되지 않으면 "고급 문제 해결" 섹션에서 방법을 시도해 볼 수 있습니다.문제를 해결하려면 다음 방법을 표시 된 순서대로 사용 하십시오.방법 1: 기본 웹 브라우저 설정 확인 
Microsoft Windows에서 사용할 웹 브라우저를 선택할 수 있습니다. Internet Explorer를 기본 웹 브라우저로 만들려면 다음 단계를 따르세요.
  1. 인터넷 탐색기를 열려면 시작을클릭한 다음 인터넷 탐색기를클릭합니다.
  2. Internet Explorer를 기본 브라우저로 지정하려면 를 클릭합니다.
  3. 도구 메뉴에서 인터넷 옵션을 클릭합니다.
  4. 프로그램 탭을 클릭한 다음 기본 값 만들기를클릭합니다.
  5. 확인을클릭한 다음 인터넷 탐색기를 닫습니다.
    정보 아이콘
    참고
    변경 사항은 다음에 Internet Explorer를 시작할 때 적용됩니다.

문제가 해결되었는지 확인합니다. 문제가 해결되면 이 문서가 완료된 것입니다. 문제가 해결되지 않으면 다음 방법을 시도해 보십시오.

방법 2: Internet Explorer가 기본적으로 열리는 파일 형식을 변경합니다.

윈도우 7 및 윈도우 비스타용 
  1. 모든 인터넷 익스플로러 창을 닫습니다.
  2. 시작을 클릭하고 제어판을 클릭합니다.
  3. 프로그램을클릭한 다음 기본 프로그램 설정을 클릭합니다.
  4. 프로그램 메뉴에서 인터넷 탐색기를클릭한 다음 이 프로그램의 기본값 선택을 클릭합니다.
  5. .htm에 대한 확인란이 있는지 확인합니다.html, 및 .url이 선택된 다음 저장을클릭합니다.
  6. 확인을 클릭합니다.
    정보 아이콘
    참고
    변경 사항은 다음에 Internet Explorer를 시작할 때 적용됩니다.
윈도우 XP용
  1. Windows 탐색기를 열려면 시작을 마우스 오른쪽 단추로 클릭한다음 내 컴퓨터를 클릭합니다.
  2. 도구 메뉴에서 폴더 옵션을클릭한 다음 파일 유형 탭을 클릭합니다.
  3. HTM 파일 형식을 찾아 선택합니다.
  4. 인터넷 익스플로러가 프로그램으로 열기로 선택되어 있는지 확인합니다. Internet Explorer를 선택하지 않으면 [변경]을클릭하고 인터넷 탐색기를 권장 프로그램으로 선택한 다음 확인을클릭합니다.
  5. 다음 파일 형식에 대해 3단계와 4단계를 반복합니다. Html 그것의 Mht MTHML Xml Xsl

문제가 해결되었는지 확인합니다. 문제가 해결되면 이 문서가 완료된 것입니다. 문제가 해결되지 않으면 다음 방법으로 이동하십시오.

방법 3: 인터넷 익스플로러 추가 기능 없음 모드 사용

브라우저 추가 기능을 사용하면 온라인 환경을 개선할 수 있지만 컴퓨터의 다른 소프트웨어에 방해가 있거나 충돌할 수 있습니다. 그러나 추가 기능을 사용하지 않도록 설정하면 일부 웹 페이지 또는 Internet Explorer 자체가 올바르게 표시되지 않을 수 있습니다. 먼저 추가 기능을 일시적으로 사용하지 않도록 설정한 인터넷 탐색기를 시작하여 문제가 해결되었는지 확인합니다. (추가 기능은 일반적인 방법으로 Internet Explorer를 다시 시작할 때까지만 비활성화됩니다.) 이렇게 하려면 다음 단계를 따르십시오.
  • 시작을클릭하고 검색 상자에 인터넷 탐색기를 입력한 다음 인터넷 탐색기(추가 기능 없음)를 클릭합니다.
    정보 아이콘
    참고
    Windows XP의 경우 시작을 클릭하여 인터넷 탐색기 아이콘을 마우스 오른쪽 단추로 클릭한 다음 추가 기능 없이 찾아보기를 클릭합니다.
Internet Explorer 추가 기능 없음 모드로 문제가 해결되면 다음 단계를 수행하여 문제를 일으키는 브라우저 추가 기능을 식별합니다.
  1. 인터넷 탐색기를 시작하려면 시작을클릭한 다음 인터넷 탐색기를클릭합니다.
  2. 도구 단추를 클릭한 다음 추가 기능 관리를 클릭합니다.
  3. 이름 목록에서 추가 기능을 클릭한 다음 에서 사용 안 함을클릭합니다. 테스트 인터넷 익스플로러.
  4. 문제를 일으키는 추가 기능을 식별할 때까지 3단계를 반복합니다.

문제가 해결되었는지 확인합니다. 문제가 해결되면 이 문서가 완료된 것입니다. 문제가 해결되지 않으면 다음 방법을 시도해 보십시오.

방법 4: 인터넷 탐색기 설정 재설정

인터넷 익스플로러 설정이나 추가 기능이 손상되었거나 호환되지 않는 경우 일반적으로 Internet Explorer 설정을 기본 설정으로 재설정하여 문제를 해결할 수 있습니다. Internet Explorer 설정을 재설정하면 이전 설정이 모두 손실되어 복구할 수 없습니다. Internet Explorer 기본 설정을 복원하면 저장된 쿠키, 양식 데이터, 암호 또는 이전에 설치된 브라우저 추가 기능을 사용하는 일부 웹 페이지가 제대로 작동하지 않을 수 있습니다. 그러나 Internet Explorer를 기본 설정으로 재설정해도 즐겨찾기, 피드 및 기타 여러 개인 설정이 삭제되지는 않습니다. 인터넷 익스플로러 설정을 재설정하려면 다음 단계를 따르세요.
  1. 모든 인터넷 익스플로러 창을 닫습니다.
  2. 시작을 클릭하고 검색 상자에 inetcpl.cpl을 입력한 다음 프로그램 목록에서 inetcpl.cpl을 클릭합니다. 인터넷 옵션 대화 상자가 나타납니다.
    정보 아이콘
    Windows XP에 대 한 참고, 클릭 시작, 클릭 실행, 입력 inetcpl.cpl 열기 상자에, 다음 확인을클릭 합니다.
  3. 고급 탭을 클릭합니다.
  4. 인터넷 탐색기 재설정 설정에서재설정을 클릭합니다. 그런 다음 다시 재설정을 클릭합니다.
  5. Internet Explorer재설정이 완료되면 인터넷 탐색기 설정 재설정 대화 상자에서 닫기를 클릭합니다.
  6. 인터넷 익스플로러를 다시 시작합니다. 변경 사항은 다음에 Internet Explorer를 열 때 적용됩니다.
방법 5: 필요한 인터넷 익스플로러 DLL 파일을 다시 등록 
정보 아이콘
참고
이 정보는 Windows XP에 적용됩니다.DLL 파일을 다시 등록하려면 다음 단계를 따르십시오.
  1. 시작을클릭하고, 모든 프로그램을클릭하고, 액세서리를클릭하고, cmd를 마우스 오른쪽 단추로 클릭한 다음 관리자로 실행을선택합니다. 관리자 암호 또는 확인 을 묻는 메시지가 표시되면 암호를 입력하거나 확인을 제공합니다.
  2. 열기 상자에 regsvr32 urlmon.dll을 입력한 다음 확인을클릭합니다.
  3. 확인을 받으면 확인을 클릭합니다.
  4. 다음 명령에 대해 2단계와 3단계를 반복합니다. regsvr32 mshtml.dll regsvr32 shdocvw.dll regsvr32 브라우루이.dll regsvr32 msjava.dll
문제가 해결되었는지 확인합니다. 문제가 해결되면 이 문서가 완료된 것입니다. 문제가 해결되지 않으면 다음 섹션으로 이동하십시오.

고급 문제 해결 방법

이 섹션은 고급 컴퓨터 사용자를 위한 것입니다.방법 1: 새 사용자 계정 만들기 
사용자 프로필에 대한 자세한 내용은 사용자 프로필을참조하십시오.방법에 대한 자세한 내용은 다음 Microsoft 웹 사이트로 이동하십시오.

방법 2: 시스템 복원 사용

시스템 복원은 "지점 복원"을 사용하여 개인 파일에 영향을 주지 않고 시스템 파일 및 설정을 이전 시점으로 되돌아갑니다. 복원 지점은 매주 자동으로 생성되며 프로그램, 장치 또는 드라이버 설치와 같은 중요한 시스템 이벤트 직전에 자동으로 생성됩니다. 시스템 복원을 시작하기 전에 열려 있는 파일을 저장하고 모든 프로그램을 닫습니다. 복원 지점을 확인한 후 시스템 복원이 컴퓨터를 다시 시작합니다. 시스템 복원을 수행하려면 다음 단계를 따르십시오.윈도우 7 및 윈도우 비스타용
  1. 시작을클릭하고, 모든 프로그램을클릭하고, 액세서리를클릭하고, 시스템 도구를클릭한 다음 시스템 복원을 클릭합니다. 관리자 암호 또는 확인 을 묻는 메시지가 표시되면 암호를 입력하거나 확인을 제공합니다.
  2. 시스템 복원 페이지에서 다음을 클릭합니다.
  3. 원하는 시스템 복원 날짜 또는 설명을 선택합니다.
    정보 아이콘
    참고
    원하는 특정 날짜가 표시되지 않으면 더 많은 날짜 표시를선택한 다음 원하는 날짜를 선택합니다.
  4. 확인 창에서 완료를클릭합니다.
컴퓨터가 다시 시작됩니다. 프로세스가 완료되면 확인 메시지가 표시됩니다.윈도우 XP용 
  1. 관리 권한이 있는 계정을 사용하여 Windows에 로그온합니다.
  2. 시작을클릭하고, 모든 프로그램을클릭하고, 액세서리를클릭하고, 시스템 도구를클릭한 다음 시스템 복원을 클릭합니다.
  3. 시스템 복원 시작 페이지에서컴퓨터 복원을 이전 시간 옵션으로 선택한 다음 다음 을 클릭합니다.
  4. 복원 지점 선택 페이지에서 이 목록에서 가장 최근의 시스템 복원 지점을 클릭하고 복원 지점 목록을 클릭한 다음 다음을 클릭합니다.
  5. 복원 점 선택 확인 페이지에서 다음클릭합니다. 시스템 복원이전 창 XP 구성을 복원한 다음 컴퓨터를 다시 시작합니다.
  6. 관리자로 컴퓨터에 로그온합니다. 그런 다음 시스템 복원 완료 페이지에서 확인을 클릭합니다.
컴퓨터가 다시 시작됩니다. 프로세스가 완료되면 확인 메시지가 표시됩니다.시스템 복원을 사용하지만 여전히 문제가 발생하거나 다른 문제가 발생하는 경우 복원 작업을 취소할 수 있습니다. 작업을 취소한 후 다른 복원 지점을 사용하여 시도할 수 있습니다. 시스템 복원 작업을 취소하려면 다음 단계를 따르십시오.
  1. 시작을클릭하고, 모든 프로그램을클릭하고, 액세서리를클릭하고, 시스템 도구를클릭한 다음 시스템 복원을 클릭합니다.
  2. 시스템 복원 취소를클릭한 다음 다음을 클릭합니다.
  3. 선택 사항을 검토한 다음 완료를클릭합니다.
컴퓨터가 다시 시작됩니다. 프로세스가 완료되면 확인을 받게 됩니다.

추가 리소스


문제가 해결되었는지 확인합니다. 문제가 해결되면 이 문서가 완료된 것입니다. 문제가 해결되지 않으면 Microsoft 고객 지원 서비스를 사용하여 다른 해결 방법을 찾을 수도 있습니다. Microsoft 지원 서비스에는 다음이 포함됩니다.
  • Microsoft 기술 자료 검색: Microsoft 제품에 대한 기술 지원 정보 및 자가 도움말 도구를 찾습니다.
  • 솔루션 센터: 제품별 자주 묻는 질문 과 지원 하이라이트를 봅니다.
  • Microsoft 커뮤니티: 연락처, 동료 및 Microsoft 에서 가장 가치 있는 전문가(MVP)에게 문의하십시오.
  • 기타 지원 옵션:질문을 하거나 Microsoft 고객 지원 서비스에 문의하거나 피드백을 제공합니다.
Internet Explorer에 문제가 계속 발생하거나 질문을 하거나 Microsoft 지원에 문의하거나 피드백을 제공하려면 Microsoft 지원 웹 사이트를 방문하십시오.