.NET Framework 버전 및 플랫폼 지원에 대한 shim 오류

참고: 이 문서에서는 shim 오류 메시지를 소개합니다. 최종 사용자인 경우 "Windows 기능 대화 상자에서 .NET Framework을 활성화해야 합니다."라는 shim 오류가 발생하면 최종 사용자 해결 방법 을 시도하십시오. 기타 다른 shim 오류인 경우, 해당 컨텐츠에 대한 목표 대상은 응용 프로그램 공급 업체 또는 개발자이며, 응용 프로그램 공급 업체에 꼭 문의하여 이 응용 프로그램에 대한 문제가 있다는 것을 알려주어야 합니다.

오류: "Windows 기능 대화 상자에서 .NET Framework을 활성화해야 합니다"

이 응용 프로그램을 시작할 수 없습니다. Windows 기능 대화 상자에서 .NET Framework를 사용해야 합니다. (제어판에서, 프로그램을 선택한 다음, Windows 기능 설정/해제를 선택하십시오.)
응용 프로그램이 적절한 .NET Framework 런타임 버전을 확인할 수 있는 방식으로 구성되어있지 않았기 때문에 이 문제가 발생합니다. 해당하는 shim 코드는 SHIM_GOTO_CONTROLPANEL입니다.
이 문제를 해결하려면, Windows 7 및 Windows 8 운영 체제 기능인 .NET Framework 3.5를 활성화 합니다.


Windows 8의 경우
Windows 7의 경우



타사 솔루션 책임의 한계

오류: "이 응용 프로그램을 시작할 수 없습니다"

이 응용 프로그램을 시작할 수 없습니다.
응용 프로그램이 적절한 .NET Framework 런타임 버전을 확인할 수 있는 방식으로 구성되지 않았습니다. 해당하는 shim 코드는 SHIM_NOVERSION_FOUND입니다.
사용자는 구성 문제를 직접 해결할 수 없습니다. 이 문제를 해결하려면 응용 프로그램 공급업체에 문의하십시오.

오류: " 이 장치에서 지원되지 않는 NET Framework 버전에 의존되어 있습니다"

이 응용 프로그램을 시작할 수 없습니다. 이 문제는 이 장치에서 지원되지 않는 .NET Framework 버전을 사용과 관련되어 있습니다.
이 장치에서 실행 되도록 응용 프로그램이 빌드되지 않았기 때문에 이 문제가 발생합니다. 예를 들어, ARM 프로세서를 사용하는 장치에서, 인텔 프로세서용으로 작성된 응용 프로그램 실행을 시도하고 있는 경우에 해당될 수 있습니다. 해당하는 shim 코드는 SHIM_UNSUPPORTED_PLATFORM입니다.
사용자는 구성 문제를 직접 해결할 수 없습니다. 응용 프로그램의 적절한 버전을 설치하려면 응용 프로그램 공급 업체에 문의하십시오.

심(shim) 오류 메시지에 대해

Microsoft .NET Framework 응용 프로그램을 시작하면, shim 프로그램이 로드할 공용 언어 런타임(CLR) 버전을 결정하여 로드하고 응용 프로그램을 시작합니다. Shim에 오류가 발생하면(예: 컴퓨터에서 호환되는 버전의 .NET Framework를 찾을 수 없는 경우) 오류 메시지가 지침과 함께 표시됩니다. 이 문서는 오류 코드 SHIM_NOVERSION_FOUND, SHIM_GOTO_CONTROLPANELSHIM_UNSUPPORTED_PLATFORM에 대한 정보를 제공합니다.

.NET Framework 초기화 오류에 대한 자세한 내용은, 다음 MSDN 웹 페이지를 참조하십시오.

속성

문서 ID: 2715633 - 마지막 검토: 2017. 1. 8. - 수정: 1

피드백