Microsoft Access에서 Access 데이터베이스를 수동으로 분할 하는 방법

고급: 전문적인 코드 작성, 상호 운용성 및 다중 사용자 기술이 필요합니다.

이 문서에는 Microsoft Access 데이터베이스 (.mdb) 파일 또는 Microsoft Access 데이터베이스 (.accdb) 파일에 적용 됩니다.

요약

다양 한 이유로 프런트 엔드 응용 프로그램이 나 백 엔드 응용 프로그램 데이터베이스를 분할할 수 설정할 수 있습니다. 백 엔드 데이터베이스 테이블을 포함 하 고 파일 서버에 저장 됩니다. 프런트 엔드 데이터베이스는 백 엔드 테이블에 연결 되는 모든 폼, 쿼리, 보고서, 매크로, 및 모듈을 포함 합니다. 프런트 엔드 데이터베이스는 사용자의 워크스테이션에 배포 됩니다.

데이터베이스 분할 유틸리티를 사용 하 여 수동으로 대신의 데이터베이스를 분리 하는 방법을 설명 합니다.

자세한 내용

Microsoft Office Access 2003에서 및 이전 버전의 Access에서 데이터베이스를 분할 하려면 다음과이 같이 하십시오.
  1. 새 Access 데이터베이스를 만듭니다.
  2. 파일 메뉴에서 외부 데이터 가져오기가리킨 다음 가져오기를 클릭 하 고
  3. 찾아 분할할 데이터베이스를 선택 합니다.
  4. 테이블 탭에서 모두 선택을 클릭 한 다음 확인을 클릭 합니다.

    Access 백 엔드 데이터베이스를 새 데이터베이스로 모든 테이블 가져옵니다 있는지 확인 합니다.
  5. 새 백 엔드 데이터베이스를 네트워크 공유에 저장 하 고 모든 사용자가 공유에 대 한 모든 권한을 갖는지 확인 합니다.
  6. 두 번째 새 Access 데이터베이스를 만듭니다.
  7. 파일 메뉴에서 외부 데이터 가져오기를 가리킨 다음 테이블 연결을클릭 하 고
  8. 방금 만든 백 엔드 데이터베이스를 선택 합니다.
  9. 테이블 탭에서 모두 선택을 클릭 한 다음 확인을 누릅니다.

    프런트 엔드 데이터베이스를 Access 백 엔드 데이터베이스의 테이블 연결 있는지 확인 합니다.
  10. 파일 메뉴에서 외부 데이터 가져오기가리킨 다음 가져오기를 클릭 하 고
  11. 를 분할할 원래 데이터베이스를 선택한 다음 가져오기를 클릭 합니다.
  12. 탭에서 모두 선택을클릭 합니다. 테이블 탭을 제외한 모든 탭에서이 단계를 반복 합니다. 을 연결 된 테이블에 이미 있기 때문에 지금 하기만 하면 나머지 개체를 가져올 수 있습니다.
  13. 테이블을 제외한 개체를 모두 선택한 후 확인을 클릭 합니다.

    이제 모든 테이블이 연결을 나머지 개체를 가져온 확인 합니다.
Microsoft Office Access 2007에서 데이터베이스를 분할 하려면 다음과이 같이 하십시오.
  1. 새 Access 데이터베이스를 만듭니다.
  2. 외부 데이터 탭의 가져오기 그룹에서 Access 를 클릭 합니다.
  3. 외부 데이터 가져오기 대화 상자에서 분할을 테이블, 쿼리, 폼, 보고서, 매크로 및 모듈을 현재 데이터베이스. 가져오기 확인란을 선택한 다음 확인을 클릭 하 고 원하는 데이터베이스를 선택 하려면 찾아보기 를 클릭 합니다.
  4. 개체 가져오기 대화 상자에서 테이블 탭에서 모두 선택을 클릭 한 다음 확인을 클릭 합니다.

    Access 백 엔드 데이터베이스를 새 데이터베이스로 모든 테이블 가져옵니다 있는지 확인 합니다.
  5. 새 백 엔드 데이터베이스를 네트워크 공유에 저장 하 고 모든 사용자가 공유에 대 한 모든 권한을 갖는지 확인 합니다.
  6. 두 번째 새 Access 데이터베이스를 만듭니다.
  7. 외부 데이터 가져오기 그룹에서 Access 를 클릭 합니다.
  8. 외부 데이터 가져오기 대화 상자에서 만든 백 엔드 데이터베이스 테이블을 만들어 데이터 원본에 연결 확인란을 선택 하 여 선택한 다음 확인을 누릅니다 찾아보기 를 클릭 합니다.
  9. 개체 가져오기 대화 상자에서 테이블 탭에서 모두 선택을 클릭 한 다음 확인을 클릭 합니다.

    프런트 엔드 데이터베이스를 Access 백 엔드 데이터베이스의 테이블 연결 있는지 확인 합니다.
  10. 외부 데이터 가져오기 그룹에서 Access 를 클릭 합니다.
  11. 외부 데이터 가져오기 대화 상자에서 선택 하 고 분할할 원래 데이터베이스, 테이블, 쿼리, 폼, 보고서, 매크로 및 모듈을 현재 데이터베이스. 가져오기 확인란을 선택한 다음 확인을 클릭 합니다 찾아보기 를 클릭 합니다.
  12. 개체 가져오기 대화 상자에서 [ 양식 ] 탭에서 모두 선택을 클릭, 테이블에 이미 연결 되어 있기 때문에 테이블 탭을 제외한 다른 모든 탭에서이 단계를 반복 합니다. 이제만 하면 나머지 개체를 가져오고 다음 확인을 클릭 합니다.

    이제 모든 테이블이 연결을 나머지 개체를 가져온 확인 합니다.
참고

이 데이터베이스는 프런트 엔드 데이터베이스입니다. 각 사용자가 프런트 엔드 데이터베이스의 자신의 복사본을 워크스테이션에이 프런트 엔드 데이터베이스를 배포할 수 있습니다.

이제 데이터베이스 성능이 향상 됩니다 성공적으로 분할 한. 이제 사용자가 폼을 열면 폼 자신의 컴퓨터에서 로컬로 열리고 있고 네트워크를 통해 전송 되지 않습니다. 네트워크를 통해 제공 되는 유일한 데이터는 연결 된 테이블의 데이터입니다.

데이터베이스를 분할 해야 하는 이유

데이터베이스를 분할 하는 일반적인 이유는 다음과 같습니다.
  • 네트워크에서 여러 사용자와 데이터베이스를 공유 합니다.
  • 개발 데이터베이스에는 여러 사람이 있고 Microsoft Visual Sourcesafe 설치 권한이 없습니다.
  • 테이블 디자인을 변경할 수 있어야 사용자를 원하지 않는.
데이터베이스를 분할 하는 가장 일반적인 이유는 네트워크에서 여러 사용자와 데이터베이스를 공유 하 고 있음을. 단순히 사용자가 폼, 쿼리, 매크로, 모듈 또는 보고서를 열 때 네트워크 공유에 데이터베이스를 저장 합니다 이러한 개체를 네트워크를 통해 데이터베이스를 사용 하는 각 작업자에 게 보낼 수 해야 합니다. 데이터베이스를 분할 하면 각 사용자가 고유한 폼, 쿼리, 매크로, 모듈 및 보고서 복사본. 따라서 네트워크를 통해 전송 되어야 하는 테이블의 데이터입니다.

참고: 데이터베이스를 분할 하려면 데이터베이스 분할 유틸리티를 사용할 수 있습니다.
속성

문서 ID: 304932 - 마지막 검토: 2017. 2. 6. - 수정: 2

피드백