MARS 에이전트를 업그레이드하려고 할 때 오류 발생: Microsoft Azure Recovery Services 에이전트 업데이트 실패

이 문서에서는 이전 버전에서 MARS(Microsoft Azure Recovery Services) 에이전트의 최신 버전 또는 릴리스로 업그레이드하려고 할 때 발생하는 문제에 대한 증상과 해결 방법을 설명합니다.

원래 제품 버전: Azure Site Recovery
원래 KB 번호: 4020490

증상

Microsoft Azure Recovery Services 에이전트 업그레이드 마법사를 사용하여 MARS 에이전트를 업그레이드하려고 하면 업그레이드가 실패하고 다음 오류 메시지가 표시됩니다.

Microsoft Azure Recovery Service 에이전트 업데이트가 실패했습니다.
오류: RecoveryServicesManagementAgent 서비스를 시작할 수 없습니다. 패치 제거
문제: 1612 오류로 업데이트 설치 실패

원인

이 문제는 업그레이드가 Windows Installer 캐시에서 MARS 에이전트의 원본 설치 관리자를 찾을 수 없기 때문에 발생합니다. 업그레이드를 성공적으로 완료하려면 원본 설치 관리자가 필요합니다.

해결 방법

이 문제를 해결하려면 원본 설치 관리자가 Windows Installer 캐시에 있는지 확인합니다. 이렇게 하려면 다음과 같이 하십시오.

  1. Microsoft Azure Recovery Services 에이전트 업그레이드 마법사를 종료합니다.

  2. 폴더에 있는 C:\Windows\Temp OBPatch.log 파일을 엽니다.

  3. "경고: 로컬 캐시된 패키지"를 검색할 OBPatch.log 파일 내에서 오류 설명 줄을 찾습니다.

  4. 다음과 유사한 줄을 찾습니다. 경고:

    로컬 캐시된 패키지 'C:\Windows\Installer\Unique_ID.msi 없습니다.

  5. 나중에 참조할 theUnique_IDvalue.

  6. MARS 에이전트 업데이트 설치 관리자(.exe) 파일을 두 번 클릭합니다. 이렇게 하면 모든 설치 관련 이진 파일 및 설치 관리자 파일이 컴퓨터의 임시 위치에 복사되고 Microsoft Azure Recovery Services 에이전트 업그레이드 마법사가 열립니다.

    참고 12단계까지 마법사를 열어 둡니다.

  7. "C:\Windows\Temp" 폴더에 있는 OBInstaller0Curr.errlog 파일을 엽니다.

  8. "SetupLaunchScreen의 디렉터리 경로" 텍스트에서 Search 다음과 유사한 최신 타임스탬프를 사용하여 선을 찾습니다. SetupLaunchScreen용 디렉터리 경로: C:\Temp_ID.

  9. 폴더로 C:\Temp_ID\Installers 이동합니다.

  10. 이 폴더에서 OBSAGENT.msi 파일을 찾아 C:\Windows\Installer 폴더에 복사합니다. 대상 파일의 이름을 Unique_ID.msi로 바꿉니다.

  11. MARS 에이전트 업그레이드 마법사를 닫습니다.

  12. 업그레이드 설치 관리자를 실행하여 업그레이드를 설치합니다. 문제가 지속되면 Microsoft 지원 문의하세요.

도움을 요청하십시오.

질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.