.NET Framework 설치한 시스템에서 동기화 모니터링 에이전트에 대한 Connect Health를 Microsoft Entra 성능 저하 및 높은 CPU 사용량

이 문서에서는 Microsoft Entra .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 또는 4.7.2에 대한 .NET Framework 4.7.2 또는 2018년 7월 업데이트를 설치한 시스템의 동기화용 Connect Health 모니터링 에이전트에서 성능 저하 및 높은 CPU 사용량을 유발하는 문제를 설명합니다.

원래 제품 버전: Microsoft Entra ID
원본 KB 번호: 4457331

증상

.NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 또는 4.7.2에 대해 .NET Framework 4.7.2 또는 2018년 7월 업데이트를 설치한 시스템에서 동기화용 Microsoft Entra Connect Health 모니터링 에이전트를 실행한다고 가정합니다. 이 시나리오에서는 시스템에서 성능이 느리고 CPU 사용량이 높을 수 있습니다.

높은 CPU 사용량을 보려면 작업 관리자를 시작하고 프로세스 탭에서 MIcrosoft.Online.Reporting.MonitoringAgent.Startup 프로세스의 CPU 사용량을 확인 합니다 .

원인

이 문제는 Microsoft Entra Connect Health for Sync 모니터링 에이전트가 .NET Framework 4.7.2 또는 .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 또는 4.7.2에 대한 2018년 7월 업데이트를 완전히 지원하지 않기 때문에 발생합니다. 다음 업데이트로 인해 모니터링 에이전트의 CPU 사용량이 높아질 수 있습니다.

.NET Framework업데이트 서버 버전 업데이트 유형
KB 4340007 Windows Server 2008 보안
KB 4340556 Windows Server 2008 R2 보안
KB 4340004 Windows Server 2008 R2 보안
KB 4340557 Windows Server 2012 보안
KB 4340005 Windows Server 2012 보안
KB 4340558 Windows Server 2012 R2 보안
KB 4340006 Windows Server 2012 R2 보안
KB 4054542 Windows Server 2012 비보안
KB 4054566 Windows Server 2012 R2 비보안
KB 4054590 Windows Server 2016 비보안
KB 4338814 Windows Server 2016(빌드 14393.2363) 비보안
KB 4345418 Windows Server 2016(빌드 14393.2368) 비보안

해결 방법

이 문제를 resolve 환경에 적합한 업데이트를 설치합니다.

  • AD DS 및 AD FS에 대한 Connect Health의 경우

    2018년 7월에 릴리스된 Microsoft Entra Connect Health Agent 버전 3.1.7.0을 설치합니다. 이 업데이트는 [여기에서 다운로드]/azure/active-directory/hybrid/how-to-connect-health-agent-install#download-and-install-the-azure-ad-connect-health-agent)에 사용할 수 있습니다.

  • Microsoft Entra Connect의 경우

    이 높은 CPU 사용량 문제에 대한 수정 사항이 포함된 최신 버전의 Microsoft Entra Connect를 설치합니다. 이 버전은 여기에서 다운로드할 수 있습니다.

    참고

    Microsoft Entra Connect 서버에서 자동 업그레이드 기능을 사용하도록 설정한 경우 최신 버전이 자동으로 설치됩니다.

바이러스 검사 클레임

Microsoft는 파일이 게시된 날짜에 사용할 수 있는 최신 바이러스 감지 소프트웨어를 사용하여 이 파일에서 바이러스를 검사했습니다. 파일은 무단 변경을 방지하는 데 도움이 되는 보안 강화 서버에 저장됩니다.

도움을 요청하십시오.

질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.