Microsoft 365, Azure 또는 Intune 페더레이션된 사용자의 계정 문제 해결

문제

페더레이션된 계정을 사용하여 Microsoft 365, Microsoft Azure 또는 Microsoft Intune 같은 클라우드 서비스를 Microsoft에 인증하려고 하면 인증이 실패하고 다음 문제 중 하나 이상이 발생합니다.

  • 로그인 프롬프트에서 페더레이션된 사용자 이름을 사용하여 Usernamefield를 업데이트하려고 하면 브라우저 주소 표시줄에 "AD FS 엔드포인트 이름>에 <로그인" 링크https://login.microsoftonline.com/login.srf?..가 포함된 웹 페이지 대신 다음 예제와 유사한 URL이 포함됩니다.

  • 페더레이션된 계정을 사용하여 로그인하고 Microsoft 365, Outlook Web App, SharePoint Online 또는 비즈니스용 Skype Online(이전의 Lync Online)과 같은 클라우드 서비스 리소스에 액세스하려고 하면 다음 오류 메시지가 표시됩니다.

    액세스 거부

원인

이러한 문제가 일부 사용자 계정에 대해서만 발생하는 경우 이는 해당 사용자 계정이 온-프레미스 Active Directory 환경에서 잘못 설정되었음을 나타냅니다. 이 시나리오에서는 다음 항목 중 하나 이상이 잘못 설정될 수 있습니다.

  • 잘못된 UPN(사용자 계정 이름) 및 암호가 사용되고 있습니다.

  • UPN은 사용자 계정에 대해 업데이트되지 않습니다.

    이 경우 페더레이션된 도메인 이름을 반영하도록 각 ID 페더레이션 계정에 대한 UPN 접미사를 업데이트해야 합니다. 사용자 계정 UPN을 확인하려면 다음 단계를 수행합니다.

    1. 로컬 Active Directory 도메인 컨트롤러에서 시작을 클릭하고 모든 프로그램을 가리킨 다음 관리 도구를 클릭한 다음 Active Directory 사용자 및 컴퓨터 클릭합니다.
    2. 변경할 사용자 계정을 마우스 오른쪽 단추로 클릭한 다음 속성을 클릭합니다.
    3. 계정 탭에서 페더레이션된 네임스페이스의 UPN 접미사가 왼쪽 위 모서리의 목록에 나열되어 있는지 확인한 다음 확인을 클릭합니다.
  • Microsoft 365 사용자 계정은 Microsoft 365 리소스에 대한 라이선스가 없습니다.

    사용자 계정에 라이선스가 없는 Microsoft 365 리소스에 대한 액세스가 제한됩니다. 사용자 계정에 대한 라이선스 상태 검사 다음 단계를 수행합니다.

    1. Microsoft 365 관리 사용자 계정을 사용하여 Microsoft 365 포털(https://portal.office.com)에 로그인합니다. 필요한 경우 관리 계정을 사용할 수 있습니다.

    2. 관리 선택한 다음 왼쪽 탐색 창에서 사용자를 선택합니다.

    3. 사용자 목록에서 테스트할 사용자 계정을 찾은 다음 표시 이름을 선택합니다. 각 사용자 계정에 Microsoft 365 리소스에 필요한 라이선스가 있는지 확인합니다.

    4. 검사 모든 항목 선택 상자를 선택합니다.

      테스트하려는 사용자 계정이 나열되지 않은 경우 Active Directory 동기화가 계정을 Microsoft Entra ID 동기화할 수 있습니다.

      참고 사용자 계정에 온-프레미스 사서함이 있는 경우 Microsoft 365 사서함이 만들어지지 않습니다. 사용자 계정이 Exchange Online 라이선스가 부여된 경우에도 이 특정 리소스를 사용할 수 없습니다.

  • 하위 도메인은 부모 도메인의 페더레이션 설정을 상속하지 않습니다.

    subdomain.contoso.com 같은 하위 도메인이 부모 도메인 앞에 추가되면(예: contoso.com) 하위 도메인은 부모 도메인의 페더레이션 상태 자동으로 상속합니다. 상속 상태 확인하려면 다음 단계를 수행합니다.

    1. Microsoft 365 관리 사용자 계정을 사용하여 Microsoft 365(https://portal.office.com)에 로그인합니다. 필요한 경우 관리 계정을 사용할 수 있습니다.
    2. 관리 클릭한 다음 왼쪽 탐색 창에서 도메인을 클릭합니다.
    3. 도메인 목록에서 페더레이션된 하위 도메인 이름을 찾은 다음 도메인 유형 설정이 Single Sign-On으로 설정되어 있는지 여부를 확인합니다.
    4. 부모 도메인에 대해 1단계를 3단계로 반복합니다. 도메인 유형 설정이 하위 도메인 설정과 다른 경우 하위 도메인은 부모에서 분리되었습니다.
  • 디렉터리 동기화 문제로 인해 온-프레미스의 적절한 사용자 계정 구성이 Microsoft Entra ID 동기화되지 않습니다.

    SSO(Single Sign-On)는 온-프레미스 Active Directory 및 Microsoft Entra ID 모두 표시되는 동일한 사용자 계정을 사용합니다. 디렉터리 동기화는 각 온-프레미스 사용자 계정에 대해 동일한 Microsoft 365 사용자 계정을 만들도록 해야 합니다. 디렉터리 동기화가 온-프레미스 Active Directory 올바른 계정 설정을 Microsoft Entra ID 동기화하지 않으면 로그인이 실패할 수 있습니다.

해결 방법

이 문제를 resolve 하려면 다음 방법 중 하나 이상을 사용합니다.

  • 올바른 UPN 및 암호가 로그인에 사용되는지 확인합니다.

  • 페더레이션된 계정에 대해 UPN이 업데이트되지 않습니다.

    이 문제를 resolve 방법에 대한 자세한 내용은 다음 Microsoft 기술 자료 문서를 참조하세요.

    2392130 페더레이션된 사용자가 Microsoft 365, Azure 또는 Intune 로그인할 때 발생하는 사용자 이름 문제 해결

  • Microsoft 365 사용자 계정은 Microsoft 365 리소스에 대한 라이선스가 없습니다.

    이 문제를 resolve Microsoft 365 포털을 사용하여 라이선스가 필요한 사용자 계정에 적절한 라이선스를 할당합니다.

  • Microsoft 365 하위 도메인은 부모 도메인의 페더레이션 설정을 상속하지 않습니다.

    이 문제를 resolve Microsoft 365 포털에서 하위 도메인을 제거합니다. 도메인을 제거하는 방법에 대한 자세한 내용은 다음 Microsoft 웹 사이트를 참조하세요.

    도메인 제거

    도메인이 제거되면 도메인을 다시 만들어야 합니다.

    도메인을 다시 만들 때 하위 도메인은 부모 도메인의 도메인 유형 설정을 상속합니다.

    참고 하위 도메인이 이미 확인된 부모 도메인의 일부로 인식되므로 DNS TXT 레코드 또는 MX 레코드를 사용한 도메인 확인은 하위 도메인 다시 만들기에 필요하지 않습니다.

  • 디렉터리 동기화 문제로 인해 온-프레미스 사용자 계정 구성이 Windows Azure AD 제대로 동기화되지 않습니다.

    계정 불일치가 발생했는지 여부를 확인하려면 다음 단계를 수행합니다.

    1. 온-프레미스 Active Directory 사용자 계정을 사소한(임의) 변경합니다.

    2. 디렉터리 동기화를 강제 적용합니다. 동기화를 강제 적용하는 방법에 대한 자세한 내용은 다음 Microsoft 웹 사이트를 참조하세요.

      디렉터리 동기화 강제 적용

      동기화가 성공했는지 여부를 확인하는 방법에 대한 자세한 내용은 다음 Microsoft 웹 사이트를 참조하세요.

      디렉터리 동기화 확인

      사소한 변경 내용이 Microsoft 365 사용자 계정과 동기화되지 않으면 디렉터리 동기화 문제로 인해 이 문제가 발생할 수 있습니다.

      참고 사용자 계정이 이미 라이선스가 있는 경우 사용자의 UPN을 적절한 값으로 업데이트하지 않고 디렉터리 동기화가 성공적으로 동기화될 수 있습니다.

추가 정보

아직 해결되지 않았습니까? Microsoft 커뮤니티 또는 Microsoft Entra 포럼 웹 사이트로 이동합니다.