현재 오프라인 상태입니다. 인터넷에 다시 연결하기를 기다리고 있습니다.

Windows 7에서 Windows Anytime Upgrade 실행 시 Anytime Upgrade 실패 오류 [Step by Step]

현상
Windows 7에서 Windows Anytime Upgrade를 이용하여 업그레이드 진행 시 "Anytime Upgrade에 실패하였습니다. 온라인으로 이동하여 문제를 해결하십시오." 오류 메시지가 발생하면서 업그레이드에 실패합니다.



원인
Windows 7 SP1(서비스 팩 1) 설치가 실패한 후 SP1의 일부 구성 파일이 시스템에 그대로 남아 있기 때문에 발생하는 문제입니다.



해결 방법
이 문제를 자동으로 해결하려면 "해결 지원" 절로 이동하십시오. 이 문제를 직접 해결하려면 "직접 해결" 절로 이동하십시오.


해결 지원


이 문제를 자동으로 해결하려면 Fix it 단추나 링크를 클릭합니다. 파일 다운로드 대화 상자에서 실행을 클릭하고 Fix it 마법사의 단계를 따릅니다.



참고
  • 다른 언어 버전의 Windows에서도 자동 해결 기능을 사용할 수 있습니다.
  • 현재 문제가 있는 컴퓨터에서 작업하고 있지 않은 경우 Fix it 솔루션을 플래시 드라이브 또는 CD에 저장한 후 문제가 있는 컴퓨터에서 실행하십시오.


이제 "문제가 해결되었습니까?" 절로 이동하십시오.


직접 해결


dism 명령어를 이용하여 시스템에 잔류한 SP1 파일을 제거하여 문제를 해결할 수 있습니다.



경우 1: Windows 7 32비트일 경우
  1. [시작]Windows 시작 버튼을 클릭하고 검색 창에 cmd를 입력하세요.



  2. 상단의 프로그램 목록에서 [cmd]를 마우스 오른쪽 단추로 클릭한 후 [관리자 권한으로 실행]을 클릭하세요.


    주의사항사용자 계정 컨트롤 메시지가 나타나면 관리자 암호를 입력하거나 [예]를 클릭합니다.

  3. 명령 프롬프트 화면에서 dism /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364e35~x86~~6.1.1.17514를 입력한 후 Enter를 누르세요.



  4. 작업이 완료되면 컴퓨터를 다시 시작하고 Windows Anytime Upgrade를 실행하여 문제가 해결되었는지 확인해 보세요.



경우 2: Windows 7 64비트일 경우
  1. [시작]Windows 시작 버튼을 클릭하고 검색 창에 cmd를 입력하세요.



  2. 상단의 프로그램 목록에서 [cmd]를 마우스 오른쪽 단추로 클릭한 후 [관리자 권한으로 실행]을 클릭하세요.


    주의사항사용자 계정 컨트롤 메시지가 나타나면 관리자 암호를 입력하거나 [예]를 클릭합니다.

  3. 명령 프롬프트 화면에서 dism /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17105를 입력한 후 Enter를 누르세요.


    주의사항위 명령어를 실행했을 때 "지정된 패키지는 올바른 Windows 패키지가 아닙니다." 메시지가 나타날 수도 있습니다. 이 경우 4번의 해결 방법을 그대로 진행합니다.

  4. dism /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514를 입력한 후 Enter를 누르세요.



  5. 작업이 완료되면 컴퓨터를 다시 시작하고 Windows Anytime Upgrade를 실행하여 문제가 해결되었는지 확인해 보세요.


문제가 해결되었습니까?

  • 문제가 해결되었는지 확인합니다. 문제가 해결된 경우는 이 절에 설명된 작업이 끝난 것이지만 문제가 해결되지 않은 경우에는 기술 지원 서비스에 문의할 수 있습니다.
  • 의견을 보내 주셔서 감사합니다. 의견을 보내거나 이 해결 방법에 대한 문제점을 보고하려면 "Fix it for me" 블로그에 의견을 남겨 주시거나 전자 메일을 보내 주십시오.


의견 보내기
의견 보내기
Microsoft 고객지원 사이트에서는 고객님의 소리를 귀담아 듣습니다. 아래 의견 보내기로 소중한 의견보내주시기 바랍니다.
속성

문서 ID: 2660015 - 마지막 검토: 05/23/2014 09:14:00 - 수정: 2.3

Windows 7 Home Premium, Windows 7 Professional

  • kbstepbystep kbtshoot kbfixme kbmsifixme KB2660015
피드백
/html>pendChild(m);