"보호를 구성 하는 입력에 대 한 적절 한 형식이" Azure VM의 백업을 사용 하는 PowerShell을 실행 하는 동안 오류가 발생 했습니다.

이 문서는 Microsoft 기계 번역 소프트웨어를 이용하여 번역되었으며 Microsoft Community에 의한 Community Translation Framework(CTF) 기술 혹은 사람이 번역한 내용에 의하여 사후 편집될 수 있습니다. Microsoft는 Knowledge Base에 있는 모든 문서에 다양한 언어로 접근할 수 있도록 하기 위하여 기계 번역, 사람에 의한 번역 및 커뮤니티가 편집한 내용을 모두 제공합니다. 번역된 문서는 어휘, 구문 및/혹은 문법에 오류가 있을 수 있습니다. Microsoft는 번역 오류로 인한 부정확성, 오류 및/또는 손해와 이를 고객이 사용하는 데에 대하여 책임을 지지 않습니다.

이 문서의 영문 버전 보기:3172632
증상
Usinga 이전 버전의 Microsoft Azure PowerShellthat 1.5.1에서 Microsoft Azure Vm (가상 컴퓨터)에 대 한 백업을 사용 하도록 설정 하면 다음과 유사한 오류 메시지가 나타납니다.

PS: C:\WINDOWS\system32 > 사용-AzureRmRecoveryServicesBackupProtection-$policy 정책-이름 BackupItemName -ResourceGroupName ResourceGroupName
-AzureRmRecoveryServicesBackupProtection 사용 가능:
BMSUserErrorInvalidConfigureProtectionRequest: 입력에 대 한 보호 구성에 적절 한 형식
컨테이너 존재 하 고 다른 매개 변수를 올바른 형식이 있는지 확인 하십시오
원인
이 문제는이 업데이트 트리거 errorin 전 1.5.1 버전의 Azure PowerShell cmdlet Microsoft Azure 복구 서비스 볼트에 대 한 중요 한 보안 수정 프로그램에 대 한 업데이트 된 때문에 발생 합니다.
해결 과정
이 문제를 해결 하려면 다운로드 및 설치 최신 버전의 Azure PowerShell.To 이렇게 이동 하십시오 Azure 다운로드 > 명령줄 도구 > PowerShell > Windows를 설치합니다.

이렇게 하면 다음과 같은 다운로드 페이지가 나타납니다.

다운로드 페이지에 대 한 스크린 샷을

경고: 이 문서는 자동으로 번역되었습니다.

속성

문서 ID: 3172632 - 마지막 검토: 07/21/2016 20:31:00 - 수정: 2.0

Microsoft Azure Recovery Services

  • kbsurveynew kbprb kbfix kbexpertiseadvanced kbmt KB3172632 KbMtko
피드백