Internet Explorer에서 사용하는 도메인 간 보안 모델의 적용을 강화하는 보안 업데이트를 사용할 수 있다

이 문서가 보관되었습니다. "그대로" 제공되었으며, 업데이트가 되지 않을 것입니다.
소개
Internet Explorer에서 사용하는 도메인 간 보안 모델의 적용을 강화하는 보안 업데이트를 사용할 수 있습니다. 이 문서에서는 개발자에게 이러한 변경에 대해 알리고 이러한 변경으로 인해 코드가 영향을 받는 경우 개발자가 사용할 수 있는 해결 방법에 대해 설명합니다.
추가 정보
보안 게시판 MS04-025는 Internet Explorer에서 도메인 간 보안 모델의 적용을 강화합니다. 보안 게시판 MS04-025에 대한 자세한 내용은 다음 Microsoft 웹 사이트를 참조하십시오.도메인 간 보안 모델에 대한 자세한 내용은 다음 Microsoft 웹 사이트를 참조하십시오.

Internet Explorer 기반 코드에 대한 변경

Internet Explorer 기반 코드가 이러한 변경의 영향을 받으면 제품의 보안 관련 사항을 검토하고 Internet Explorer 기반 코드를 다음과 같이 변경하는 것이 좋습니다.

DHTML 스크립트 액세스가 탐색 중 제거됨

보안 컨텍스트가 탐색 중 변경되면 Internet Explorer 개체 모델에 대한 스크립트 액세스가 즉시 제거됩니다. 이것은 한 보안 컨텍스트의 스크립트가 다른 보안 컨텍스트의 개체 모델에 액세스하는 것을 방지합니다. 이 문제를 해결하려면 탐색 후 개체에 액세스하지 않아도 되도록 DHTML 스크립트를 업데이트하십시오.

이진 코드에서 실행되는 스크립트 URL에 대한 컨텍스트 적용

IDispatch 인터페이스와 IDispatchEx 인터페이스를 사용하는 이진 코드에서 스크립트 URL을 실행하는 컨텍스트가 적용됩니다. 예를 들어, ActiveX 컨트롤과 같은 이진 개체가 JavaScript 프로토콜을 사용하여 스크립트를 실행하려고 하면 이 실행이 실패합니다. 이 문제를 해결하려면 execScript 메서드나 setTimeout 메서드를 사용하여 이진 코드에서 스크립트를 실행하십시오.

자세한 내용은 다음 Microsoft 웹 사이트를 방문하십시오.



Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹에 참여하시기 바랍니다.
access denied permission denied script error KB867801 cross-frame
속성

문서 ID: 875345 - 마지막 검토: 01/12/2015 23:56:27 - 수정: 1.1

  • Microsoft Internet Explorer 6.0
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer (Programming) 6.0
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.01
  • kbnosurvey kbarchive kbinfo kbbug kbpending KB875345
피드백