Microsoft Dynamics GP를 시작할 때 "사용자 활동 파일에서 로그인이 제거되었으며 회계 시스템에 있을 수 없습니다." 오류 메시지

이 문서에서는 Microsoft Dynamics GP를 시작할 때 발생하는 오류에 대한 솔루션을 제공합니다.

적용 대상: Microsoft Dynamics GP
원래 KB 번호: 916679

증상

Microsoft Dynamics GP를 시작하면 다음과 같은 오류 메시지가 표시됩니다.

로그인이 사용자 활동 파일에서 제거되었으며 회계 시스템에 있을 수 없습니다.

원인

이 문제는 자동 클라이언트 업데이트가 게시될 때 발생합니다. 또한 Microsoft Windows Installer 파일(.msp 파일)의 경로가 잘못되었거나 .msp 파일이 없습니다.

해결 방법

이 문제를 해결하려면 다음 방법 중 하나를 사용하세요.

방법 1

클라이언트 업데이트가 모든 클라이언트에 이미 설치된 경우 게시된 클라이언트 업데이트를 삭제합니다. 이렇게 하려면 다음 단계를 따르세요.

  1. 시스템 관리자(sa) 사용자 계정을 사용하여 Microsoft Dynamics GP에 로그인합니다.
  2. 적절한 단계를 사용합니다.
    • Microsoft Dynamics GP에서 Microsoft Dynamics GP 메뉴의 도구를 가리키고 설치 프로그램을 가리킨 다음 시스템을 가리킨 다음 클라이언트 업데이트 선택합니다.
    • Microsoft Dynamics GP 9.0에서 도구 메뉴에서 설치 프로그램을 가리킨 다음 시스템을 가리킨 다음 클라이언트 업데이트 선택합니다.
  3. 자동화된 클라이언트 업데이트 관리 창에서 업데이트 이름 상자 옆에 있는 아이콘을 선택합니다.
  4. 업데이트 창에서 설치한 업데이트를 선택한 다음 선택을 선택합니다.
  5. 자동화된 클라이언트 업데이트 관리 창에서 삭제를 선택합니다.

방법 2

클라이언트 업데이트를 유지하려면 .msp 파일이 있고 .msp 파일의 경로가 올바른지 확인합니다. 이렇게 하려면 다음 단계를 따르세요.

  1. sa 사용자 계정을 사용하여 Microsoft Dynamics GP에 로그인합니다.
  2. 도구 메뉴에서 설치 프로그램을 가리킨 다음 시스템을 가리킨 다음 클라이언트 업데이트 선택합니다.
  3. 자동화된 클라이언트 업데이트 관리 창에서 업데이트 이름 상자 옆에 있는 아이콘을 선택합니다.
  4. 업데이트 창에서 .msp 파일의 경로가 올바른지 확인합니다. 경로가 올바르지 않으면 수정합니다.
  5. .msp 파일이 경로 끝에 있는 디렉터리에 있는지 확인합니다.

방법 3

시스템에 로그인할 수 없는 경우 DYNAMICS 데이터베이스의 자동 클라이언트 업데이트 테이블에서 자동 클라이언트 업데이트를 제거합니다. 이렇게 하려면 다음 단계를 따르세요.

  1. DYNAMICS 데이터베이스의 백업이 있는지 확인합니다.

  2. SQL 쿼리 분석기 또는 SQL Server Management Studio 엽니다.

  3. 모든 자동 클라이언트 업데이트를 표시하려면 다음 SQL 문을 실행합니다.

    select * from DYNAMICS..SYUPDATE
    
  4. 유효한 UNCPath가 없는 자동 클라이언트 업데이트를 제거합니다. 이렇게 하려면 다음 스크립트를 실행합니다.

    delete DYNAMICS..SYUPDATE where UPDATENAME = 'XXXX'
    

    참고

    'XXXX'를 올바른 업데이트 이름으로 바꿉 있습니다.

  5. Microsoft Dynamics GP에 로그인합니다.

상태

Microsoft는 적용 대상 섹션에 나열된 Microsoft 제품의 문제임을 확인했습니다. 이 문제는 수정되도록 예약되지 않았습니다.