현재 오프라인 상태입니다. 인터넷에 다시 연결하기를 기다리고 있습니다.

MS10-022: 2010년 4월 13일자 VBScript(Visual Basic Scripting) 5.6용 보안 업데이트에 대한 설명

Windows XP에 대한 지원이 종료되었습니다.

Microsoft는 2014년 4월 8일 Windows XP에 대한 지원을 종료했습니다. 이러한 변경에 따라 해당 소프트웨어 업데이트 및 보안 옵션이 영향을 받습니다. 사용자에게 미치는 영향 및 계속 보호를 받는 방법에 대해 알아보십시오.

2015년 7월 14일 Windows Server 2003 지원 종료

Microsoft는 2015년 7월 14일 Windows Server 2003에 대한 지원을 종료했습니다. 이러한 변경에 따라 해당 소프트웨어 업데이트 및 보안 옵션이 영향을 받습니다. 사용자에게 미치는 영향 및 계속 보호를 받는 방법에 대해 알아보십시오.

소개
Microsoft는 보안 공지 MS10-022를 발표했습니다. 보안 공지 전체 내용을 보려면 다음 Microsoft 웹 사이트 중 하나를 방문하십시오.

이 보안 업데이트에 대한 도움과 지원을 받는 방법

일반 사용자의 경우 미국과 캐나다에서는 1-866-PCSAFETY로 전화를 하거나 기타 지역에서는 해당 지역의 Microsoft 지사에 연락하여 무료 지원을 받을 수 있습니다. 보안 업데이트와 관련된 문제에 대한 지원을 받기 위해 해당 지역의 Microsoft 지사에 연락하는 방법에 대한 자세한 내용은 다음 Microsoft 국가별 지원 웹 사이트를 참조하십시오. 북미 고객은 다음 Microsoft 웹 사이트를 방문하여 무제한 무료 전자 메일 지원이나 무제한 개인 채팅 지원을 즉시 받을 수도 있습니다. 기업 고객의 경우 통상적인 지원 담당자를 통해 보안 업데이트에 대한 지원을 받을 수 있습니다.
추가 정보

이 보안 업데이트에 대한 추가 정보

알려진 문제

우리는 다음 모든 조건이 충족되는 제한된 범위의 컴퓨터에 영향을 미치는 문제점을 알고 있습니다.
  • Windows XP 서비스 팩 3이 설치되어 있습니다.
  • 이전 버전의 Windows 스크립트 호스트 5.6이 수동으로 설치되었습니다.
참고 기본적으로 Windows XP 서비스 팩 3은 Windows 스크립트 호스트 5.7을 설치합니다. 이 알려진 문제는 이전 버전의 Windows 스크립트 호스트가 수동으로 설치되어 있는 컴퓨터로 제한됩니다(설치 작업을 누가 수행했는지는 관계 없음).

이 알려진 문제의 영향을 받는 컴퓨터에는 예기치 않은 Vbsript.dll 버전이 있기 때문에 이 보안 업데이트가 설치되지 않을 수 있습니다. Windows XP 서비스 팩 3에 이 보안 업데이트를 설치하려면 Vbscript.dll 파일 버전이 적어도 5.7 이상이어야 합니다.

Windows XP 서비스 팩 3이 실행되는 컴퓨터에서 이 알려진 문제를 해결하려고 하며 Vbscript.dll 파일 버전이 5.6인 경우 컴퓨터에 설치되어 있는 Windows Internet Explorer 버전에 따라 다음 방법 중 하나를 사용하십시오.

Internet Explorer 6
  1. Vbscript.dll을 원하는 파일 버전으로 복원합니다.

    Vbscript.dll을 버전 5.7로 복원하려면 다음 중 하나를 수행하십시오.
    • Windows XP용 KB951978 스크립트 엔진 다운로드 및 설치합니다.
      951978 Windows Vista 서비스 팩 1, Windows Server 2008 또는 Windows XP 서비스 팩 3에서 VBScript 또는 JScript 스크립트를 실행할 때 스크립트 출력이 예상대로 표시되지 않음
      참고 자동 업데이트를 사용하도록 설정한 경우 이 업데이트가 자동으로 제공됩니다.
    • Internet Explorer 8로 업그레이드합니다. Internet Explorer 8을 구하는 방법에 대한 자세한 내용은 다음 Microsoft 웹 사이트를 참조하십시오.참고 자동 업데이트를 사용하도록 설정한 경우 이 업데이트가 자동으로 제공됩니다.
    • Internet Explorer 7로 업그레이드합니다. Internet Explorer 7을 구하는 방법에 대한 자세한 내용은 다음 Microsoft 웹 사이트를 참조하십시오.
  2. 보안 업데이트를 설치합니다.

    여기에 설명된 대로 Vbscript.dll을 원하는 버전으로 복원한 후에는 보안 공지 MS10-022에 설명된 대로 Windows XP 서비스 팩 3용 VBScript 5.7 보안 업데이트(KB981349)를 설치합니다.

    참고 이 보안 업데이트는 Vbscript.dll 버전이 5.7.0.0 이상일 경우 자동 업데이트를 통해 제공됩니다.
Internet Explorer 7
  1. Vbscript.dll을 원하는 파일 버전으로 복원합니다.

    Vbscript.dll을 버전 5.7로 복원하려면 다음 중 하나를 수행하십시오.
    • Windows XP용 KB951978 스크립트 엔진 다운로드 및 설치합니다.
      951978 Windows Vista 서비스 팩 1, Windows Server 2008 또는 Windows XP 서비스 팩 3에서 VBScript 또는 JScript 스크립트를 실행할 때 스크립트 출력이 예상대로 표시되지 않음
      참고 자동 업데이트를 사용하도록 설정한 경우 이 업데이트가 자동으로 제공됩니다.
    • Internet Explorer 8로 업그레이드합니다. Internet Explorer 8을 구하는 방법에 대한 자세한 내용은 다음 Microsoft 웹 사이트를 참조하십시오.참고 자동 업데이트를 사용하도록 설정한 경우 이 업데이트가 자동으로 제공됩니다.
    • Internet Explorer 7을 제거한 후 Internet Explorer 7을 다시 설치합니다.
  2. 보안 업데이트를 설치합니다.

    여기에 설명된 대로 Vbscript.dll을 원하는 버전으로 복원한 후에는 보안 공지 MS10-022에 설명된 대로 Windows XP 서비스 팩 3용 VBScript 5.7 보안 업데이트(KB981349)를 설치합니다.

    참고 자동 업데이트를 사용하도록 설정한 경우 이 업데이트가 자동으로 제공됩니다.
Internet Explorer 8

Internet Explorer 8을 설치했으며 자동 업데이트를 사용하도록 설정한 경우 올바른 업데이트가 자동으로 제공되며 추가 작업을 수행할 필요가 없습니다. 이 보안 업데이트를 수동으로 설치해야 할 경우 보안 공지 MS10-022에 설명된 대로 Windows XP 서비스 팩 3용 VBScript 5.8 보안 업데이트(KB981349)를 다운로드하여 설치합니다.

이 보안 업데이트 적용에 대한 전제 조건

이 보안 업데이트를 설치하려면 Microsoft VBScript(Visual Basic Scripting Edition) 5.6이 컴퓨터에 설치되어 있어야 합니다.

VBScript 5.6은 다음 프로그램에 의해 설치됩니다.
  • Microsoft Internet Explorer 6
  • Windows Server 2003(버전에 x86 기반 SP2, x64 기반 SP2 및 Itanium 기반 SP2 포함)
  • Windows XP(버전에 x86 기반 SP2 및 x64 기반 SP2 포함)
  • Windows 스크립트 호스트 5.6
컴퓨터에 설치된 Access의 버전을 확인하려면 다음 단계를 수행하십시오.
  1. Windows 탐색기를 엽니다.
  2. 다음 디렉터리를 찾습니다.
    %systemroot%\system32
  3. Vbscript.dll 파일을 마우스 오른쪽 단추로 클릭하고속성을 클릭합니다.
  4. 세부 정보 탭을 클릭하여 파일 버전 필드를 확인합니다.
파일 버전이5.6.0.8825와 같이 5.6로 시작되면 컴퓨터에 VBScript 5.6이 설치되어 있는 것입니다.

제거 정보

이 보안 업데이트를 제거하려면 다음 중 하나를 수행하십시오.
  • 제어판의 프로그램 추가/제거 항목을 사용합니다.
  • 다음 폴더에 있는 Spuninst.exe 유틸리티를 사용합니다.
    %Windir%\$NTUninstallKB981350$\Spuninst

다시 시작 정보

이 보안 업데이트를 적용한 후에 컴퓨터를 다시 시작해야 할 수 있습니다.

파일 정보

이 보안 업데이트의 영어(미국) 버전은 다음 표에 나열된 파일 특성(또는 그 이후의 파일 특성)을 갖습니다. 이 파일의 날짜와 시간은 UTC(협정 세계시)로 나열되며 파일 정보를 볼 때 현지 시간으로 변환됩니다. UTC와 현지 시간의 차이를 보려면 제어판의 날짜/시간 도구에서 표준 시간대 탭을 사용하십시오.
지원되는 모든 x86 기반 버전의 Windows 2000 SP4
File nameFile versionFile sizeDateTimePlatform
Vbscript.dll5.6.0.8838401,40812-Mar-201021:44x86
지원되는 모든 x86 기반 버전의 Windows XP SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838417,79210-Mar-201008:02x86SP2SP2GDR
Vbscript.dll5.6.0.8838417,79210-Mar-201008:07x86SP2SP2QFE
지원되는 모든 x86 기반 버전의 Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838401,40809-Mar-201005:20x86SP2SP2GDR
Vbscript.dll5.6.0.8838401,40809-Mar-201005:27x86SP2SP2QFE
지원되는 모든 x64 기반 버전의 Windows Server 2003 SP2 및 Windows XP Professional SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.8838663,04009-Mar-201004:43x64SP2SP2GDR
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:43x86SP2SP2GDR\WOW
Vbscript.dll5.6.0.8838663,55209-Mar-201004:38x64SP2SP2QFE
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:38x86SP2SP2QFE\WOW
지원되는 모든 Itanium 기반 버전의 Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vbscript.dll5.6.0.88381,116,67209-Mar-201004:41IA-64SP2SP2GDR
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:41x86SP2SP2GDR\WOW
Vbscript.dll5.6.0.88381,117,69609-Mar-201004:38IA-64SP2SP2QFE
Wvbscript.dll5.6.0.8838401,40809-Mar-201004:38x86SP2SP2QFE\WOW
update security_patch security_update security bug flaw vulnerability malicious attacker exploit registry unauthenticated buffer overrun overflow specially-formed scope specially-crafted denial of service dos
속성

문서 ID: 981350 - 마지막 검토: 04/16/2010 16:22:43 - 수정: 1.1

  • Microsoft Internet Explorer 6.0
  • Microsoft Windows Server 2003 Service Pack 2
  • Microsoft Windows XP Service Pack 2
  • Microsoft Windows 2000 서비스 팩 4
  • kbsurveynew kbfix kbbug kbsecvulnerability kbsecbulletin kbsecurity kbqfe kbexpertiseinter KB981350
피드백