외부 데이터 범위 및 속성 관리

외부 데이터 범위의 속성을 변경하여 데이터베이스, 웹 쿼리 또는 텍스트 파일과 같은 외부 데이터 원본에 대한 연결을 통해 워크시트로 가져온 데이터를 제어할 수 있습니다.

외부 데이터 범위는 워크시트에 가져온 데이터의 위치를 정의하는 정의된 이름 또는 테이블 이름입니다. 외부 데이터에 연결하면 Excel에서 자동으로 외부 데이터 범위를 만듭니다. 이 예외는 데이터 원본에 연결된 피벗테이블 보고서뿐입니다. 피벗테이블 보고서는 외부 데이터 범위를 사용하지 않습니다. Excel에서는 외부 데이터 범위를 서식을 지정하고 배치하거나 다른 데이터와 같은 계산에 사용할 수 있습니다.

외부 데이터 범위 속성

외부 데이터 범위에는 셀 서식 및 열 너비 보존과 같은 데이터를 제어하는 데 사용할 수 있는 추가 속성(쿼리 또는 연결 속성과 혼동하지 않는)이 있습니다. 데이터 탭의 연결 그룹에서 속성을 클릭하여 이러한 외부 데이터 범위 속성을 변경할 있습니다. 그런 다음 다음을 수행하여 변경합니다.

  • Microsoft 쿼리 및 데이터 연결 마법사에서 만든 외부 데이터 범위의 경우 외부 데이터 속성 대화 상자를 사용합니다.

  • HTML 데이터를 검색하는 가져온 텍스트 파일 또는 웹 쿼리에서 만든 외부 데이터 범위의 경우 외부 데이터 범위 속성 대화 상자를 사용합니다.

  • XML 데이터를 검색하는 웹 쿼리에서 만든 외부 데이터 범위의 경우 XML 맵 속성 대화 상자를 사용합니다.

  1. 를 검색할 워크시트 를 외부 데이터 범위.

  2. 수식 입력줄 에서 이름 상자 옆에 있는 화살표를 클릭한 다음 원하는 외부 데이터 범위의 이름을 클릭합니다.

  1. 이름 관리자에 >수식을 선택합니다.

  2. Name Manager 대화 상자에서 외부 데이터 범위의 이름을 클릭한 다음 편집을 클릭합니다. 이름을 두 번 클릭해도 됩니다.

  3. 이름 편집 대화 상자에 이름 상자에 참조에 대한 새 이름을 입력합니다.

참고: 닫기 단추는 Name Manager 대화 상자만 닫습니다. 이미 변경한 내용을 커밋하기 위해 닫기 를 클릭할 수 없습니다.

Microsoft 쿼리, 가져온 텍스트 파일, 웹 쿼리 또는 데이터 연결 마법사에서 만든 외부 데이터 범위에 대한 원본 쿼리를 변경할 수 있습니다.

  1. 내부 쿼리를 변경하려는 외부 데이터 범위에서 셀을 클릭합니다.

  2. 데이터 >를 선택합니다.

  3. 외부 데이터 속성 대화 상자에서 연결 속성 속성 .

  4. 연결 속성 대화 상자에서 정의 탭을 클릭한 다음 쿼리 편집 을 클릭합니다.

Microsoft Query에서 쿼리 생성 및 편집에 대한 자세한 내용은 Microsoft 쿼리 도움말을 참조하세요.

  1. 내부 쿼리를 변경하려는 외부 데이터 범위에서 셀을 클릭합니다.

  2. 쿼리 > 연결 & 연결 탭을> 원하는 연결을 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  3. 연결 속성 대화 상자에서 정의 탭을 클릭한 다음 쿼리 편집 을 클릭합니다.

  4. 텍스트 파일 가져오기 대화 상자에서 가져오기 를 클릭합니다.

  5. 텍스트 가져오기 마법사에서 가져온 텍스트 파일을 변경한 다음 완료를 클릭합니다.

    텍스트 파일 가져오기에 대한 자세한 내용은 텍스트 파일 가져오기 또는 내보내기 를 참조하세요.

  1. 내부 쿼리를 변경하려는 외부 데이터 범위에서 셀을 클릭합니다.

  2. 데이터 >를 선택합니다.

  3. 쿼리 > 연결 & 연결 탭을> 원하는 연결을 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다.

  4. 연결 속성 대화 상자에서 정의 탭을 클릭한 다음 쿼리 편집 을 클릭합니다.

  5. 웹 쿼리 편집 대화 상자에서 웹 쿼리를 변경한 다음 완료를 클릭합니다.

웹 쿼리 만들기 및 편집에 대한 자세한 내용은 웹 페이지에 연결 을 참조하세요.

  1. 내부 쿼리를 변경하려는 외부 데이터 범위에서 셀을 클릭합니다.   

  2. 데이터 >를 선택합니다.

  3. 외부 데이터 속성 대화 상자에서 연결 속성 속성 .

  4. 연결 속성 대화 상자에서 정의 탭을 클릭합니다.

  5. 다음 중 하나를 수행합니다.

    • 명령 유형 상자에서표를 클릭한 다음 명령 텍스트 상자에서 값을 적절한 테이블, 보기 또는 쿼리의 이름으로 변경합니다.

    • 명령 유형 상자에서 SQL 또는 기본값을 클릭한 다음 명령 텍스트 상자에서 SQL 문을 편집합니다.

      참고: 연결이 정의된 방식에 따라 명령 형식 상자를 사용할 수 없습니다(어리게 표시).

  1. 수식 표시줄에서 이름 상자 옆에 있는 화살표를 클릭하고복사할 외부 데이터 범위의 이름을 선택합니다.

    Excel 테이블의 경우 범위의 이름을 선택한 다음 CTRL+A를 눌러 표 헤더를 선택합니다.

    외부 데이터 범위에 포함되지 않은 열 레이블 또는 수식을 포함하려면 복사할 열 레이블 또는 수식이 포함된 셀을 선택합니다. 수식 표시줄의 이름 상자 옆에 있는 화살표를 클릭하고 복사할 외부 데이터 범위의 이름을 클릭합니다.

  2. 복사를 >선택합니다.

  3. 외부 데이터 범위를 붙여넣을 통합 문서로 전환합니다.

  4. 의 왼쪽 위 셀을 붙여 넣을 영역.

    워크시트가 외부 데이터 대체하지 않도록하려면 워크시트에 클릭한 셀의 오른쪽 또는 아래에 데이터가 없는지 확인하세요.

  5. 탭의 클립보드 그룹에서 붙여넣기를 클릭합니다.

참고: 외부 데이터 범위의 일부만 복사하는 경우 쿼리 복사되지 않습니다. 복사된 데이터를 새로 고칠 수 없습니다.

데이터를 새로 고칠 때 Excel에 반환되는 더 작거나 큰 데이터 집합을 처리하는 방법을 제어할 수 있습니다.

  1. 데이터 >를 선택합니다.

  2. 외부 데이터 범위 속성 대화 상자의 새로 고침 시 데이터 범위의 행 수가 변경되는 경우 다음중 하나를 클릭합니다.

    • 새 데이터에 대한 셀 삽입, 사용되지 않는 셀 삭제

      참고 사항: 

      • 데이터 원본에 하나 이상의 행을 추가하면 외부 데이터 범위 바로 아래 셀이 아래로 이동하지만 외부 데이터 범위의 오른쪽에 있는 셀은 이동하지 않습니다.

      • 데이터 원본에서 하나 이상의 행이 삭제되면 외부 데이터 범위 바로 아래 셀이 올라가지만 외부 데이터 범위의 오른쪽에 있는 셀은 이동하지 않습니다.

    • 새 데이터에 대한 전체 행 삽입, 사용되지 않는 셀 지우기

      참고 사항: 

      • 데이터 원본에 하나 이상의 행이 추가되는 경우 외부 데이터 범위의 바로 아래와 오른쪽에 있는 셀이 아래로 이동됩니다.

      • 데이터 원본에서 하나 이상의 행이 삭제되면 외부 데이터 범위의 바로 아래와 오른쪽에 있는 셀은 이동하지 않습니다.

    • 새 데이터로 기존 셀을 덮어 사용되지 않은 셀 지우기

      참고 사항: 

      • 데이터 원본에 하나 이상의 행이 추가되는 경우 외부 데이터 범위 바로 아래에 있는 셀은 덮어 사용되지만 외부 데이터 범위의 오른쪽에 있는 셀은 이동하지 않습니다.

      • 데이터 원본에서 하나 이상의 행이 삭제되면 외부 데이터 범위의 바로 아래와 오른쪽에 있는 셀은 이동하지 않습니다.

  1. 데이터 >를 선택합니다.

  2. 데이터 서식 및 레이아웃에서다음 중 하나 이상을 사용합니다.

    • 필드 이름을 첫 번째 행으로 포함하려면 필드 이름 포함 확인란을 선택합니다.

      참고: 이 확인란은 2003년 Microsoft Office 프로그램 또는 프로그래밍식으로 생성된 외부 데이터 범위로 변환되는 외부 데이터 범위에만 사용할 수 있습니다.

    • 행 번호 열을 추가하려면 행 번호 포함 확인란을 선택합니다.

      참고: 가져온 텍스트 파일, XML 파일 또는 웹 쿼리에는 이 확인란을 사용할 수 없습니다.

    • 적용하는 셀 서식을 유지하려면 셀 서식 유지 확인란을 선택합니다.

      참고: 웹 쿼리의 경우 옵션 대화 상자에서 전체 HTML 서식을 선택하면 이 옵션이 자동으로 지워집니다. 쿼리 편집 대화 상자에서 옵션 대화 상자에 액세스합니다.

    • 설정한 열 너비를 유지하려면 열 너비 조정 확인란을 선택합니다.

    • 적용하는 열 정렬, 필터링 및 레이아웃을 유지하려면 열 정렬/필터/레이아웃 유지 확인란을 선택합니다.

      참고: 이 확인란은 웹 쿼리에 사용할 수 없습니다.

    • 적용하는 열 필터링을 유지하려면 열 필터 보존 확인란을 선택합니다.

      참고: 이 확인란은 XML 데이터를 기반으로 하는 웹 쿼리에만 사용할 수 있습니다.

참고: 다음 절차는 2003년 Microsoft Office 프로그램 또는 프로그래밍식으로 생성된 외부 데이터 범위로 변환되는 외부 데이터 범위에만 적용됩니다. 사용자 인터페이스를 사용하여 만든 모든 외부 데이터 범위는 Excel 테이블로 만들어집니다. 이러한 테이블은 새 행이 추가될 때 자동으로 확장되고 계산된 열을 작성합니다.

  1. 외부 데이터 범위의 첫 번째 데이터 행에 인접한 셀에 수식을 입력합니다.

    참고: 첫 번째 행은 첫 번째 행에 헤더가 포함되어 있는지 여부에 따라 외부 데이터 범위의 첫 번째 또는 두 번째 행일 수 있습니다.

  2. 셀을 선택하고 셀을 두 번 채우기 핸들 외부 데이터 범위의 모든 행에 수식을 복사합니다.

  3. 외부 데이터 범위에서 셀을 클릭합니다.

  4. 데이터 >를 선택합니다.

  5. 외부 데이터 범위 속성 대화 상자에서 데이터 확인란에 인접한 열에서 채우기 수식을 선택합니다.

    참고: 외부 데이터 범위가 확장되는 경우 새로 고침 바로 인접하거나 외부 데이터 범위 내에 있는 수식만 복사합니다.

외부 데이터 범위를 고정하면 데이터가 유지되지만 해당 쿼리는 유지되지 않습니다. 따라서 고정된 외부 데이터 범위를 새로 고칠 수 없습니다.

  1. 데이터 연결을 제거하려는 Excel 테이블이 포함된 워크시트 를 클릭합니다.

  2. 수식 표시줄에서 이름 상자 옆에 있는 화살표를 클릭한 다음 데이터 연결을 제거할 외부 데이터 범위의 이름을 클릭합니다. 그런 다음 데이터 범위가 선택됩니다.

  3. 도구 탭의 외부 테이블 데이터 그룹에서 연결 해제를 클릭합니다. 데이터 범위는 그대로 유지되고 여전히 동일한 이름을 유지하지만 연결이 삭제됩니다.

참고: 다음 절차는 2003년 Microsoft Office 프로그램 또는 프로그래밍식으로 생성된 외부 데이터 범위로 변환되는 외부 데이터 범위에만 적용됩니다. 사용자 인터페이스를 사용하여 만든 모든 외부 데이터 범위는 Excel 테이블로 만들어집니다. 이러한 테이블은 새 행이 추가될 때 자동으로 확장되고 계산된 열을 작성합니다.

  1. 데이터 >를 선택합니다.

  2. 쿼리 정의에서쿼리 정의 저장 확인란을 선택 취소합니다.

참고: 통합 문서를 저장하면 통합 문서에서 기반 쿼리가 삭제됩니다. 그러나 저장된 데이터베이스 쿼리 파일(.dqy 또는 .odc 파일)은 삭제되지 않습니다. 쿼리 마법사 또는 Microsoft 쿼리에서 쿼리를 만들 때 쿼리를 저장한 경우 쿼리 파일이 컴퓨터에 저장되고 쿼리를 다시 사용하여 외부 데이터를 검색할 수 있습니다. 자세한 내용은 Microsoft 쿼리 도움말을 참조하세요.

참고: 다음 절차는 데이터 연결 마법사 또는 Microsoft 쿼리(가져온 텍스트 파일 또는 웹 쿼리에 해당하지 않습니다)를 사용하여 만든 외부 데이터 범위 Microsoft Office, 2003년 2003 프로그램에서 변환된 외부 데이터 범위 또는 프로그래밍식으로 만든 외부 데이터 범위에만 적용됩니다. 사용자 인터페이스를 사용하여 만든 모든 외부 데이터 범위는 Excel 테이블로 만들어집니다.

  1. 다음 중 하나를 수행하여 외부 데이터 범위 위에 빈 행을 삽입합니다.

    • 새 행을 삽입할 위의 셀을 선택합니다. 그런 다음 홈 탭의 그룹에서 삽입 옆에 있는 화살표를 클릭한 다음 시트 행 삽입을 클릭합니다. 하나의 셀을 선택했기 때문에 현재 행 위에 하나의 새 행이 삽입됩니다.

    • 새 행을 삽입하려는 위의 행의 행 선택기 를 클릭합니다. 그런 다음 홈 탭의 그룹에서 삽입을 클릭합니다. 하나의 전체 행을 선택했기 때문에 선택한 행 위에 하나의 새 행이 삽입됩니다.

  2. 빈 행의 셀에 원하는 레이블을 입력합니다.

  3. 외부 데이터 범위에서 셀을 클릭합니다.

  4. 데이터 >를 선택합니다.

  5. 외부 데이터 범위 속성 대화 상자의 데이터 서식 및 레이아웃에서 필드이름 포함 확인란을 선택 취소한 다음 확인 을 클릭합니다.

  6. 기존 필드 이름을 제거하고 외부 데이터 범위를 새로 고치려면 외부 데이터 범위에서 셀을 클릭한 다음 데이터 새로 고침을 단추 이미지 .

참고: 데이터베이스에서 데이터를 검색할 때 Microsoft Query의 열 이름에 대한 변경 내용은 외부 데이터 범위에 유지됩니다. 쿼리에서 열 이름 변경에 대한 자세한 내용은 Microsoft 쿼리 도움말을 참조하세요.

  1. 삭제할 외부 데이터 범위를 포함하는 워크시트 를 클릭합니다.

  2. 수식 표시줄에서 이름 상자 옆에 있는 화살표를 클릭한 다음 삭제할 외부 데이터 범위의 이름을 클릭합니다.

    외부 데이터 범위가 Excel 테이블인 경우 CTRL+A를 눌러 전체 테이블을 선택합니다.

  3. 외부 데이터 범위를 삭제하려면 DELETE를 눌러야 합니다.

  4. 기반 쿼리를 삭제하려면 Excel에서 메시지가 표시되면 예를 클릭합니다.

참고 항목

Excel 도움말에 대한 파워 쿼리

추가 도움이 필요하신가요?

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×