쿼리 만들기, 로드 또는 Excel(Power Query)

Power Query는 통합 문서에 Power 쿼리를 만들고 로드하는 여러 가지 방법을 제공합니다. 쿼리 옵션 창에서 기본 쿼리 로드 설정을 설정할 수도 있습니다.   

      워크시트의 데이터가 Power Query로 셰이프되는지 알기 위해 데이터 셀을 선택하고 쿼리 컨텍스트 리본 탭이 나타나면 Power Query에서 데이터가 로드되었습니다. 

쿼리 탭을 공개하기 위해 쿼리에서 셀 선택

어떤 환경에 있는지 알 수 있습니다. Power Query는 데이터 가져오기, Excel 작업 및 피벗 테이블, 테이블 및 명명된 범위를 편집하는 경우 특히 사용자 인터페이스에 Excel 통합됩니다. 혼동을 방지하기 위해 현재 어떤 환경, 현재 Excel 또는 Power Query에 있는지 아는 것이 중요합니다.

친숙한 Excel 워크시트, 리본 및 눈금

Power Query Editor 리본 및 데이터 미리 보기 

일반적인 Excel 워크시트 일반적인 파워 쿼리 편집기 보기

예를 들어 워크시트에서 데이터를 조작하는 Excel 파워 쿼리와 근본적으로 다릅니다. 또한 워크시트에 있는 연결된 데이터는 Excel 뒤에서 Power Query가 작동하여 데이터를 셰이프할 수 있습니다. 이 문제는 Power Query에서 워크시트 또는 데이터 모델에 데이터를 로드할 때만 발생합니다.

워크시트 탭 이름 개조    워크시트 탭의 이름을 의미 있는 방식으로 개조하는 것이 좋습니다. 특히 많은 경우 이 탭의 이름을 의미 있는 방식으로 개조하는 것이 좋습니다. 데이터 워크시트와 Power Query 편집기에서 로드된 워크시트의 차이를 명확히 하는 것이 특히 중요합니다. 워크시트가 두 개뿐인 워크시트가 Excel 및 테이블1이라는테이블을 Excel 만들어 만든 쿼리가 있는 경우에도 쉽게 혼동할 수 있습니다. 워크시트 탭의 기본 이름을 더 의미 있는 이름으로 변경하는 것이 좋습니다. 예를 들어 Sheet1을 DataTable로, Table1을 QueryTable로 바 변경합니다. 이제 데이터가 있는 탭과 쿼리가 있는 탭이 명확해집니다.

가져온 데이터에서 쿼리를 만들거나 빈 쿼리를 만들 수 있습니다.

가져온 데이터에서 쿼리 만들기

쿼리를 만드는 가장 일반적인 방법입니다.

  1. 일부 데이터를 가져올 수 있습니다. 자세한 내용은 외부 데이터 원본에서 데이터 가져오기 를 참조하세요.

  2. 데이터에서 셀을 선택한 다음, 편집> 선택합니다.

빈 쿼리 만들기

처음부터 시작하면 됩니다. 이 작업은 다음 두 가지 방법으로 수행할 수 있습니다.

  • 다른 > 쿼리에서 데이터 > 데이터 > 선택합니다.

  • Power Query> 시작> 데이터 > 데이터를 선택합니다.

이 시점에서 Power Query M 수식 언어를 잘 알고 있는 경우 단계 및 수식을 수동으로 추가할 수 있습니다.

또는 홈을 선택한 다음 새 쿼리 그룹에서 명령을 선택할 수 있습니다. 다음 중 하나를 실행합니다.

  • 원본을 선택하여 데이터 원본을 추가합니다. 이 명령은 데이터 > 리본 메뉴에서 데이터 Excel 입니다.

  • 최근 원본을 선택하여 작업한 데이터 원본에서 선택합니다. 이 명령은 리본 메뉴의 > 최근 원본 명령과 Excel 입니다.

  • 데이터 입력을 선택하여 수동으로 데이터를 입력합니다. 외부 데이터 원본과 무관하게 Power Query Editor를 사용해 보려고 이 명령을 선택할 수 있습니다.

쿼리가 유효하고 오류가 없는 경우 워크시트 또는 데이터 모델로 다시 로드할 수 있습니다.

Power Query 편집기에서 쿼리 로드

Power Query 편집기에서 다음 중 하나를 실행합니다.

  • 워크시트에 로드하려면 부하 > & 닫기 > & 선택합니다.

  • 데이터 모델에 로드하려면 홈> 로딩 & > 로 & 선택합니다.

    데이터 가져오기 대화 상자에서 데이터 모델에 이 데이터 추가를선택합니다.

   경우에 따라 Load To 명령이 희미해지거나 비활성화됩니다. 통합 문서에서 쿼리를 처음 만들 때 발생할 수 있습니다. 이 경우 새 워크시트에서& 로딩 닫기를 선택하고 쿼리 > & 쿼리 > 데이터 쿼리 탭을 선택하고, 쿼리를 마우스 오른쪽 단추로 클릭한 다음 로 로드를 선택합니다. 또는 Power 쿼리 편집기 리본에서 쿼리 > 로딩을 선택합니다.

쿼리 및 연결 창에서 쿼리 로드 

Excel 다른 워크시트 또는 데이터 모델에 쿼리를 로드할 수 있습니다.

  1. Excel 연결에서 데이터 > 쿼리 & 선택한다음 쿼리 탭을 선택합니다.

  2. 쿼리 목록에서 쿼리를 찾고 쿼리를 마우스 오른쪽 단추로 클릭한 다음 로 로드를 선택합니다. 데이터 가져오기 대화 상자가 나타납니다.

  3. 데이터를 가져오는 방법을 결정한 다음 확인 을 선택합니다. 이 대화 상자 사용에 대한 자세한 내용은 물음표(?)를 선택합니다.

워크시트에 로드된 쿼리를 편집하는 방법에는 여러 가지가 있습니다.

워크시트의 데이터에서 Excel 편집

  • 쿼리를 편집하려면 Power 쿼리 편집기에서 이전에 로드된 셀을 찾아 데이터에서 셀을 선택한 다음, 쿼리> 선택합니다.

쿼리 및 연결 창에서 & 편집

하나의 통합 문서에 & 쿼리가 많고 빠르게 찾으면 연결 창에서 쿼리를 사용하는 것이 더 편리할 수 있습니다.

  1. Excel 연결에서 데이터 > 쿼리 & 선택한다음 쿼리 탭을 선택합니다.

  2. 쿼리 목록에서 쿼리를 찾고 쿼리를 마우스 오른쪽 단추로 클릭한 다음 편집을 선택합니다.

쿼리 속성 대화 상자에서 쿼리 편집

  • Excel 데이터 데이터> 연결 & > 쿼리 탭을 선택하고, 쿼리를 마우스 오른쪽 단추로 클릭하고 속성을 선택하고 속성대화 상자에서 정의 탭을 선택한 다음 쿼리 편집을 선택합니다.

   쿼리가 있는 워크시트에 있는경우 데이터> 속성을 선택하고 속성 대화 상자에서 정의 탭을 선택한 다음 쿼리 편집을 선택합니다. 

데이터 모델에는 일반적으로 관계에 정렬된 여러 테이블이 포함되어 있습니다. Load To 명령을 사용하여 데이터 가져오기 대화 상자를 표시한 다음 데이터 모드 l에이 데이터 추가 확인란을 선택하여 데이터 모델에 쿼리를 로드합니다. 데이터 모델에 대한 자세한 내용은 통합 문서 데이터 모델에 사용되는 데이터 원본 찾기,데이터 모델 만들기 및 여러 테이블을 사용하여 피벗 테이블을 Excel참조하세요.

  1. 데이터 모델을 열기 위해 관리 에서 power pivot > 선택합니다.

  2. Power Pivot 창 아래쪽에서 원하는 테이블의 워크시트 탭을 선택합니다.

    올바른 테이블이 표시 됐는지 확인합니다. 데이터 모델에는 많은 테이블이 있습니다.

  3. 표의 이름을 메모합니다.

  4. Power Pivot 창을 닫기 위해 파일> 선택합니다. 메모리를 다시 저장하는 데 몇 초 정도 걸릴 수 있습니다.

  5. 쿼리 > 속성 & 연결 > 데이터를 선택하고 쿼리를 마우스 오른쪽 단추로 클릭한 다음 편집을 선택합니다.

  6. Power Query 편집기에서 변경을 완료하면 파일> 로드 & 선택합니다.

결과

워크시트의 쿼리와 데이터 모델의 테이블이 업데이트됩니다.

데이터 모델에 쿼리를 로드하는 데 워크시트에 로드하는 것보다 훨씬 오래 걸리는 경우 Power Query 단계를 확인하여 포함 연산자를 사용하여 텍스트 열 또는 목록 구조화된 열을 필터링하는지 확인할 수 있습니다. 이 작업을 Excel 행에 대한 전체 데이터 집합을 통해 다시 열소합니다. 또한 Excel 실행을 효과적으로 사용할 수 없습니다. 해결 방법을 사용하여 등가 또는 시작과 같은 다른 연산자를 사용해 를 시도합니다.

Microsoft는 이 문제를 알고 있으며 조사 중입니다.

Power Query를 로드할 수 있습니다.

  • 워크시트에. Power Query 편집기에서 Load> & 닫기 > & 선택합니다.

  • 데이터 모델에. Power Query 편집기에서 홈 > 로딩 & > 로 & 선택합니다. 

    기본적으로 Power Query는 단일 쿼리를 로드할 때 새 워크시트에 쿼리를 로드하고 동시에 여러 쿼리를 데이터 모델에 로드합니다.  모든 통합 문서 또는 현재 통합 문서의 기본 동작을 변경할 수 있습니다. 이러한 옵션을 설정할 때 Power Query는 워크시트 또는 데이터 모델 데이터 및 주석에서 쿼리 결과를 변경하지 않습니다.

    로딩 닫기 를 선택한 후 표시하는 가져오기 대화 상자를 사용하여 쿼리의 기본 설정을 동적으로 &수 있습니다. 

모든 통합 문서에 적용되는 전역 설정

  1. Power Query 편집기에서 파일> 옵션 및 >옵션을 선택합니다.

  2. 쿼리 옵션 대화 상자의 왼쪽에 있는 전역섹션에서   데이터 로드 를 선택합니다.

  3. 기본 쿼리 로드 설정 섹션에서 다음을 실행합니다.

    • 표준 부하 설정 사용을 선택합니다. 

    • 사용자 지정 기본부하 설정 지정을 선택한 다음 워크시트에 부하를 선택하거나 선택 취소하거나 데이터   모델에 로드 를 선택합니다.

   대화 상자 아래쪽에서 기본값 복원을 선택하여 기본 설정으로 편리하게 돌아올 수 있습니다.

현재 통합 문서에만 적용되는 통합 문서 설정

  1. 쿼리 옵션 대화 상자의 왼쪽, 현재 통합 문서 섹션에서 데이터 로드를 선택합니다.

  2. 다음 중 하나 이상을 수행합니다.

    • 형식 검색에서구조화되지 않은 원본에 대한 열 유형 및 헤더 검색을 선택하거나 지우기 를 선택합니다.

      기본 동작은 이를 감지하는 것입니다. 데이터를 직접 셰이프하는 경우 이 옵션을 선택 취소합니다.

    • 관계에서데이터 모델에 처음 추가할 때 테이블 간의 관계 만들기를 선택하거나 지우기

      데이터 모델로 로드하기 전에 기본 동작은 관계형 데이터베이스의 외계 키와 같은 테이블 간의 기존 관계를 찾아 데이터로 가져오는 것입니다. 직접 이 옵션을 선택 취소합니다.

    • 관계에서데이터 모델에 로드된 쿼리를 새로 고칠 때 관계를 선택하거나 지우기

      기본 동작은 관계를 업데이트하지 않는 것입니다. 데이터 모델에 이미 로드된 쿼리를 새로 고치면 Power Query는 관계형 데이터베이스의 외계 키와 같은 테이블 간의 기존 관계를 찾아 업데이트합니다. 데이터를 가져온 후 수동으로 만든 관계를 제거하거나 새 관계를 도입할 수 있습니다. 그러나 이 작업을 원할 경우 옵션을 선택합니다.

    • 배경 데이터에서백그라운드에서 데이터 미리 보기 허용을 선택하거나 선택 취소합니다.

      기본 동작은 백그라운드에서 데이터 미리 보기를 다운로드하는 것입니다. 모든 데이터를 바로 표시하려는 경우 이 옵션을 선택 취소합니다.

참고 항목

Excel용 파워 쿼리 도움말

쿼리 관리 Excel

추가 도움이 필요하신가요?

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

×