통합 & 변환 환경 가져오기

Excel 2016에는 Get & 변환 이라는 강력한 도구 집합이 도입 되었습니다. 파워 쿼리 기술을 기반으로 하는 이러한 도구를 사용 하면 다양 한 원본에서 데이터를 간편 하 게 연결, 결합 및 셰이프 할 수 있습니다. 다음 & 변형 연습 자습서 에서 기본 사항에 대해 안내해 드립니다.

Excel에서 데이터 가져오기 및 셰이핑 기능에 대 한 다음 주요 업데이트를 발표 하는 것은 통일 된 통합 & 변환 환경입니다. 3 월 2017 Office 365 업데이트를 통해 Excel의 데이터 가져오기 기능을 개선 하 고 데이터 탭의 단추를 다시 정렬 하 여 가져오기 & 변형 기능을 완전히 활용할 수 있습니다.

데이터 탭에서 & 변형 옵션 가져오기

통합 된 & 변환 환경을 통해 Excel에서 제대로 통합 되 고 최신 데이터 가져오기 및 셰이핑 기능을 활용할 수 있습니다. 파일, 데이터베이스, Azure, 온라인 서비스 등 다양 한 인기 데이터 원본의 데이터를 쉽게 연결 하 고 가져올 수 있습니다. 데이터 형식을 정렬, 변경, 열 분할, 데이터 집계 등의 다양 한 방법으로 데이터를 표시할 수 있습니다. 지속적으로 증가 하는 새 커넥터의 제공은 일상적인 작업에서 귀중 하 고 시간을 절약할 수 있는 도구를 & 변환 하 게 됩니다.

새로운 환경은 데이터 > 외부 데이터 가져오기에서 사용할 수 있는 오래 된 레거시 데이터 가져오기 마법사를 대체 합니다. 그러나 필요한 경우 계속 액세스할 수 있습니다. 참고: 레거시 외부 데이터 가져오기 환경을 복원 하려면 어떻게 하나요?

참고: 이 기능은 Office 365 구독이있는 경우에만 Excel 에서만 사용할 수 있습니다. Office 365 구독자 인 경우 최신 버전의 Office가 설치 되어 있는지 확인합니다.

CSV 파일 또는 웹 같은 인기 있는 원본에서 데이터를 가져오려면 어떻게 하나요?

리본 메뉴에서 가장 인기 있는 연결선을 쉽게 액세스할 수 있도록 데이터를 가져오는 사용자에 게이를 알립니다. 이 업데이트에서는이 원칙을 따르고 사용 하는 것과 일관 된 환경을 유지 하려고 시도 했습니다. 이제 텍스트/c o a p, 웹에서, 테이블/범위에서데이터 탭의 데이터 가져오기 & 섹션에서 사용할 수 있는 세 개의 위쪽 연결선을 찾을 수 있습니다.

Text/CSV에서

이 연결선을 사용 하 여 텍스트 (* .txt), 쉼표로 구분 된 값 (* .csv) 또는 서식 있는 텍스트 (* .prn) 파일에서 데이터를 쉽게 가져올 수 있습니다. 이 최신 커넥터는 파워 쿼리 기술을 기반으로 하며 이전 텍스트 마법사를 대체 합니다.

새 커넥터로 데이터 가져오기를 시작 하려면 Text/CSV에서 데이터 >를 클릭 하 고 원본 파일을 선택한 다음 확인을 클릭 합니다. 텍스트/ c o p s 커넥터에서 새로운 기능과 향상 된 입력 파일의 구조를 분석 하 고 관련 가져오기 설정을 자동으로 적용 합니다. 구분 기호를 기준으로 열을 분할 하 고 열 머리글로 사용할 첫 번째 행을 승격 하는 등의 다양 한 기능을 사용할 수 있습니다.

텍스트 옵션에서 & 변형 가져오기

미리 보기가 원하는 방식이 아닌 경우에는 파일 원본, 구분 기호 또는 데이터 형식 검색 논리와 같은 기본 가져오기 설정을 구성할 수 있습니다. 선택에 따라 데이터의 미리 보기가 자동으로 업데이트 됩니다.

그런 다음 로드 를 클릭 하 여 데이터를 워크시트에 직접 로드 하거나 로드 옆의 화살표를 클릭 하 여 데이터 모델에 데이터를 로드할 수 있습니다. 쿼리 편집기에서 추가 데이터 변환을 적용 하려면 편집을 클릭 합니다.

이 커넥터를 사용 하 여 HTML 페이지에서 데이터를 "scrape" 할 수 있습니다. 이것은 파워 쿼리 기술을 기반으로 하는 다른 최신 커넥터로, 레거시 웹 마법사를 대체 합니다.

사용을 시작 하려면 웹에서>데이터 를 클릭 하 고 대상 페이지 URL을 지정한 다음 확인을 클릭 합니다. 페이지의 모든 테이블 목록이 탐색 대화 상자에 표시 됩니다. 테이블 보기나웹 보기에서 웹 페이지를 조작 하는 옵션이 있습니다. 테이블 뷰를 사용 하 여 먼저 왼쪽에 있는 테이블 이름을 클릭 하면 해당 테이블의 데이터가 오른쪽에 표시 됩니다. 웹 보기를 사용 하면 탐색 목록에서 표를 클릭 하거나 웹 보기 미리 보기 창에서 테이블을 클릭할 수 있습니다. 보기 중 하나에서 여러 테이블을 선택할 수 있습니다.

웹 옵션에서 & 변형 가져오기

테이블/범위에서

이 연결선을 사용 하 여 Excel 워크시트의 테이블 또는 명명 된 범위에 연결 된 새 쿼리를 만들 수 있습니다. 그런 다음 쿼리 편집기 창에서 데이터를 구체화 하 고 추가 변환을 적용할 수 있습니다.

테이블 옵션에서 & 변형 가져오기

XML 파일 또는 Microsoft SQL Server와 같은 추가 원본에서 데이터를 가져오려면 어떻게 하나요?

새 쿼리를 만들어 Microsoft Access 데이터베이스 또는 OData 피드와 같은 단일 데이터 원본에서 데이터를 가져오거나 한 번에 여러 텍스트 파일의 데이터를 폴더에서 가져올 수 있습니다.

데이터>클릭 하 여 데이터를 가져오면드롭다운 메뉴에서 사용 가능한 데이터 원본이 표시 됩니다. 원본 옵션은 Excel 통합 문서, XML 파일 또는 전체 폴더, SQL Server 또는 Oracle 등의 데이터베이스, HDInsight 또는 Blob 저장소와 같은 Azure 서비스, SharePoint Online 목록 또는 Salesforce 같은 온라인 서비스 등의 범주로 구성 되어 있습니다. 외에는 OData 또는 ODBC와 같은 다양 한 소스가 있습니다.

사용할 수 있는 연결선 목록은 지속적으로 증가 하 고 있습니다.

데이터베이스 옵션에서 & 변환 가져오기

이 업데이트를 사용 하면 데이터 탭의 외부 데이터 가져오기 섹션에서 이전에 사용할 수 있었던 다음과 같은 레거시 마법사, Access, 웹, 텍스트, SQL Server, OData 데이터 피드, XML 데이터 가져오기 및 데이터 연결 Wizard. 어떤 이유로 든 제거 된 레거시 마법사 중 하나를 사용 해야 하는 경우 레거시 외부 데이터 가져오기 환경을 복원 하려면 어떻게 하나요? 를 참조 하세요.

그러나 이전의 외부 데이터 가져오기 기능 집합에 포함 되어 있으며, Analysis ServicesMicrosoft Query에서 새로운 환경으로 유지 되는 두 가지 인기 및 매우 고유한 마법사가 있습니다. 이러한 항목은 새 환경에서 데이터베이스및 >데이터 > 아래에 있는 다른 원본 범주에서 각각 찾을 수 있습니다.

Get & 변환 기능을 활용 하 여 데이터를 정리 하 고이를 셰이프 하려면 어떻게 하나요?

강력한 데이터 분석을 위한 필수 단계로 데이터를 정리 하 고 정리할 수 있는 & 변환을 가져옵니다 . 열을 제거 하 고, 행을 필터링 하 고, 열 데이터 형식을 변경 하 고, 값을 바꿀 수 있습니다. 이 작업은 모든 데이터 변형을 편리 하 고 표시 하는 전용 쿼리 편집기 창을 통해 수행 됩니다.

리본의 데이터 탭으로 전환 하 고 데이터 가져오기를클릭 한 다음 사용 가능한 연결선 중 하나를 사용 하 여 원하는 데이터 원본 (예: 파일 또는 데이터베이스)에 연결 하 고 탐색 창에서 데이터를 미리 봅니다.

Gent & 변환 탐색기

가져오려는 테이블을 선택한 다음 편집 을 클릭 하 여 쿼리 편집기 창을 엽니다.

& 변형 쿼리 편집기 가져오기

쿼리 편집기 창 내부의 리본에서 사용할 수 있는 다양 한 명령 컬렉션을 사용 합니다. 데이터 정렬 및 필터링, 데이터 형식 변환, 열 분할 또는 병합, 데이터 집계 등을 통해 강력한 변환을 적용할 수 있습니다.

데이터에 적용 하는 모든 변환 단계가 기록 되 고 쿼리의 일부로 저장 됩니다. 기록 된 변형은 쿼리 편집기 창 내의 적용 된 단계 섹션을 통해 관찰 하 고 관리할 수 있으며, 쿼리를 새로 고칠 때마다 데이터에 다시 적용 됩니다.

최근에 사용한 원본, ODC (Office 데이터베이스 연결) 파일, 기타 통합 문서 연결 또는 테이블에서 데이터를 가져오려면 어떻게 하나요?

데이터 가져오기 영역에서 가장 인기 있는 시나리오 중 하나는 최근 원본에서 데이터를 연결 하 고 가져오는 것입니다. 사용자는 일반적으로 데이터를 가져오기 위해 연결 하는 자주 사용 하는 원본 집합을 설정 합니다.

최근 데이터 원본 중 하나를 연결 하 여 쿼리를 만들려면 최근 원본>데이터 를 클릭 합니다. 그런 다음 최근에 연결 된 소스를 찾아 하나를 선택한 다음 연결 을 클릭 하 여 가져오기 흐름을 계속 진행할 수 있습니다.

최근 원본 & 변환 창 가져오기

자주 사용 하는 다른 시나리오는 통합 문서의 기존 연결 또는 테이블에서 데이터를 가져오는 것입니다. 예를 들어 이전에 만든 통합 문서 연결을 기준으로 새 피벗 테이블을 만들 수 있습니다. 또는 조직 내 다른 사용자가 정의한 ODC (Office 데이터베이스 연결) 파일을 사용 하 여 데이터 원본에서 연결 및 가져오기를 원할 수 있습니다.

이 업데이트를 사용 하 여 모든 쿼리 정의를 ODC 파일로 내보내고, 통합 문서에서 공유 하거나 동료와 공유할 수 있습니다. 쿼리 정의를 ODC 파일로 내보내려면 쿼리 & 연결 왼쪽 창에서 쿼리를 마우스 오른쪽 단추로 클릭 하 고 연결 파일 내보내기를선택 합니다. 생성 된 ODC 파일에는 데이터 원본에 대 한 연결 지침과 데이터에 적용 되는 변환 단계를 비롯 한 모든 종속성이 포함 된 쿼리 정의가 들어 있습니다. 쿼리 정의를 내보내는 다른 방법은 쿼리 상황에 맞는 메뉴에서 속성 을 선택 하 여 열 수 있는 쿼리 속성 대화 상자를 통하는 것입니다.

ODC 파일을 받은 후에는이를 사용 하 고 쿼리 정의를 통합 문서로 가져올 수 있습니다. ODC 메커니즘을 통해 데이터를 가져오려면기존 연결> 데이터 를 클릭 합니다. 기존 연결 대화 상자가 표시 되 고 사용 가능한 ODC 파일, 기존 통합 문서 연결 또는 테이블에서 가져올 수 있습니다.

기존 연결 또는 쿼리를 선택 합니다.

Visio 또는 Excel 2013 및 이전 버전 등의 다른 응용 프로그램에서 사용 되는 ODC 파일을 만들어야 하는 경우에는 SQL Server 데이터베이스, microsoft Access 데이터베이스, OData 피드, Analysis Services, microsoft Query 또는 데이터 연결 마법사에서 다음 커넥터를 사용 하면 됩니다. 다른 응용 프로그램에서 ODC 파일을 소모 하는 경우 해당 응용 프로그램은 ODC의 연결 지침도 다시 사용 하므로 원본 쿼리에 포함 된 변환 단계는 포함 되지 않습니다. SQL Server에서 OData 데이터 피드 커넥터를 사용 하 여 Access에서 레거시를 복원 해야 하는 경우에 는 레거시 외부 데이터 가져오기 환경을 어떻게 복원 하나요? 를 참조 하세요.

기존 통합 문서 쿼리 및 연결을 관리 하는 방법

Excel 2016에서 & 변환을 수행 하는 경우 두 가지 데이터 가져오기 방법을 도입 했습니다. 첫 번째는 쿼리 를 사용 하 고 새로 고침 및 통합 문서 요소에 로드 하기 위해 장면 뒤에 있는 통합 문서 연결에 의존 하는 새로운 Get & 변환 환경입니다. 두 번째는 통합 문서 연결을 사용 하는 이전 레거시 환경입니다. 통합 문서 쿼리 및 연결 관리도 별도로 수행 되었습니다. 통합 문서 쿼리는 통합 문서 연결 대화 상자를 통해 연결 되는 반면 전용 쿼리 창을 통해 관리 됩니다. 이로 인해 저희 사용자 들이 혼란을 일으켰습니다.

이 업데이트를 통해이 문제를 해결 했습니다. 이제 전용 쿼리 & 연결 측 창에서 통합 문서 쿼리 및 연결을 액세스 하 고 관리할 수 있습니다. 왼쪽 창을 열려면 데이터 > 쿼리 & 연결 단추를 클릭 합니다.

연결 창 & & 변환 쿼리 가져오기

창 맨 위에 있는 쿼리 탭을 클릭 하 여 통합 문서에서 사용 가능한 쿼리를 찾아 관리할 수 있습니다. 쿼리를 마우스 오른쪽 단추로 클릭 하 여 쿼리 상황에 맞는 메뉴에 액세스 하면 추가 작업을 수행할 수 있습니다. 예를 들어 원본으로 사용 하는 원본에서 쿼리 데이터를 새로 고치거 나, 쿼리를 복사/붙여 넣고, 쿼리 편집기를 사용 하 여 쿼리 변환 편집 등의 작업을 수행할 수 있습니다.

쿼리 속성 대화 상자를 통해 쿼리 및 기본 연결에 대 한 관리도 간소화 했습니다. 현재, 통합 문서에서 새 쿼리를 만들 때마다 새 기본 연결 엔터티가 자동으로 백그라운드에서 만들어지고이 쿼리와 연결 됩니다. 쿼리 역할은 데이터 원본에 연결 하 고 필수 데이터 변환을 적용 하는 데 사용 되는 반면, 데이터를 로드 하는 위치 (예: 워크시트 또는 데이터 모델) 및 쿼리 데이터에 대 한 새로 고침 설정은 다음과 같습니다. 새로 고침 빈도입니다. 새 쿼리 속성 대화 상자를 사용 하면 이름 또는 변형 명령 등의 모든 쿼리 속성과 중앙 집중화 된 방식으로 새로 고침 설정 등의 기본 연결 속성을 쉽게 제어할 수 있습니다. 새 쿼리 속성 대화 상자를 열려면 쿼리 & 연결 창에서 쿼리의 상황에 맞는 메뉴에서 속성 명령을 클릭 합니다.

왼쪽 창 위쪽의 연결 탭을 클릭 하면 텍스트, Analysis Services또는 Microsoft Query와 같은 레거시 마법사 중 하 나와 연결 된 통합 문서에서 사용 가능한 레거시 연결을 찾아보고 관리할 수 있습니다. 연결을 마우스 오른쪽 단추로 클릭 하 여 상황에 맞는 메뉴에 액세스 합니다. 여기에는 잘 알려진 연결 속성 대화 상자를 통해 원본에서 연결 데이터 새로 고침, 연결 삭제 또는 연결 속성 관리 등의 추가 작업을 수행할 수 있습니다.

레거시 외부 데이터 가져오기 환경을 복원 하는 방법은 무엇 인가요?

새로운 & 변환 환경은 레거시 마법사와 비교 하 여 커넥터 제공 및 변환 기능 측면에서 상위입니다. 그러나 기존 마법사 중 하나를 사용 하 여 데이터를 가져오는 경우에도 여전히 시간이 남아 있습니다. 예를 들어 데이터 원본 로그인 자격 증명을 통합 문서의 일부로 저장 하려는 경우 (이 메서드는 최신 보안 표준을 따르지 않으며, 새로운 & 변환 환경에서 지원 되지 않는다는 점에 유의 하세요.)

리본을 사용자 지정 하 여 레거시 커넥터에 액세스 하거나, 데이터 > 데이터 가져오기 드롭다운 메뉴에서 바로 Excel 옵션 대화 상자에서 새로 만들기 및 손쉬운 구성 설정을 사용 하 여 이전 데이터 가져오기 마법사를 다시 표시할 수 있습니다.

파일 > 옵션 으로 이동 하 여 레거시 데이터 가져오기 마법사 표시> 데이터 > 사용 하 여 사용할 레거시 마법사를 선택 합니다.

파일 > 옵션 > 데이터에 대 한 레거시 & 변환 마법사 옵션의 이미지입니다.

데이터 > 데이터 가져오기 드롭다운 메뉴를 열고 전용 레거시 마법사 범주에서 이전에 선택한 레거시 데이터 가져오기 마법사 중 하나를 실행 합니다.

레거시 & 변환 메뉴 옵션 가져오기

& 변환 가져오기에 대 한 추가 정보

Get & 변환 기능에 대 한 자세한 내용은 Microsoft Excel 용 파워 쿼리 도움말을 참조하 여 시작 하는 것이 좋습니다.

추가 지원

Excel 기술 커뮤니티의 전문가에게 질문하고, Answers 커뮤니티에서 지원을 받고, Excel 사용자 의견에서 새로운 기능이나 개선 사항을 제안해 보세요.

참고:  이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 정보가 도움이 되는지 알려주세요. 참조할 수 있는 영문 문서가 여기 있습니다.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×