Excel에서 데이터 모델 만들기

데이터 모델을 사용하면 여러 테이블의 데이터를 통합하여 통합 문서 내에서 관계형 데이터 원본을 Excel 수 있습니다. 데이터 Excel 투명하게 사용되어 피벗 테이블 및 피벗차트에 사용되는 테이블형 데이터를 제공합니다. 데이터 모델은 필드 목록의 테이블 컬렉션으로 시각화됩니다. 대부분의 경우 해당 테이블이 있는 것을 알지 못합니다.

데이터 모델 작업을 시작하기 전에 일부 데이터를 수집해야 합니다. 이를 위해 한 걸음 뒤로 돌아가서 비디오를 시청하거나 변환 및 Power Pivot 다운로드에 대한 학습 가이드를 & 변환(Power Query) 환경이 & 있습니다.

파워 피벗은 어디에 있나요?

  • Excel 2016 & Microsoft 365용 Excel - 전원 피벗이 리본 메뉴에 포함됩니다.

  • Excel 2013 - Power Pivot는 2013 Office Professional Plus Excel 버전의 일부이지만 기본적으로 사용할 수 없습니다. 2013 에 대한 Power Pivot추가 기능을 시작하는 Excel 자세히 알아보고

  • Excel 2010 - Power Pivot추가 기능을 다운로드한 다음 Power Pivot 추가 기능을 설치합니다.

Get & 변환(Power Query)은 어디인가요?

  • Excel 2016 & Microsoft 365용 Excel - & 변환(Power Query)이 데이터 탭의 Excel 통합되었습니다.

  • Excel 2013 - Power Query는 Excel 추가 기능이지만 활성화해야 합니다. 파일 > 옵션 > 으로 이동한 다음 창 아래쪽의 드롭다운 관리에서 COM 추가 기능 > 선택합니다. Microsoft Power Query에서Excel 확인을 확인하여 활성화합니다. 파워 쿼리 탭이 리본 메뉴에 추가됩니다.

  • Excel 2010 - Power Query 추가 기능을 다운로드하고 설치합니다.. 활성화되면 파워 쿼리 탭이 리본 메뉴에 추가됩니다.

시작하기

먼저 일부 데이터를 수집해야 합니다.

  1. Excel 2016 및 Microsoft 365용 Excel 데이터 가져오기 > 데이터 변환 & 데이터 가져오기 > 데이터 가져오기에서 텍스트 파일 Excel, 통합 문서, 웹 사이트, Microsoft Access, SQL Server 또는 여러 관련 테이블을 포함하는 다른 관계형 데이터베이스와 같은 모든 수의 외부 데이터 원본에서 데이터를 가져올 수 있습니다.

    2013년 Excel 및 2010년의 경우 외부 데이터 > Power Query로 이동하고 데이터 원본을선택합니다.

  2. Excel 선택하라는 메시지가 표시됩니다. 동일한 데이터 원본에서 여러 테이블을 사용하려면 여러 테이블 선택 사용 옵션을 선택합니다. 여러 테이블을 선택하면 Excel 자동으로 데이터 모델을 만듭니다.

    참고: 이러한 예제에서는 수업 및 성적에 대한 Excel 세부 정보가 있는 통합 문서와 통합 문서를 사용하고 있습니다. 학생 데이터 모델 샘플통합 문서 를 다운로드하고 따라할 수 있습니다. 완성된 데이터 모델을 사용하여 버전을 다운로드할 수 있습니다..

    변환 &(Power Query) 내비게이터 보기
  3. 하나 이상의 테이블을 선택한 다음 로드를 클릭합니다.

    원본 데이터를 편집해야 하는 경우 편집 옵션을 선택할 수 있습니다. 자세한 내용은 쿼리 편집기(Power Query) 소개 를 참조합니다.

이제 가져온 모든 테이블이 포함된 데이터 모델이 있으며 피벗 테이블 필드 목록 에 표시됩니다.

참고 사항: 

  • 두 개 이상의 테이블을 동시에 가져오는 경우 모델이 암시적으로 Excel.

  • 추가 기능을 사용하여 데이터를 가져오는 데 파워 피벗 모델이 명시적으로 만들어집니다. 추가 기능에서 모델은 각 탭에 테이블형 데이터가 Excel 탭된 레이아웃으로 표시됩니다. Power Pivot추가 기능을 사용하여 데이터 가져오기 를 참조하여 데이터베이스 데이터베이스를 사용하여 데이터 가져오기의 기본 SQL Server.

  • 모델에 단일 테이블이 포함될 수 있습니다. 테이블 하나만 기준으로 모델을 만들려면 표를 선택하고 에서 데이터 모델에 추가를 파워 피벗. 필터링된 데이터 세트, 계산된 열, 계산된 필드, KPIS 및 계층구조와 같은 파워 피벗 기능을 사용하려는 경우 이 작업을 할 수 있습니다.

  • 기본 및 외계 키 관계가 있는 관련 테이블을 가져오는 경우 테이블 관계를 자동으로 만들 수 있습니다. Excel 데이터 모델의 테이블 관계에 대한 기본으로 가져온 관계 정보를 사용할 수 있습니다.

  • 데이터 모델의 크기를 줄이는 방법에 대한 팁은 데이터 모델 및 Power Pivot를 사용하여 메모리 효율적인 데이터 모델 만들기를 Excel 참조하세요.

  • 추가 탐색은 자습서: 데이터 가져오기 Excel 및 데이터 모델 만들기 를 참조합니다.

팁: 통합 문서에 데이터 모델이 있는지 어떻게 알 수 있나요? 관리 파워 피벗 >로 이동 워크시트와 같은 데이터가 표시되는 경우 모델이 있습니다. 참조: 자세한 내용은 통합 문서 데이터 모델에 사용되는 데이터 원본을 참조합니다.

테이블 간의 관계 만들기

다음 단계는 테이블 간에 관계를 만들어 데이터를 끌어오는 것입니다. 각 테이블에는 기본 키 또는 학생 ID 또는 수업 번호와 같은 고유 필드 식별자가 필요합니다. 가장 쉬운 방법은 Power Pivot의 다이어그램 보기에서 해당 필드를 끌어서 놓는 것입니다.

  1. Power Pivot > 관리로 이동

  2. 탭에서다이어그램 보기 를 선택합니다.

  3. 가져온 모든 테이블이 표시되고 각 테이블의 필드 수에 따라 크기 변경에 다소 시간이 걸릴 수 있습니다.

  4. 다음으로 기본 키 필드를 한 테이블에서 다음 테이블로 드래그합니다. 다음 예제는 학생 테이블의 다이어그램 보기입니다.

    Power Query 데이터 모델 관계 다이어그램 보기

    다음 링크를 만들어 졌습니다.

    • tbl_Students | 학생 ID > tbl_Grades | 학생 ID

      즉, 학생 테이블에서 학생 ID 필드를 성적 테이블의 학생 ID 필드로 끌어다 놓습니다.

    • tbl_Semesters | 학기 ID > tbl_Grades | 한학기

    • tbl_Classes | 수업 번호 > tbl_Grades | 수업 번호

    참고 사항: 

    • 관계를 만들기 위해 필드 이름은 동일할 필요는 없지만 동일한 데이터 형식이 필요합니다.

    • 다이어그램 보기의 커넥터에는 한쪽에 "1"이 있으며 다른 한 쪽에는 "*"가 있습니다. 즉, 테이블 간에 일대다 관계가 있으며 피벗 테이블에서 데이터가 사용되는 방법을 결정하는 것입니다. 자세한 내용은 데이터 모델의 테이블 간의 관계입니다.

    • 커넥터는 테이블 간에 관계가 있는 것만 나타냅니다. 실제로 서로 연결된 필드는 표시되지 않습니다. 링크를 보시고 Power Pivot > > 관계 > 관리 > 관리 > 로 이동하세요. Excel 데이터 > 있습니다.

데이터 모델을 사용하여 피벗테이블 또는 피벗 차트

단일 Excel 통합 문서에는 하나의 데이터 모델만 포함될 수 있지만 해당 모델에는 통합 문서 전체에서 반복적으로 사용할 수 있는 여러 테이블이 포함되어 있습니다. 기존 데이터 모델에 테이블을 더 추가할 수 있습니다.

  1. 파워 피벗에서 관리로 이동합니다.

  2. 탭에서 피벗 테이블 을 선택합니다.

  3. 피벗테이블을 배치할 위치(새 워크시트 또는 현재 위치)를 선택합니다.

  4. 확인을클릭하고 Excel 필드 목록 창이 오른쪽에 표시되는 빈 피벗테이블을 추가합니다.

    Power Pivot PivotTable 필드 목록

다음으로 피벗테이블을 만들거나피벗 차트를 만든다. 테이블 간에 관계를 이미 만든 경우 피벗 테이블에서 해당 필드를 사용할 수 있습니다. 학생 데이터 모델 샘플 통합 문서에서 이미 관계를 만들어 왔다.

데이터 모델에 기존 관련 없는 데이터 추가

모델에서 사용할 많은 데이터를 가져오거나 복사했지만 데이터 모델에 추가하지 않았다고 가정합니다. 새 데이터를 모델로 푸시하는 것이 생각보다 쉽습니다.

  1. 먼저 모델에 추가할 데이터 내에서 모든 셀을 선택합니다. 모든 범위의 데이터일 수 있지만 데이터 형식이 Excel 가장 좋은 데이터입니다.

  2. 다음 방법 중 하나를 사용하여 데이터를 추가합니다.

  3. 데이터 파워 피벗 >추가를 클릭합니다.

  4. 피벗 > 삽입을 클릭한다음 피벗테이블 만들기 대화 상자에서 데이터 모델에 이 데이터 추가를 선택합니다.

이제 범위 또는 테이블이 모델에 연결된 테이블로 추가됩니다. 모델에서 연결된 테이블 작업에 대한 자세한 내용은 Power Pivot에서 연결된 테이블을 사용하여 Excel 추가를 참조합니다.

테이블에 파워 피벗 추가

파워 피벗 워크시트에서와 같이 새 행을 직접 입력하여 테이블에 행을 추가할 수 Excel 없습니다. 그러나 원본 데이터를 복사하고 붙여넣거나, 원본 데이터를 업데이트하고 Power Pivot모델을 새로 고침하여 행을 추가할 수 있습니다.

추가 지원

언제든지 Excel 기술 커뮤니티의 전문가에게 질문하고, Answers 커뮤니티에서 지원을 받을 수 있습니다.

참고 항목

변환 & Power Pivot 학습 가이드 보기

쿼리 편집기 소개(파워 쿼리)

메모리 효율적 데이터 모델 만들기 및 Excel 피벗

자습서: 데이터 가져오기 Excel 데이터 모델 만들기

통합 문서 데이터 모델에서 사용된 데이터 원본 확인

데이터 모델의 테이블 간 관계

추가 도움이 필요하신가요?

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

×