Office에서 맞춤법 및 문법 검사

모든 Microsoft Office 프로그램은 맞춤법을 대부분의 프로그램은 문법을 검사할 수 있습니다. 

해당 맞춤법 또는 문법 검사가 정상적으로 작동하지 않는 경우 맞춤법 및 문법 검사가 정상적으로 작동하지 않는 경우를 참조하세요. 기본 언어가 아닌 언어로 맞춤법 또는 문법을 검사하려면 다른 언어로 맞춤법 및 문법 검사를 참조하세요.

Office 365를 사용하고 있나요? Word에서 강력한 새 편집기 기능을 확인해 보세요! 자세한 내용은 편집기 - 문서 작성 도우미를 참조하세요.

수동으로 맞춤법 및 문법 검사 실행

파일에서 맞춤법 및 문법 검사를 시작하려면 F7 키 를 누르거나 다음 단계를 수행하세요.

  1. 대부분의 Office 프로그램을 열고 리본의 검토 탭을 클릭합니다. Access 또는 InfoPath에서는 이 단계를 건너뛸 수 있습니다. Project에서는 프로젝트 탭으로 이동합니다.

  2. 맞춤법 검사 또는 맞춤법 및 문법 검사를 클릭합니다.

    검토 리본의 맞춤법 및 문법 단추

  3. 맞춤법 오류가 발견되면 대화 상자에 문법 검사기에서 찾은 철자가 잘못된 첫 번째 단어가 표시됩니다.

  4. 맞춤법 오류를 해결할 방법(무시, 프로그램의 사전에 추가 또는 변경)을 결정하고 나면 다음 맞춤법이 틀린 단어로 이동됩니다.

자세한 내용을 보려면 아래 제목을 클릭

대부분의 Office 프로그램은 사용자가 입력할 때 자동으로 의심되는 맞춤법 및 문법 오류를 검사하므로 작업하는 동안 오류를 표시하기 위해 특별히 해야 할 일은 없습니다. 

참고 사항: 

  • Access, Excel 또는 Project에서는 자동 맞춤법 및 문법 검사를 사용할 수 없습니다. F7 키를 눌러 맞춤법 검사를 수동으로 시작할 수 있습니다.

  • 자동 문법 검사는 Outlook, Word, PowerPoint 2013 이상에서만 사용할 수 있습니다.

Office에서는 잠재적 맞춤법 오류는 빨간색 물결선으로 표시되고 잠재적 문법 오류는 파란색 물결선으로 표시됩니다.

맞춤법 또는 문법 오류가 표시되지 않으면 자동 검사가 해제된 것일 수 있습니다. 자동 맞춤법 및 문법 검사를 설정할 수 있습니다.

수정에 도움이 필요한 맞춤법 또는 문법 오류가 표시되면 밑줄이 그어진 단어 또는 구를 마우스 오른쪽 단추로 클릭하고 옵션 중 하나를 선택하여 오류를 수정합니다.

Office에서 단어를 맞춤법이 틀린 것으로 플래그를 지정하지만, 사용자가 원하는 방식으로 철자를 입력한 것이라면 사전에 추가를 선택하여 Office에 앞으로 해당 단어를 맞춤법이 틀린 것으로 플래그를 지정하지 않도록 알립니다. 이에 대한 자세한 내용은 맞춤법 검사 사전에서 단어 추가 또는 편집을 참조하세요.

작업하는 동안 Office에 의심되는 오류가 물결선으로 표시되지 않게 하려면 자동 맞춤법 및 문법 검사를 해제하면 됩니다.

  1. 맞춤법 및 문법 검사 옵션을 엽니다.

    • OneNote, PowerPoint, Publisher, Visio 및 Word: 파일 메뉴에서 옵션을 클릭한 다음 언어 교정을 클릭합니다.

    • InfoPath: 탭에서 맞춤법 검사 옆이나 아래의 화살표를 클릭한 다음 맞춤법 검사 옵션을 클릭합니다.

    • Outlook: 파일 메뉴에서 옵션을 클릭하고 메일을 클릭한 다음 맞춤법 및 자동 고침을 클릭합니다.

  2. 입력할 때 자동으로 맞춤법 검사 확인란을 선택하거나 선택 취소합니다. 자동 문법 검사가 있는 프로그램에서는 입력할 때 문법 오류 표시 확인란을 선택하거나 선택 취소할 수도 있습니다.

    입력할 때 자동으로 맞춤법 검사 확인란

    참고: Word에서는 작업 중인 문서 또는 모든 새 문서에 대해 맞춤법 검사를 설정하거나 해제할 수 있습니다. 예외 항목 목록에서 옵션을 선택한 다음 현재 문서에서만 맞춤법 오류 숨기기현재 문서에서만 문법 오류 숨기기 확인란을 선택하거나 선택 취소합니다.

Office에서 문법을 전혀 검사하지 않도록 하려면(맞춤법 검사를 실행할 때나 입력할 때 자동으로) 문법 검사를 해제하면 됩니다.

  1. 맞춤법 및 문법 검사 옵션을 엽니다.

    • OneNote, PowerPoint, Publisher, Visio 및 Word: 파일 메뉴에서 옵션을 클릭한 다음 언어 교정을 클릭합니다.

    • InfoPath: 탭에서 맞춤법 검사 옆이나 아래의 화살표를 클릭한 다음 맞춤법 검사 옵션을 클릭합니다.

    • Outlook: 파일 메뉴에서 옵션을 클릭하고 메일을 클릭한 다음 맞춤법 및 자동 고침을 클릭합니다.

  2. 입력할 때 문법 오류 표시맞춤법 및 문법 동시 검사 확인란을 선택 취소합니다.

    문법 확인란

    참고: 일부 Office 프로그램에는 이러한 두 옵션이 없습니다.

Word, Outlook, PowerPoint 2013 이상에서는 다음을 수행하여 이전에 건너뛴 단어 및 문법을 다시 검사할 수 있습니다.

  1. 검사할 문서 또는 항목을 엽니다.

  2. 파일 메뉴에서 옵션 > 언어 교정 > 문서 다시 검사를 클릭합니다. Outlook에서는 파일 > 옵션 > 메일 > 맞춤법 및 자동 고침에서 찾을 수 있습니다.

  3. 맞춤법 및 문법 검사 다시 설정에 대한 경고 메시지가 표시되면 를 클릭합니다.

  4. 대화 상자에서 확인을 클릭하여 문서로 돌아간 다음 다시 맞춤법 및 문법 검사를 실행합니다.

보내주신 의견은 제품을 개선하는 데 반영됩니다.

이 문서는 2019년 10월 28일Ben에 의해 마지막으로 업데이트되었습니다. 이 문서가 유용했거나 유용하지 않았다면 아래에서 사용자 의견 컨트롤을 사용하여 Microsoft가 제품을 개선하는 데 도움이 되는 건설적인 의견을 남겨 주시기 바랍니다.

참고 항목

문서 난이도 테스트

맞춤법 및 문법 검사가 정상적으로 작동하지 않는 경우

Office 2013 및 이전 버전에서 문법 및 문장체 옵션 선택

맞춤법 검사 사전에 단어 추가

맞춤법 또는 문법 검사 시 다른 언어의 단어가 제대로 검사되지 않는 경우

대/소문자, 맞춤법 및 기호에 대한 자동 고침 옵션 선택

Outlook에서 메시지를 보내기 전에 맞춤법 검사

Mac용 Office 응용 프로그램은 입력 시 잠정 맞춤법과 문법 오류를 자동으로 검사합니다. 문서를 모두 작성할 때까지 기다렸다가 맞춤법과 문법을 검사하려는 경우 자동 검사를 해제하거나 맞춤법 및 문법 검사를 모두 한번에 실행할 수 있습니다.

Word

입력할 때 맞춤법 및 문법을 자동으로 검사합니다.

Word에서는 잠재적 맞춤법 오류는 빨간색 물결선으로 표시되고 잠재적 문법 오류는 초록색 물결선으로 표시됩니다.

팁: 맞춤법 또는 문법 오류가 표시되지 않으면 자동 맞춤법 및 문법 검사를 설정해야 할 수 있으며 이는 다음의 절차에서 설명합니다.

맞춤법 또는 문법 오류가 표시되면 Control 키를 누른 채 해당 단어 또는 구를 클릭하고 옵션 중 하나를 선택합니다.

Word에서 단어를 맞춤법이 잘못된 것으로 잘못 표시하였으나 해당 단어를 사전에 추가하여 나중에 Word에서 제대로 인식하도록 하려는 경우 맞춤법 검사 사전에서 단어 추가 또는 편집을 참조하세요.

  1. Word 메뉴에서 기본 설정 > 맞춤법 및 문법 검사를 클릭합니다.

  2. 맞춤법 및 문법 검사 대화 상자의 맞춤법 검사에서 입력할 때 자동으로 맞춤법 검사 확인란를 선택하거나 선택을 취소합니다.

  3. 문법 검사에서 입력할 때 자동으로 문법 검사 확인란을 선택하거나 선택을 취소합니다.

  4. 대화 상자를 닫아 변경 내용을 저장합니다.

  1. 검토 탭에서 맞춤법 및 문법 검사를 클릭합니다.

  2. Word에서 잠재적인 오류를 발견하는 경우 맞춤법 및 문법 검사 대화 상자가 열리며 맞춤법 오류는 빨간색 텍스트로, 문법 오류는 녹색 텍스트로 표시됩니다.

  3. 오류를 수정하려면 다음 중 하나를 수행합니다.

    • 상자에 수정 사항을 입력하고 변경을 클릭합니다.

    • 추천 단어 목록에서 사용할 단어를 클릭한 다음 변경을 클릭합니다.

    오류를 건너뛰려면 다음 중 하나를 수행합니다.

    • 오류의 해당 인스턴스만 건너뛰려면 무시를 클릭합니다.

    • 오류의 모든 인스턴스를 건너뛰려면 모두 무시를 클릭합니다.

    • 문법 오류의 경우 다음 문장을 클릭하여 해당 오류 인스턴스를 건너뛰고 다음 오류로 이동합니다.

    모든 문서에서 철자가 잘못된 단어를 건너뛰려면 추가를 클릭하여 해당 단어를 사전에 추가합니다. 이 기능은 철자가 잘못된 단어에만 작동합니다. 사전에 사용자 지정 문법을 추가할 수는 없습니다.

  4. 오류를 수정하거나, 무시하거나, 건너뛰면 Word가 다음 오류로 이동합니다. Word에서 문서 검토를 완료한 경우 맞춤법 및 문법 검사가 완료되었다는 메시지가 표시됩니다.

  5. 확인을 클릭하여 문서로 돌아갑니다.

Word에서 이전에 무시하도록 지정한 맞춤법 및 문법 문제를 검사하도록 무시된 단어 및 문법 목록을 지우거나 재설정할 수 있습니다.

참고: 무시된 단어 및 문법 목록을 초기화하는 경우 현재 열려 있는 문서에 대해서만 목록이 지워집니다. 다른 문서에서 무시하도록 지정한 맞춤법 또는 문법 문제는 영향을 받지 않습니다.

  1. 확인해야 하는 문서를 엽니다.

  2. 도구 메뉴에서 맞춤법 및 문법을 가리킨 다음 무시된 단어와 문법 재설정을 클릭합니다.

    Word에서 무시하는 단어 및 문법 목록을 지우려면 무시된 단어와 문법 재설정을 클릭합니다.

    Word에서 맞춤법 검사기 및 문법 검사기 재설정 작업에 대한 경고가 표시됩니다.

    Word에서 예를 클릭하여 이전에 무시하도록 지정한 맞춤법 및 문법 검사를 수행합니다.
  3. Yes를 클릭하여 계속합니다.

  4. 검토 탭을 클릭한 다음 맞춤법 및 문법을 클릭하여 맞춤법 및 문법을 검사합니다.

Outlook

입력할 때 맞춤법 및 문법을 자동으로 검사합니다.

기본적으로 Outlook은 입력할 때 맞춤법 오류를 검사합니다. Outlook은 빨간색 파선 밑줄을 사용하여 잠정 맞춤법 오류를 나타내고 잠정 문법 오류를 표시하는 데는 녹색 파선을 이용합니다.

  1. 파선 밑줄이 표시된 단어가 보이면 Control 키를 누른 채 해당 단어 또는 어구를 클릭하고 옵션 중 하나를 선택합니다.

  2. 바로 가기 메뉴에서 다음 중 하나를 수행합니다.

    • 바로 가기 메뉴 위쪽의 유사어 중 하나를 클릭합니다.

    • 단어의 한 인스턴스를 무시하려면 맞춤법 무시를 클릭합니다.

    • 맞춤법 사전에 단어를 추가하려면 맞춤법 학습을 클릭합니다.

전자 메일 메시지를 연 후 다음을 실행합니다.

  • Outlook에서 맞춤법 오류를 자동으로 수정하게 하려면 Outlook 메뉴에서 기본 설정을 클릭합니다. 개인 설정에서 맞춤법 및 문법을 클릭합니다. 입력할 때맞춤법확인란 옆에 있는 상자를 클릭합니다.

  • 자동 문법 검사를 켜거나 끄려면 Outlook 메뉴에서 기본 설정을 클릭합니다. 개인 설정에서 맞춤법 및 문법을 클릭합니다. 입력할 때 맞춤법 확인 옆에 있는 상자를 클릭합니다.

유형 기본 설정으로 맞춤법 검사

메시지 또는 다른 항목 작성을 마친 후 모든 맞춤법 및 문법 문제를 동시에 수정할 수 있습니다.

  1. 편집 메뉴에서 맞춤법 및 문법을 가리킨 다음 맞춤법 및 문법을 클릭합니다.

  2. 다음 중 하나를 실행합니다.

    • 추천 단어 목록에서 사용할 단어를 클릭하거나 상단의 상자에 새로운 맞춤법을 입력한 후 변경을 클릭합니다.

    • 이 단어를 건너뛰고 철자가 잘못된 다음 단어로 이동하려면 무시를 클릭합니다.

    • 맞춤법 사전에 단어를 추가하려면 추가를 클릭합니다.

팁: 다음 맞춤법 또는 문법 오류로 건너뛰는 바로 가기 키는 명령 + ;입니다.

PowerPoint

PowerPoint에서 맞춤법은 검사할 수 있지만 문법은 검사할 수 없습니다.

입력할 때 자동으로 맞춤법 검사

PowerPoint에서는 자동으로 맞춤법 오류를 검사하고 물결 모양의 빨간색 밑줄로 잠재적인 맞춤법 오류를 표시합니다.

팁: 맞춤법 오류가 표시되지 않으면 자동 맞춤법 검사를 설정해야 할 수 있으며 이는 다음의 절차에서 설명합니다.

맞춤법 오류가 표시되면 해당 단어 또는 구를 Ctrl+클릭하거나 마우스 오른쪽 단추로 클릭하고 추천 옵션 중 하나를 선택합니다.

  1. PowerPoint 메뉴에서 기본 설정 > 맞춤법 검사를 클릭합니다.

  2. 맞춤법 검사 대화 상자에서 입력할 때 자동으로 맞춤법 검사 확인란을 선택하거나 선택을 취소합니다.

  1. 검토 탭에서 맞춤법 검사를 클릭합니다.

  2. PowerPoint에서 잠재적 오류를 발견하면 맞춤법 검사 창이 열리고 맞춤법 오류가 표시됩니다.

  3. 오류를 수정하려면 다음 중 하나를 수행합니다.

    • 슬라이드에서 오류를 수정합니다.

    • 맞춤법 검사 창에서 추천 단어 중 하나를 클릭한 다음 변경을 클릭합니다.

    오류를 건너뛰려면 다음 중 하나를 수행합니다.

    • 오류의 해당 인스턴스만 건너뛰려면 무시를 클릭합니다.

    • 오류의 모든 인스턴스를 건너뛰려면 모두 무시를 클릭합니다.

    • 모든 문서에서 철자가 잘못된 단어를 건너뛰고 해당 단어를 사전에 추가하려면 추가를 클릭합니다.

  4. 오류를 수정하거나, 무시하거나, 건너뛰면 PowerPoint가 다음 오류로 이동합니다. PowerPoint에서 프레젠테이션 검토를 완료한 경우 맞춤법 검사가 완료되었다는 메시지가 표시됩니다.

  5. 확인을 클릭하여 프레젠테이션으로 돌아갑니다. 

Excel

Excel에서 맞춤법은 검사할 수 있지만 문법은 검사할 수 없습니다.

한 번에 맞춤법 모두 검사

  1. 검토 탭에서 맞춤법 검사를 클릭합니다.

    참고: 맞춤법 오류가 감지되지 않거나 추가하려는 단어가 이미 사전에 들어 있으면 맞춤법 검사 대화 상자가 열리지 않습니다.

  2. 다음 중 하나를 실행합니다.

    작업

    방법

    단어 변경

    추천 단어에서 사용할 단어를 클릭하고 변경을 클릭합니다.

    이 문서에서 이 단어의 모든 항목 변경

    추천 단어에서 사용할 단어를 클릭하고 모두 변경을 클릭합니다.

    이 단어를 건너뛰고 철자가 잘못된 다음 단어로 이동

    한 번 건너뛰기를 클릭합니다.

    이 문서에서 이 단어의 모든 항목을 건너뛰고 철자가 잘못된 다음 단어로 이동

    모두 무시를 클릭합니다.

참고 항목

다른 언어로 맞춤법 및 문법 검사

추가 도움이 필요하신가요?

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×