Visio 셰이프에 데이터 추가

Visio 셰이프에 데이터 추가

Visio에서 셰이프는 관련 데이터를 포함할 수 있습니다. 셰이프 데이터라고도 하는 이 데이터는 세부 정보를 표시할 때 유용합니다. 예를 들어, 다이어그램을 텍스트로 채우지 않고도 셰이프 데이터에 네트워크 다이어그램의 프로세스나 각 장비에 단계를 표시할 수 있습니다.

셰이프에 데이터를 직접 추가하거나 또는 (Visio Professional을(를) 사용하는 경우) 외부 데이터 원본의 데이터를 도형에 연결할 수 있습니다. 이 문서에서는 셰이프에 직접 데이터를 추가 하는 방법에 대해 설명합니다. 

다음 문서에서는 외부 데이터 원본으로 작업 하는 방법에 대해 설명합니다.

셰이프 데이터 보기

Visio 개체의 셰이프 데이터를 보려면 다음 작업을 수행합니다.

  • 셰이프를 마우스 오른쪽 단추로 클릭한 다음 데이터 > 셰이프 데이터를 선택합니다.

    셰이프를 마우스 오른쪽 단추로 클릭하고 데이터를 선택한 다음, 셰이프 데이터를 선택합니다.

    셰이프 데이터 창이 열립니다.

선택한 셰이프에 데이터 추가

이미 드로잉에 있는 셰이프에 데이터를 추가하려면 먼저 데이터 필드를 셰이프에 추가한 다음 값을 추가합니다.

선택한 셰이프에 데이터 필드를 추가하려면

  1. 보기 탭의 표시 그룹에서 작업창을 클릭한 다음 셰이프 데이터를 클릭합니다.

    셰이프 데이터 작업창 표시가 토글됩니다.

  2. 데이터를 추가할 셰이프를 선택합니다.

  3. 선택 영역을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 데이터를 가리킨 다음 셰이프 데이터 정의를 클릭합니다.

  4. 셰이프 데이터 정의 대화 상자에서 새로 만들기를 클릭한 후 다음을 실행합니다.

    • 레이블 입력란에 새 필드의 이름을 입력합니다.

    • 형식 목록에서 포함할 새 필드의 데이터 형식을 선택합니다.

    • 서식 목록에서 데이터를 표시할 서식을 선택합니다. 서식 옵션은 선택한 데이터 형식에 따라 달라집니다.

    • 필드에 데이터를 추가하는 사용자에게 텍스트 프롬프트를 표시하려는 경우 프롬프트 상자에 원하는 텍스트를 입력합니다. 셰이프 데이터 창에 있는 필드 위에 마우스 포인터를 두면 텍스트가 나타납니다.

  5. 확인을 클릭합니다.

데이터 필드에 값을 추가하려면

  • 셰이프 데이터 창에서 각 셰이프를 한 번에 하나씩 선택하고 데이터 필드에 값을 입력합니다.

    셰이프 데이터 창의 내용에는 선택한 셰이프에 대한 데이터만 표시됩니다.

재사용 가능한 데이터 필드 집합 만들기

각 셰이프에 대해 개별적으로 데이터 필드를 만들 필요는 없습니다. 즉, 데이터 필드 집합을 만든 후 드로잉에서 선택된 모든 셰이프 및 드로잉에 나중에 배치하는 셰이프에 적용할 수 있습니다.

재사용 가능한 데이터 필드 집합을 만들려면

  1. 보기 탭의 표시 그룹에서 작업창을 클릭한 다음 셰이프 데이터를 클릭합니다.

    셰이프 데이터 작업창 표시가 토글됩니다.

  2. 셰이프 데이터 작업창의 아무 곳이나 마우스 오른쪽 단추로 클릭한 다음 셰이프 데이터 집합을 클릭합니다.

  3. 셰이프 데이터 집합 작업창에서 추가를 클릭합니다.

  4. 셰이프 데이터 집합 추가 대화 상자에서 데이터 집합의 이름을 입력합니다.

  5. 새 집합 만들기를 선택한 다음 확인을 클릭합니다.

    데이터 집합은 셰이프 데이터 집합 창의 이름 열에 나타납니다.

  6. 새 데이터 집합을 선택한 다음 정의를 클릭합니다.

  7. 셰이프 데이터 정의 대화 상자에서 셰이프 데이터 집합의 필드를 정의합니다.

  8. 다른 필드를 만들려면 새로 만들기를 클릭합니다.

  9. 데이터 필드를 모두 정의했으면 확인을 클릭합니다.

  10. 드로잉에서 선택한 셰이프에 데이터 집합을 적용하려면 셰이프 데이터 집합 작업창에서 집합을 선택한 다음 적용을 클릭합니다.

데이터 집합을 적용한 셰이프 중 하나에서 새 필드를 보려면 해당 셰이프를 선택한 다음 셰이프 데이터 창을 살펴봅니다.

마스터 셰이프에 데이터 필드 추가

특정 셰이프를 사용할 때마다 같은 셰이프 데이터 집합을 추가하려는 경우 마스터 셰이프 복사본을 데이터 필드에 추가하면 시간을 절약할 수 있습니다. 예를 들어 이름, 직원 번호 등의 데이터 필드를 직원 셰이프의 마스터에 추가할 수 있습니다.

사용자 지정 스텐실에 셰이프 복사본을 만들려면

  1. 셰이프 창에서 마스터 셰이프를 마우스 오른쪽 단추로 클릭하고 내 셰이프에 추가를 가리킨 다음 중 하나를 실행합니다.

    • 새 스텐실에 마스터 셰이프를 추가하려면 새 스텐실에 추가를 클릭합니다.

    • 기존 사용자 지정 스텐실에 마스터 셰이프를 추가하려면 기존 스텐실에 추가를 클릭합니다.

  2. 다른 이름으로 저장 대화 상자에서 새 스텐실의 이름을 입력한 다음 저장을 클릭합니다.

  3. 셰이프 창에서 다른 셰이프를 클릭하고 내 셰이프를 가리킨 다음 복사된 마스터 셰이프가 들어 있는 스텐실을 클릭합니다.

사용자 지정 스텐실에서 새 마스터를 편집하려면

  1. 새 스텐실의 제목 표시줄을 마우스 오른쪽 단추로 클릭한 다음 바로 가기 메뉴에서 스텐실 편집을 클릭합니다.

  2. 방금 스텐실에 추가한 셰이프를 마우스 오른쪽 단추로 클릭하고 마스터 편집을 가리킨 다음 마스터 셰이프 편집을 클릭합니다.

  3. 셰이프의 편집 창에서 해당 셰이프를 마우스 오른쪽 단추로 클릭하고 데이터를 가리킨 다음 셰이프 데이터 정의를 클릭합니다.

  4. 셰이프 데이터 정의 대화 상자에서 필드의 이름을 입력하고 원하는 기타 정보를 입력합니다. 예를 들어 데이터 형식을 변경하거나 셰이프 프롬프트를 추가할 수 있습니다.

  5. 다른 필드를 만들려면 새로 만들기를 클릭하고 이전 단계를 반복합니다.

  6. 데이터 필드 정의를 마쳤으면 확인을 클릭합니다.

  7. 마스터 셰이프의 편집 창을 닫으려면 보기 탭의 그룹에서 계단식을 클릭하고 마스터 셰이프의 창을 선택한 다음 위 모서리에 있는 닫기 단추(X)를 클릭합니다.

  8. 셰이프를 업데이트할 것인지 묻는 메시지가 표시되면 를 클릭합니다.

  9. 셰이프 창에서 스텐실을 마우스 오른쪽 단추로 클릭하고 저장을 클릭합니다.

데이터 필드를 삭제하려면

  1. 삭제할 데이터 필드가 있는 셰이프를 선택합니다.

  2. 셰이프 데이터 창의 아무 곳이나 마우스 오른쪽 단추로 클릭한 다음 셰이프 데이터 정의를 클릭합니다.

  3. 셰이프 데이터 정의 대화 상자의 속성에서 삭제할 데이터 필드를 선택하고 삭제를 클릭한 다음 확인을 클릭합니다.

웹용 Visio에서 셰이프에 데이터를 추가할 수는 없지만, Visio 데스크톱 앱에서 셰이프에 이미 추가된 데이터는 볼 수 있습니다. 유사히, Visio 데스크톱 앱에서 셰이프에 하이퍼링크를 추가했다면 해당 하이퍼링크 또한 보이고 클릭하여 이동할 수 있습니다.

셰이프 데이터 보기

  1. 보려는 다이어그램을 엽니다.

  2. 셰이프 정보 셰이프 정보 명령 를 선택합니다.

  3. 셰이프 데이터를 보려면 해당 셰이프를 선택합니다.

    하이퍼링크가 있는 셰이프 데이터의 예

참고 항목

웹용 Visio 도움말

웹용 Visio에서 다이어그램 보기, 만들기 및 편집

추가 도움이 필요하신가요?

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×