XML 데이터 가져오기

이전에 Xml 맵을 만든경우이를 사용 하 여 매핑된 셀에 xml 데이터를 가져올 수 있지만 xml 지도 없이 xml 데이터를 가져오는 방법에 대 한 몇 가지 방법과 명령도 있습니다.

XML 맵이 있는 경우이 작업을 수행 하 여 XML 데이터를 매핑된 셀로 가져옵니다.

  1. XML 맵에서 매핑된 셀 중 하나를 선택 합니다.

  2. 개발자 > 가져오기를클릭 합니다.

    개발 도구 탭이 표시되지 않을 경우 개발 도구 탭 표시를 참조하세요.

  3. Xml 가져오기 대화 상자에서 가져올 xml 데이터 파일 (.xml)을 찾아 선택 하 고 가져오기를클릭 합니다.

XML 데이터를 가져오는 다른 방법

문제에 대 한 자세한 내용은이 문서의 뒷부분에 나오는 XML 데이터 가져오기와 관련 된 일반적인 문제 를 참조 하세요.

Xml 데이터 파일을 XML 표로 가져오기

  1. 개발자 > 가져오기를클릭 합니다.

    개발 도구 탭이 표시되지 않을 경우 개발 도구 탭 표시를 참조하세요.

  2. Xml 가져오기 대화 상자에서 가져올 xml 데이터 파일 (.xml)을 찾아 선택 하 고 가져오기를클릭 합니다.

    XML 데이터 파일이 스키마를 참조 하지 않으면 Excel에서 XML 데이터 파일의 스키마를 유추 합니다.

  3. 데이터 가져오기 대화 상자에서 다음 중 하나를 수행 합니다.

    1. 기존 워크시트에서 xml 표 를 선택 하 여 xml 데이터 파일의 내용을 워크시트의 지정 된 셀 위치에 있는 xml 표로 가져옵니다.

    2. 새 워크시트에서 xml 표 를 선택 하 여 파일의 내용을 새 워크시트의 A1 셀부터 xml 표로 가져옵니다. Xml 데이터 파일의 스키마가 Xml 원본 작업창에 표시 됩니다.

  4. XML 데이터 파일이 스키마를 참조 하지 않으면 Excel에서 XML 데이터 파일의 스키마를 유추 합니다.

  5. XML 데이터 (예: 데이터 바인딩, 형식, 레이아웃)의 동작을 제어 하려면 속성을 클릭 하 여 xml 맵 속성 대화 상자를 표시 합니다. 예를 들어 기본적으로 데이터를 가져올 때 매핑된 범위의 기존 데이터는 덮어쓰므로이를 변경할 수 있습니다.

여러 XML 데이터 파일 가져오기

  1. 매핑된 셀을 선택 하 여 여러 XML 파일을 매핑된 셀 집합 하나로 가져옵니다.

    여러 개의 XML 파일을 여러 개의 매핑된 셀 집합으로 가져오려면 워크시트에서 매핑되지 않은 모든 셀을 클릭 합니다.

  2. 개발자 > 가져오기를클릭 합니다.

    개발 도구 탭이 표시되지 않을 경우 개발 도구 탭 표시를 참조하세요.

  3. Xml 가져오기 대화 상자에서 가져올 xml 데이터 파일 (.xml)을 찾아 선택 합니다.

    • 파일이 인접해 있으면 Shift 키를 누른 채 목록의 첫 번째 파일과 마지막 파일을 클릭 합니다. XML 파일의 모든 데이터는 매핑된 셀에 가져오고 추가 됩니다.

    • 파일이 인접해 있지 않으면 Ctrl 키를 누른 채 목록에서 가져올 각 파일을 클릭 합니다.

  4. Import(가져오기)를 클릭합니다.

    인접 하지 않은 파일을 선택한 경우 가져오기 <파일 이름> 대화 상자가 나타납니다. 각 파일에 대해 가져오는 XML 데이터 파일에 해당 하는 XML 맵을 선택 합니다.

    아직 가져오지 않은 모든 선택한 파일에 대해 단일 맵을 사용 하려면 이 스키마의 모든 선택 된 파일에이 XML 맵 사용을 선택 합니다.

여러 XML 데이터 파일을 외부 데이터로 가져오기

같은 네임 스페이스를 사용 하지만 XML 스키마가 다른 여러 XML 파일을 가져오려면 Xml 데이터 가져오기 명령을 사용할 수 있습니다. Excel에서는 가져오는 각 XML 데이터 파일에 대해 고유한 XML 맵을 만듭니다.

참고: 네임 스페이스를 정의 하지 않는 여러 XML 파일을 가져오는 경우 이러한 XML 파일은 동일한 네임 스페이스를 사용 하는 것 처럼 처리 됩니다.

  1. Microsoft 365 구독이 있는 Excel을 사용 하는 경우 XML의파일 >에서 데이터 > 가져오기> 클릭 합니다.

    Excel 2016 또는 이전 버전을 사용 하는 경우 다른 원본의데이터 > XML 데이터 가져오기에서> 클릭 합니다.

  2. 가져올 XML 데이터 파일 (.xml)이 있는 드라이브, 폴더 또는 인터넷 위치로 이동 합니다.

  3. 파일을 선택하고 열기를 클릭합니다.

  4. 데이터 가져오기 대화 상자에서 다음 중 하나를 수행 합니다.

    • 기존 워크시트의 XML 표    파일의 내용을 새 워크시트의 새 XML 표로 가져옵니다. XML 데이터 파일이 스키마를 참조 하지 않으면 Excel에서 XML 데이터 파일의 스키마를 유추 합니다.

    • 기존 워크시트    Xml 태그를 열 머리글로 표시 하는 행과 열이 있는 2 차원 테이블에서 열 머리글 아래의 행에 있는 데이터를 가져옵니다. 첫 번째 요소 (루트 노드)는 제목 처럼 사용 되며 지정 된 셀 위치에 표시 됩니다. 나머지 태그는 두 번째 행에서 사전순으로 정렬 됩니다. 이 경우 Excel에서 스키마를 추론 하지 않으므로 XML 맵을 사용할 수 없습니다.

    • 새 워크시트    Excel이 통합 문서에 새 워크시트를 추가 하 고 새 워크시트의 왼쪽 위 모서리에 XML 데이터를 자동으로 배치 합니다. XML 데이터 파일이 스키마를 참조 하지 않으면 Excel에서 XML 데이터 파일의 스키마를 유추 합니다.

  5. XML 데이터 (예: 데이터 바인딩, 서식, 레이아웃)의 동작을 제어 하려면 속성을 클릭 하 여 xml 맵 속성 대화 상자를 표시 합니다. 예를 들어 기본적으로 데이터를 가져올 때 매핑된 범위의 기존 데이터를 덮어쓰게 되지만이를 변경할 수 있습니다.

XML 데이터 파일을 열어 데이터 가져오기

  1. 파일 > 열기를 클릭합니다.

    Excel 2007를 사용 하는 경우 Microsoft Office 단추 Office 단추 이미지 클릭 하 > 엽니다.

  2. 열기 대화 상자에서 열려는 파일이 있는 드라이브, 폴더 또는 인터넷 위치를 클릭 합니다.  

  3. 파일을 선택하고 열기를 클릭합니다.

  4. XML 가져오기 대화 상자가 표시 되는 경우에는 다음 옵션 중 하나를 클릭할 수 있도록 하나 이상의 확장 가능 스타일 시트 언어 변환 (XSLT) 스타일 시트가 열려 있는 파일에서 참조 됩니다.

    • 스타일 시트를 적용 하지 않고 파일 열기    Xml 태그를 열 머리글로 표시 하는 행과 열이 있는 2 차원 테이블에서 열 머리글 아래의 행에 있는 데이터를 가져옵니다. 첫 번째 요소 (루트 노드)는 제목 처럼 사용 되며 지정 된 셀 위치에 표시 됩니다. 나머지 태그는 두 번째 행에서 사전순으로 정렬 됩니다. 이 경우 Excel에서 스키마를 추론 하지 않으므로 XML 맵을 사용할 수 없습니다.

    • 다음 스타일 시트가 적용 된 파일을 엽니다 (하나 선택).    적용 하려는 스타일 시트를 선택 하 고 확인을 클릭 합니다. XML 데이터는 선택한 스타일 시트에 따라 서식이 지정 됩니다.

      참고: Excel에서 XML 데이터가 읽기 전용으로 열리므로 excel 매크로 사용 통합 문서 파일 형식 (.xlsm)에 원래 원본 파일을 실수로 저장 하지 않습니다. 이 경우 Excel에서 스키마를 추론 하지 않으므로 XML 맵을 사용할 수 없습니다.

  5. Xml 열기 대화 상자가 표시 되는 경우 xml 파일에 XSLT 스타일 시트 참조가 없는 것입니다. 파일을 열려면 다음 옵션 중 하나를 클릭 합니다.

    • Xml 표 를 클릭 하 여 새 통합 문서에 xml 표를 만듭니다.

      파일의 내용을 XML 테이블로 가져옵니다. XML 데이터 파일이 스키마를 참조 하지 않으면 Excel에서 XML 데이터 파일의 스키마를 유추 합니다.

    • 읽기 전용 통합 문서로를클릭 합니다.

      Xml 태그를 열 머리글로 표시 하는 행과 열이 있는 2 차원 테이블에서 열 머리글 아래의 행에 있는 데이터를 가져옵니다. 첫 번째 요소 (루트 노드)는 제목 처럼 사용 되며 지정 된 셀 위치에 표시 됩니다. 나머지 태그는 두 번째 행에서 사전순으로 정렬 됩니다. 이 경우 Excel에서 스키마를 추론 하지 않으므로 XML 맵을 사용할 수 없습니다.

      Excel에서 XML 데이터가 읽기 전용으로 열리므로 excel 매크로 사용 통합 문서 파일 형식 (.xlsm)에 원래 원본 파일을 실수로 저장 하지 않습니다. 이 경우 Excel에서 스키마를 추론 하지 않으므로 XML 맵을 사용할 수 없습니다.

    • XML 원본 작업창 사용을클릭 합니다.

      Xml 데이터 파일의 스키마가 Xml 원본 작업창에 표시 됩니다. 그런 다음 스키마의 요소를 워크시트로 끌어 해당 요소를 워크시트에 매핑할 수 있습니다.

      XML 데이터 파일이 스키마를 참조 하지 않으면 Excel에서 XML 데이터 파일의 스키마를 유추 합니다.

XML 데이터 가져오기와 관련 한 일반적인 문제

Excel에서 XML 맵에 따라 데이터의 유효성을 검사할 수 없는 경우 Xml 가져오기 오류 대화 상자가 표시 됩니다. 이 대화 상자에서 세부 정보 를 클릭 하 여 각 오류에 대 한 추가 정보를 확인 합니다. 다음 표에는 몇 가지 일반적인 가져오기 오류가 나와 있습니다.

오류

무슨 일이 있었나요

스키마 유효성 검사 실패

XML 맵 속성 대화 상자에서 가져오기 및 내보내기에 대 한 데이터 유효성 검사 를 클릭 하면 데이터를 가져왔지만 지정 된 XML 맵에 대해 데이터의 유효성을 검사할 수 없습니다.

일부 데이터를 텍스트로 가져왔습니다.

가져온 데이터 중 일부 또는 전체가 선언 된 데이터 형식에서 텍스트로 변환 되었습니다. 계산에이 데이터를 사용 하려면 데이터를 텍스트에서 숫자나 날짜로 변환 해야 합니다. 예를 들어 date 데이터 형식으로 변환 될 때까지 YEAR 함수에서는 text로 변환 된 날짜 값이 의도 한 대로 작동 하지 않습니다. 다음과 같은 경우 Excel에서 데이터를 텍스트로 변환 합니다.

  • 데이터가 Excel에서 지원 되지 않는 형식으로 되어 있습니다.

  • 데이터가 XSD 데이터 형식의 Excel 내부 표시와 호환 되지 않습니다. 이 문제를 해결 하려면 각 데이터 형식 선언을 검사 하 여 xml 데이터를 XML 스키마에 따라 유효한 지 확인 합니다.

XML 구문 분석 오류

XML 파서는 지정 된 XML 파일을 열 수 없습니다. XML 파일에 구문 오류가 없고 XML이 제대로 구성 되어 있는지 확인 합니다.

데이터에 해당 하는 XML 맵을 찾을 수 없음

이 문제는 가져올 XML 데이터 파일을 두 개 이상 선택 하 고 Excel에서 파일 중 하나에 대해 일치 하는 XML 맵을 찾을 수 없는 경우에 발생 합니다. 대화 상자의 제목 표시줄에 이름이 지정 된 파일의 경우 먼저 적절 한 스키마를 가져온 다음 파일을 다시 가져와 봅니다.

데이터에 맞게 XML 표의 크기를 조정할 수 없음

XML 표에 데이터를 가져오거나 추가 하는 방법으로 행을 추가할 수 있지만 테이블에는 확장할 공간이 없습니다. XML 표는 아래쪽 에서만 확장할 수 있습니다. 예를 들어 xml 표 바로 아래에 그림 또는 다른 표 등의 개체가 있을 수 있습니다. 또는 XML 표를 확장 하기 위해 Excel 행의 제한인 1048576을 초과 하 게 됩니다. 이 문제를 해결 하려면 워크시트의 테이블 및 개체를 다시 정렬 하 여 XML 표를 아래쪽에서 확장할 수 있도록 합니다.

지정 된 XML 파일이 스키마를 참조 하지 않는 경우

열려는 XML 파일이 XML 스키마를 참조 하지 않는 경우 파일에 있는 XML 데이터를 사용 하려면 Excel에서 XML 파일의 내용에 따라 스키마가 필요 합니다. 해당 스키마가 올바르지 않거나 불충분 한 경우 통합 문서에서 제거 합니다. 그런 다음 xml 스키마 파일을 만들고 xml 데이터 파일이 스키마를 참조 하도록 XML 데이터 파일을 편집 합니다. 자세한 내용은 xml 요소를 Xml 맵의 셀에 매핑을 참조 하세요.

참고: Excel 유추한 스키마는 별도의 XML 스키마 데이터 파일 (.xsd)로 내보낼 수 없습니다. Xml 스키마 편집기를 만드는 데 사용 되는 다른 메서드는 필요 하지 않을 수도 있습니다 .이에 대 한 편리한 액세스 권한 또는 사용법을 모를 수 있습니다.

Excel에서 통합 문서에서 만든 스키마를 제거 하려면 다음 단계를 따르세요.

  1. 개발 도구 > 원본을 클릭합니다.

    개발 도구 탭의 XML 명령

    개발 도구 탭이 표시되지 않을 경우 개발 도구 탭 표시를 참조하세요.

  2. Xml 원본 작업창에서 xml 맵을클릭 합니다.

  3. Xml 맵 대화 상자에서 만든 Xml 지도 Excel을 클릭 하 고 삭제를 클릭 합니다.

같은 네임 스페이스를 사용 하지만 여러 스키마가 예상 대로 작동 하지 않는 여러 XML 파일 가져오기

여러 XML 데이터 파일 및 XML 스키마를 사용 하 여 작업 하는 경우 일반적으로 각 스키마에 대 한 XML 맵을 만들고 원하는 요소를 매핑한 다음 각 XML 데이터 파일을 적절 한 XML 맵으로 가져옵니다. 가져오기 명령을 사용 하 여 동일한 네임 스페이스의 여러 xml 파일을 여는 경우 하나의 xml 스키마만 사용할 수 있습니다. 이 명령을 사용 하 여 동일한 네임 스페이스와 다른 스키마를 사용 하는 여러 XML 파일을 여는 경우 예기치 않은 결과가 표시 될 수 있습니다. 예를 들어 데이터를 덮어쓰거나 파일이 열리지 않을 수 있습니다.

같은 네임 스페이스와 다른 XML 스키마를 사용 하는 여러 XML 파일을 가져오려면 Xml 데이터 가져오기 명령 ( 기타 원본에서데이터 > 클릭)을 사용 합니다. 이 명령을 사용 하면 동일한 네임 스페이스의 여러 XML 파일이 여러 XML 스키마를 사용할 수 있습니다. Excel에서는 가져올 각 XML 데이터 파일에 대해 고유한 XML 맵을 만듭니다.

참고: 네임 스페이스를 정의 하지 않는 여러 XML 파일을 가져오는 경우 이러한 XML 파일은 동일한 네임 스페이스를 사용 하는 것 처럼 처리 됩니다.

개발 도구 탭 표시

개발 도구 탭이 나타나지 않는 경우 다음을 실행하여 표시합니다.

  • Excel 2013 및 Excel 2010:

    1. 파일 > 옵션을 클릭합니다.

    2. 리본 사용자 지정 범주를 클릭합니다.

    3. 기본 탭에서 개발 도구 확인란을 선택한 다음 확인을 클릭합니다.

  • Excel 2007:

    1. Microsoft Office 단추 Office 단추 이미지 > Excel 옵션을 클릭 합니다.

    2. 기본 설정 범주를 클릭합니다.

    3. Excel에서 가장 많이 사용하는 옵션에서 리본 메뉴에 개발 도구 탭 표시 확인란을 선택한 다음 확인을 클릭합니다.

참고 항목

Excel에서 XML 보기

XML 요소를 XML 맵의 셀에 매핑

XML 데이터 내보내기

참고:  이 페이지는 자동화를 통해 번역되었으며 문법 오류나 부정확한 설명을 포함할 수 있습니다. 이 목적은 콘텐츠가 사용자에게 유용하다는 것입니다. 정보가 도움이 되는지 알려주세요. 참조할 수 있는 영문 문서가 여기 있습니다.

Office 기술 확장
교육 살펴보기
새로운 기능 우선 가져오기
Office Insider 참여

이 정보가 유용한가요?

의견 주셔서 감사합니다!

피드백을 주셔서 감사합니다. Office 지원 에이전트와 연락하는 것이 도움이 될 것 같습니다.

×